Avisos
Vaciar todo

No funciona las url amigables, no me quita el index.php?  

 
Ginés
 Ginés
Reputable Member

Buenos dias.

Llevo un par de dias probando el tema de las url amigables, ahora las tengo activadas en mi joomla, pero repasando los videotutoriales de la tienda del tomate encuentro que existen muchas más posibilidades, como quitar por ejemplo el index.php? a la dirección del navegador y también incluir html.

Bién siguiendo instrucciones de los videos y manuales, se consigue renombrando el htacess.txt a .htacess y con el web.config.txt igual.

Yo realizo estos pasos y no me marcha, vas a cualqueir sección y en el navegador aparece la dirección bién, sin el index.php y con html al final, pero la página en cuestión no se carga.

También he probado con la herramienta sh404SEF, que también tiene sus buenos capitulos en la tienda del tomate, pero igual, activando esas posibilidades desde el propio módulo, como quedan anuladas las que vienen por defecto en joomla tampoco marcha.

¿Sabeis a que puede ser debido esto?

Trabajo con joomla 1.7 con una plantilla de gavick, la gk_corporate2

Graciaas de antemano.

Citar
Respondido : 16/01/2012 11:37 am
David Noguera
 David Noguera
Miembro Admin

Hola ginés,

envíanos, a que web te refieres?? Puedes pasarnos un enlace que se vea con errores??? Debería de funcionar sin problemas, estás en un servidor de Webempresa?? o en localhost??

Saludos

ResponderCitar
Respondido : 16/01/2012 12:05 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ginés
 Ginés
Reputable Member

Buenas David,

Estoy en un servidor de Webempresa, lo voy activar de nuevo pero momentaneamente ya que perjudica los usuarios, para que comprubes que no marcha con estas opciones activas.

Adjunto captura de pantalla con las opciones activas ahora mismo.

Y por ejemplo haciendo clic en cualquiera de las secciones de arriba en la web, cualquier verás que no carga la web.

Por ejemplo, Contacto, Foro, etc...

http://www.inveuro.es

http://www.inveuro.es/contacto.html

No se si tendrá algo que ver la versión php del servidor webempresa, ayer tuve un pequeño problemita que se soluciono por esta versión, tenia un modulo configurado y preparado para la versión del servidor php 5.3 xxxx y la del server de webempresa trabaja con la 5.2xxxx

Saludos y gracias.

ResponderCitar
Respondido : 16/01/2012 12:17 pm
David Noguera
 David Noguera
Miembro Admin

Hola,

no creo que tenga nada que ver con el tema de la versión de PHP.

Asegúrate de que el fichero htaccess.txt lo has renombrado correctamente a .htaccess, parece como si no tubieras fichero .htaccess..

Saludos

ResponderCitar
Respondido : 16/01/2012 12:22 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ginés
 Ginés
Reputable Member

Buenas de nuevo, si lo tengo renombrado, mira:

Saludos.

ResponderCitar
Respondido : 16/01/2012 12:26 pm
David Noguera
 David Noguera
Miembro Admin

OK, pero fíjate que ocupa 0 bytes... está vacío...

Bájate el fichero htaccess.txt de un joomla 1.7 nuevo y vuelve a subirlo y asegúrate de que no ocupa 0 bytes...

Saludos

ResponderCitar
Respondido : 16/01/2012 12:36 pm

Cursos Gratuitos WordPress

Ginés
 Ginés
Reputable Member

Gracias David, que detalle, es cierto no tenia tamaño ninguno.

He subido el original de la plantilla de Gavick y ahora sí.

Es necesario tener el htaccess.txt también o no?

Gracias de todo corazón, esta mañana avancé un montón en mis problemas.

ResponderCitar
Respondido : 16/01/2012 12:48 pm
David Noguera
 David Noguera
Miembro Admin

Hola ginés, no es necesario tener el htaccess.txt también, el que realmente vale es el fichero .htaccess..

Me alegro que te hayamos podido ayudar 🙂

Saludos

ResponderCitar
Respondido : 16/01/2012 12:56 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ginés
 Ginés
Reputable Member

Pues listo, gracias Davida, se puede cerrar el post, hoy sí, para ser lunes buen comienzo.

ResponderCitar
Respondido : 16/01/2012 12:58 pm