Pasos para actualizar de Joomla 2.5.28 a Joomla 3  

Página 1 / 2
 
Alceste
 Alceste
Noble Member

Hola,
Para actualizar de Joomla 2.5.28 a Joomla 3x, entiendo que hay varias cosas a actualizar:
- La plantilla Corporate Responsive de Shape 5 y sus componentes
- La versión de PHP?
- Los plugins o extensiones de terceros
-La versión de Joomla.
¿Por què orden debo proceder?

Planteé varios problemas que me encuentro para actualizar este tema hace tiempo en este hilo, puede que ahora haya más opciones...
https://www.webempresa.com/foro/32-Joomla-30/154880-Problema-para-actualizar-de-Joomla-2528-a-Joomla-371.html

Saludos y gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 28/11/2017 10:51 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

La plantilla Corporate Responsive de Shape 5 y sus componentes
Si, tienes que comprar que la plantilla es compatible con la version 3x de joomla y que dispones de su actualización, tienes que revisar también todas las extensiones que tienes instaladas y comprobar que todas tengan su actualización para 3x

La versión de PHP?
para el buen funcionamiento, joomla recomienda que tengas instalada la versión 7x, esto lo puedes realizar facilmente desde tu cuenta de cPanel -> Software -> Configurar PHP

El cambio de versión es reversible, es decir puedes volver a una versión inferior si ves que tienes problemas.

¿Por què orden debo proceder?
Lo primero es clonar la web y realizar os pasos en ese clon, con eso nunca tendrás la web en producción parada si pasa algún inconveniente.

Un avez en el clon, realiza la actualización de joomla y despues de su plantilla y extensiones.

Recuerda desactivar o mejo eliminar akeeba si lo utilizas para copias de seguridad y desactivar el plugin el plugin Remember Me

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 28/11/2017 11:33 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola,
Mantengo la web en porducción con Joomla 2.5
He creado el clon en otra carpeta, lo he instalado, lo he actualizado y en el backend aparentemente todo va bien. Pero cuando trato de acceder a la url me da este error:

500 - JHtmlBehavior::mootools not found

Por otro lado, cuando trato de instalar un componente de la plantilla Corporate Responsive de Shape 5 que el es "Shape5_Vertex4_Patch" me da este error:

JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración de Joomla!

Error
No se puede encontrar el paquete de instalación

Informo de la ruta y el nombre del clon:
Contenido solo visible a usuarios registrados

Saludos y graciss

ResponderCitar
Respondido : 29/11/2017 2:00 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes todas tus extensiones acutalizadas?, el problema es que la referencia a la librería de javascript mootools ya no existe en versiones 3.x de Joomla

Si tienes extensiones antiguas que estas usando desactivalas y verifica, ref:

https://forum.joomla.org/viewtopic.php?t=846854

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/11/2017 5:02 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola,
Parece que he conseguido actualizar bien y cargar la nueva versión de la plantilla. Pero me ocurrren varias cosas de las que no sé la razón:
- Solo me aparecen los iconos para escoger idiomás Español y Catalán (No aparece Frances e Inglés)
- En el menú inferior los items salen uno debajo de otro en vertical y antes estaba en horizontal
- En Joomla 3 me aparece Asociaciones Multiidioma vacío. En Joomla 2.5 no veo esta extensión.
-Al cargar la nueva plantilla me había dado un mensaje de error el instalador, algo parecido a esto: "Parece que está intentando instalar una plantilla que ya existe". Sin embargo funciona.

La url del clon con Joomla 3 es esta: (Podéis compararla con la que está en producción)
Contenido solo visible a usuarios registrados

Saludos y gracias

ResponderCitar
Respondido : 30/11/2017 9:40 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

Solo me aparecen los iconos para escoger idiomás Español y Catalán (No aparece Frances e Inglés)

.- Accede a Extensiones -> Gestor de Idiomas y comprueba que tengas instalados e activados los idiomas que quieres que se muestren ( Comprueba " sitio " Y " Contenido " )

En el menú inferior los items salen uno debajo de otro en vertical y antes estaba en horizontal

.- Añade lo siguiente al archivo custom.css que encontraras en templates/corporate_response/css/custom.css

#s5_bottom_menu_wrap .nav>li>a {
    display: inline-block;
}

En Joomla 3 me aparece Asociaciones Multiidioma vacío
Si puedes adjunta una captura de pantalla ya que no me queda claro lo que quieres indicar

Parece que está intentando instalar una plantilla que ya existe
Supongo que seria al actualizar la plantilla, es un aviso que no tiene importancia, solo te indica que la plantilla que estas instalando ya existe.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 30/11/2017 10:49 am

Cursos Gratuitos WordPress

Alceste
 Alceste
Noble Member

Hola,
Lo del menu inferior solucionado, gracias.
Pero sigue fallándo el tema idiomas. En idiomas solo aparecen los iconos de Español y Catalán. Faltan los de Inglés y Francés, aunque estan instalados y activos en sitio y contenido. A lo mejor es que debo ampliar el espacio del módulo para que quepan dos iconos más ahí?

Por otro lado, la web solo funciona bien en catalán. En Espsañol (que es el idioma predeterminado) funciona algunos items del menú principal, pero en los que tienen "hijos" items que cuelgan, como en Decoración o Ferretería, se quda en blanco y no carga nada.

Curiosamente había funcionado al principio y ahora no. Veo que la web del clon carga lenta. No sé si puede tener algo que ver con falta de espacio en el hosting...es que no sé qué más probar...

Por otro lado, es raro que me cargue el clon con https, ya que la web original en joomla 2.5 estaba en http solo...

url del clon:
Contenido solo visible a usuarios registrados

GracioAS

ResponderCitar
Respondido : 30/11/2017 1:59 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

A lo mejor es que debo ampliar el espacio del módulo para que quepan dos iconos más ahí?
No, lo estoy revisando en el inspector de la web y solo carga esos idiomas, tendrás que ver si hay alguna opción en la plantilla.

los que tienen "hijos" items que cuelgan, como en Decoración o Ferretería, se quda en blanco y no carga nada
Accede al menú y vuelve a generar ese item, es posible que al ser un clon las URL tengas que volver a generarlas.

No sé si puede tener algo que ver con falta de espacio en el hosting.
Si claro, cuanto mas espacio tengas ocupado en el disco mas lento te cargara la web y si a eso le sumamos que en la misma cuenta están corriendo 2 webs, estas consumen mas recursos.

es raro que me cargue el clon con https,
¿ Tienes instalado el certificado en el dominio " Contenido solo visible a usuarios registrados" ?, al pertenecer al mismo dominio si tienes instalado el certificado, el clon te cargara también por https.

Si ves que tienes problemas con los idiomas, lo mejor es que lo consultes con los desarrolladores, puede ser un tema de tu plantilla.

Una cosa que puedes probar es activar otra plantilla y ver si en esa plantilla te carga bien el selector.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 30/11/2017 2:50 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola,
No tengo muy claro como a qué te refieres con esto:

los que tienen "hijos" items que cuelgan, como en Decoración o Ferretería, se quda en blanco y no carga nada
Accede al menú y vuelve a generar ese item, es posible que al ser un clon las URL tengas que volver a generarlas.

Generar el item te refieres a volver a enlazar el item del menú con el artículo (Ya lo he intenado sin éxito), a generar nuevos módulos de menú... Puedes detallarlo un poco más. Gracias y disculpa mi torpeza
Saludos

ResponderCitar
Respondido : 01/12/2017 9:06 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Supongo que te refieres a que los ítems de menú en algunos casos no se despliegan, veo que se generan errors javascript, tal como se ve en la imagen.

De manera general es posible que otra extensión te este generando conflictos, tendrísa que ir desactivando extensiones hasta ver cual te causa el problema.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/12/2017 4:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola,
creo que esta no puede ser la causa, ya que con el idioma Català no se da este problema y supongo que si fuera un conflicto de Java Script se daría en todos los idiomas. De todos modos comprobaré
Saludos

ResponderCitar
Respondido : 02/12/2017 11:10 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

Generar el item te refieres a volver a enlazar el item del menú con el artículo
Si, me refiero a que edites el item de menú que no carga y que vuelvas a enlazarlo o mejor que lo elimines y que crees uno item nuevo.

Un saludo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 02/12/2017 11:19 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola,
Hay otra cosa rara. Los elementos del menu en francés estan despublicados, cuando voy a publicarlos me dice que están bloqueados. Los desbloqueo y sucede otra vez lo mismo. No me deja publicarlos. Sale este mensaje

Error
Fallo publicando 1 elemento del menú porque al menos uno de sus niveles superiores está despublicado o uno de sus niveles inferiores está bloqueado.

Saludos

ResponderCitar
Respondido : 02/12/2017 11:52 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

ese aviso puede venir si tienes asociado ese elemento de menú a otros menú ( idioma es, uk, etc... ) los menús asociados a ese elemento tienen que estar también activos.

Puedes probar a eliminar esa asociación y comprobar si puedes activarlo.

Un Saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 02/12/2017 2:51 pm

Cursos Gratuitos WordPress

Alceste
 Alceste
Noble Member

Hola,
Esto es muy raro. El problema está en que si publico un módulo en la posición left_inset o left en la plantilla en español, no aparece nada ni se carga el contenido de la web. Si despublico este módulo o lo público en la posición Below_body_1, entonces se carga el módulo y el resto de la web.

Pero en el idioma catalán, todo funciona bien, estando el módulo publicado en la posición left_inset, que es en el que está originalmente.

Por otro lado el problema de los idiomas persiste. No puedo publicar los items dels menu en algunos idomas. Sigue bloqueado. Por tanto Solo se muestran dos en el selector de idioma Tengo 4 idionas instalados y en contenido. Tengo activo el filtro de idiomas, los menús de idiomas y la plantilla en diferentes idiomas. Me estoy volviendo loco con esto. ¿Puede ser un problema de base de datos? Que alguna tabla haya quedado corrupta al actualizar o algo así? Es como si la web no respondiera a la configuración que le doy, como si los idiomas no estuvieran activos. ¿Cómo puedo publicar estos items?

Saludos y gracias

ResponderCitar
Respondido : 04/12/2017 10:36 am
Página 1 / 2

Por favor Iniciar Sesión o Registro