Problema con adjuntos en K2  

 
Juan Carlos
 Juan Carlos
Estimable Member

He añadido un adjunto a un artículo y lo ha subido sin problema, aparece en el artículo, pero cuando pulso en el adjunto para descargarlo me devuelve un error asi

404 - No se ha encontrado

A qué puede ser debido?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 16/04/2013 9:27 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Habría que verificar si el problema puede estar causado por el hecho de tener activadas las urls amigables.

Prueba a desactivar temporalmente las urls amigables en la configuración global de tu Joomla y comprueba si en este caso funciona el enlace al documento.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/04/2013 9:35 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan Carlos
 Juan Carlos
Estimable Member

Ya he hecho la prueba y parece no tener relación.

Tampoco funciona cambiando la configuración SEO.

El artículo tiene una nueva ubicación, por si necesitan acceder.

http://vidartv.com/index.php?option=com_k2&view=item&id=3239:el-nuevo-papa-o-el-papa-negro&Itemid=351

ResponderCitar
Respondido : 17/04/2013 8:27 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Juan Carlos,

Revisa el siguiente hilo de foro: Link a post de foro, solo visible a usuarios registrados

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/04/2013 2:58 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan Carlos
 Juan Carlos
Estimable Member

Renombrando la carpeta com_k2 funciona. Pero al sustituir el código de que habla el hilo me devuelve un nuevo error.

Si desactivo las URL amigables, el error es el mismo.

LAS PRUEBAS LAS ESTOY HACIENDO UN NUEVO ITEM
http://vidartv.com/index.php?option=com_k2&view=item&id=3291:la-noche-que-ense%C3%B1%C3%A9-el-apocalipsis-a-fidel-castro&Itemid=351

ResponderCitar
Respondido : 24/04/2013 10:17 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Juan Carlos,

En vez de activar todos los parámetros de las URLs amigables, activa los dos primeros en la configuración global de Joomla!, parámetros de SEO:
Motor de búsqueda para URLs amigables --> Si
Usar la reescritura URL --> Si
Agrega sufijo a la URL --> No

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 24/04/2013 10:23 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan Carlos
 Juan Carlos
Estimable Member

He comprobado esa configuración y me devuelve el mismo error. Además, si quito los sufijos, los menús me dejan de funcionar.

ResponderCitar
Respondido : 24/04/2013 10:33 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No me cuadra el enlace que viene en la descarga. La dirección del enlace parece estar mal construida. ¿Estás tratando de descargar un archivo que tienes en el mismo servidor?

Indícanos qué datos has puesto en el adjunto.

Si desactivas las urls amigables: ¿qué url te pone para la descarga?

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/04/2013 1:35 pm

Cursos Gratuitos WordPress

Juan Carlos
 Juan Carlos
Estimable Member

El adjunto está en el item siguiente:

http://vidartv.com/profeticavoz/item/3291-la-noche-que-ense%C3%B1%C3%A9-el-apocalipsis-a-fidel-castro.html

El archivo adjunto se ha subido con la función 'adjuntos' del item en K2, y está en el mismo servidor que la web.

La ruta del archivo ahora es:

http://profeticavoz/item/download/14_ab3b6846416164a3d8af7e6f42938338.html

le falta el dominio...

Y si desactivo los sufijos la ruta es:

http://profeticavoz/item/download/14_ab3b6846416164a3d8af7e6f42938338

lo unico que ocurre es que no añade la extensión *.html

Si desactivo las url amigables la ruta es:

http://index.php/?option=com_k2&view=item&task=download&id=14_ab3b6846416164a3d8af7e6f42938338&Itemid=351

Y si renombro la carpeta com_k2, funciona, y la ruta es:

http://vidartv.com/profeticavoz/item/download/14_ab3b6846416164a3d8af7e6f42938338.html

ResponderCitar
Respondido : 25/04/2013 3:30 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Si dices que renombrando la carpeta com_k2 te funciona entonces esto tiene que significar que la plantilla de Joomla que estás utilizando está aplicando una sobreescritura sobra la plantilla de artículo de K2 que hace que no funcione correctamente.

Por tanto, tendrías la opción de dejar la carpeta renombrada, con el correspondiente cambio en el diseño o tratar de editar el archivo item.php que debería haber en esa carpeta para aplicar los cambios necesarios para que funcione el enlace.

El código que se utiliza por defecto para poder descargar los archivos adjuntos es el siguiente:

  item->params->get('itemCategory') || $this->item->params->get('itemTags') || $this->item->params->get('itemAttachments')): ?>
  
  

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/04/2013 9:29 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan Carlos
 Juan Carlos
Estimable Member

Perfecto,

Ahora sí.

He sustituido desde y ya funciona la descarga de adjuntos.

ResponderCitar
Respondido : 02/05/2013 5:43 pm

Por favor Iniciar Sesión o Registro