Redirección de acce...
Avisos
Vaciar todo

Redirección de acceso incorrecta, va a editar perfl de usuario  

Página 2 / 2
 
Montse
 Montse
Estimable Member

Hola, cuando pincho acceso me aparecen las preguntas de inicio de sesión perfectamente, pero cuando pincho acceder me aparecen los datos de quien ha entrado, es decir, el perfil de usuario.
Envío Pantallazo de la configuración del elemento del menú principal "acceso" a ver si me podéis asesorar.
Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/12/2013 11:34 pm
Montse
 Montse
Estimable Member

Pues sí, dice "Hola Carmelo" cuando he habilitado el formulario, pero accede perfectamente cuando he redireccionado "Acceso" a Index.php. Fenomenal. :woohoo:
El problema es que sale la página principal en blanco y sólo aparece el btón de "Finalizar". Su pongo que habrá que poner algo más no? Si utilizo el formulario de arriba a la derecha para registrarme, pasa lo mismo cuando accede.... 🙁

Muchísimas gracias.

ResponderCitar
Respondido : 30/12/2013 8:17 pm

Cursos Gratuitos WordPress

Montse
 Montse
Estimable Member

Concreto más, he puesto redirección de entrada y salida al módulo de formulario de acceso (arriba a la derecha) para que vaya a INICIO, y estupendo, va muy bien y muestra la página incial, pero al hace lo mismo con el botón de módulo de acceso del menú principal, pues sigue mostrando Finalizar al acceder y no muestra la página principal. Es decir, el formulario de acceso va fenomanal y el botón Acceso no.
Es que los estoy probando a ver cuál queda mejor, porque me gustaría quitar el formulario... 🙁
Gracias

ResponderCitar
Respondido : 30/12/2013 8:30 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Montse

Prueba eliminando el ítem de menú acceso, sólo deja el módulo de acceso.
Es decir lo común es tener el módulo de acceso visible siempre, no es necesario el ítem de menú

Saludos.

ResponderCitar
Respondido : 30/12/2013 10:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Montse
 Montse
Estimable Member

No puedo, al despublicarlo me dice "No se puede anular la publicación de inicio por defecto"

ResponderCitar
Respondido : 31/12/2013 4:34 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Esto te ocurre porque tienes puesto el elemento de menú "Acceso" como elemento de menú de inicio. Para cambiar esto vete en la administración de Joomla a la edición de este menú.

En el listado de elementos de menú verás una columna de nombre Inicio que muestra un icono con forma de estrella. Debes de tener el elemento "Acceso" marcado con la estrella amarilla, lo que lo convierte en el principal. Pulsa sobre el icono de la estrella del elemento de menú de nombre "Inicio". Verás que la estrella amarilla la pasará a tener ese elemento de menú, lo que lo convierte en elemento de inicio.

Una vez hecho esto sí que podrás despublicar el elemento de menú "Acceso".

ResponderCitar
Respondido : 31/12/2013 4:39 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Montse
 Montse
Estimable Member

Es que no me lo permite. Me da este error al intentar poner la estrella en Inicio

ResponderCitar
Respondido : 31/12/2013 4:45 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Eso ocurre porque tienes el elemento de menú "Acceso" bloqueado. Si te fijas en la captura de pantalla que has enviado sale un icono de un candado junto al elemento de menú "Acceso", síntoma de que anteriormente no has cerrado correctamente este elemento (suele ocurrir cuando pulsa en el botón "Atrás" del navegador en lugar de cerrar el elemento).

Pulsa sobre el elemento de menú "Acceso" para editarlo. Una vez dentro, pulsa en el enlace Cerrar de la parte superior derecha. De esta forma desbloquearás este elemento de menú. Una vez hecho esto podrás seguir las indicaciones que te había dado antes.

ResponderCitar
Respondido : 31/12/2013 4:52 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Montse
 Montse
Estimable Member

No tengo palabras, mil gracias. No puedo en este punto expresar mi agradecimiento. Hacéis magia chicos.

Lo que ocurre es que, una vez hecho estp, vuelve al problema inicial, que se ha solucionado a media. Entrando desde "acceso",el problema inicial sigue ocurriendo, verás, al iniciar no sale la página principal al acceder con un usuario, sólo sale "Finalizar" a pesar de estar redirigida.

Por otro lado, si entro desde el formulario de acceso (arriba a la derecha) todo va bien, pero si entro con un usuario ejemplo que os dí, carmelo-carmelo, fenomeno, muestra la pantalla de inicio, pero si entro con cualquier otro sale de nuevo en toda la página el botón de "Finalizar", y mi intención es que salga toda la hoja claro.¡ en los dos casos, entrando desde "Acceso" y desde el Formulario de acceso.
Os envío pantallazos del problema, configuración del iten de menú "Acceso" ahora ya despublicado, del que sólo existe el módulo como me habéis dicho (que está fenomenal), y configuración del módulo "Formulario de acceso" a ver qué se os ocurre.

A ver qué se os ocurre, porque creo que lo he redirigido a donde quiero mil veces...

ResponderCitar
Respondido : 31/12/2013 5:13 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Montse

Al probar :
Contenido solo visible a usuarios registrados

Se conecta correctamente y veo que te dirige a la página de inicio

Saludos.

ResponderCitar
Respondido : 31/12/2013 8:10 pm

Cursos Gratuitos WordPress

Montse
 Montse
Estimable Member

Sí, pero como explico abajo, al probar con cualquier otro usuario no, aparece sólo "Finalizar" y no muestra la página de inicio.
Es lo que explico abajo, con ese usuario sí, con otros no.

ResponderCitar
Respondido : 01/01/2014 6:39 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Montse,

Entonces deberías facilitarnos un usuario "que no funcione" ya que lo que pretendemos es reproducir el problema para determinarlo y ver que solución se puede aplicar ¿no?.

Saludos

ResponderCitar
Respondido : 01/01/2014 7:21 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Montse
 Montse
Estimable Member

Vale sorry, lo que pasa es ahora me funciona con todos los usuarios...no sé, he redistribído permisos al crear nuevos usuarios, y me funciona con todos los diferentes permisos, debía ser cuestión de algo de eso...

Cosilla: ¿Cómo se dan aquí las gracias...? No veo el botón al escribir una respuesta y quería pinchar en "Gracias" 🙂

ResponderCitar
Respondido : 01/01/2014 7:58 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Montse,

El comportamiento de "Finalizar" es el correcto y depende mucho de que plantilla estés usando, las plantillas "antiguas" son mucho más austeras en ese sentido.

Las gracias las encuentras debajo de los botones de cada Técnico que responde.

Saludos y gracias a tí por la paciencia.

ResponderCitar
Respondido : 01/01/2014 9:45 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 2 / 2