Avisos
Vaciar todo

"Crear una cuenta" con el acceso tradicional de Joomla y no con el de virtuemart  

 
David
 David
Estimable Member

Buenos días, tengo un problema.

Cree una página que en principio iba a ser una tienda online, pero al final ha sido una página normal. El problema que tenemos es que ahora, con el módulo de acceso a usuarios de Joomla, si pulsamos en "Crear una cuenta" nos la intenta crear como si fuese virtuemart (Pidiendo datos de comprador y de facturación). ¿Cómo podríamos volver al registro tradicional?

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 01/06/2017 11:09 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola David.

¿ siges teniendo el componente virtuemart instalado ?
Si ya no lo tienes que utilizar solo hay que eliminarlo y por defecto tendrás el formulario de joomla.

Si quieres seguir con virtuemart ( Mostrar productos, catalogo, etc... ) puedes asignar los campos que quieres sean obligatorios y los que quieres que se muestren, estas opciones las tienes dentro de Configuración -> Campos de comprador

Un saludo

ResponderCitar
Respondido : 01/06/2017 11:33 am

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Estimable Member

Hola y gracias por la respuesta, he desinstalado virtuemart y, ahora, me aparece un error al pulsar en "Crear una cuenta" 🙁

ResponderCitar
Respondido : 01/06/2017 5:30 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si ves la url que se genera de registro sigue haciendo referencia a virtuemart,
Revisa si aún tienes instalado algo de Virtuemart desde Extensiones > Gestor de extensiones.

Revisa también si tienes la cache de t usitio habilitada, prueba deshabilitar la cache, prueba también desahbilitar las urls amigables.

Saludos

ResponderCitar
Respondido : 01/06/2017 7:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Estimable Member

Gracias por la respuesta jhon, en el gestor de extensiones ya no aparece nada al buscar "Virtuemart", he limpiado la caché desde Sistema>Limpiar la caché y desactivad las URL amigables, pero el problema continúa 🙁

ResponderCitar
Respondido : 02/06/2017 11:49 am
Julen
 Julen
Miembro Admin

Hola David,

Por favor, envíanos una captura de la pantalla del error que te da e indícanos la url de la página que visualizas para que podamos revisar lo que comentas.

https://guias.webempresa.com/preguntas-frecuentes/captura-de-pantalla/
Nota: Adjunta las capturas en forma .jpg o .png (no las incrustes en archivos doc, docx o pdf).

ResponderCitar
Respondido : 02/06/2017 12:08 pm

Cursos Gratuitos WordPress

David
 David
Estimable Member

Hola Julen, la URL a la que nos lleva al pulsar en crear una cuenta es esta:
http://heliosar.weberalia.es/index.php?option=com_virtuemart&view=user&layout=edit
(el formulario de acceso está en la portada: http://heliosar.weberalia.es )

Captura de pantalla:

ResponderCitar
Respondido : 02/06/2017 2:38 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es muy extraño que el módulo de login se haya quedado con el link de virtuemart cuando virtuemart ya esta desinstalado, has comprobado que no exista nada de virtuemart en : Extensioens > Gestor de Extensiones > Gestionar?

Prueba eliminando el módulo de login y colocarlo nuevamente.

Una opción también sería instalar nuevamente Virtuemart, verificar y desinstalarlo nuevamente.

Saludos.

ResponderCitar
Respondido : 02/06/2017 8:51 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Estimable Member

Hola Jhon, yo creo que ya no existe nada de virtuemart, adjunto captura:

A modo de prueba, he incluído un nuevo módulo de acceso en el showcase de la web: http://heliosar.weberalia.es/ , pero el problema continúa

ResponderCitar
Respondido : 05/06/2017 11:23 am
Julen
 Julen
Miembro Admin

Hola,

A modo de prueba, puedes probar a eliminar la cache almacenada:

. Accede Sistema -> Limpiar Cache, pulsa en borrar todo
.- Selecciona limpiar cache expirada y realiza los mismos pasos.

Comprueba si se soluciona.

ResponderCitar
Respondido : 05/06/2017 11:59 am

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Estimable Member

Hola Julen, muchas gracias por tu respuesta. Lo he probado pero todo sigue igual 🙁

ResponderCitar
Respondido : 06/06/2017 11:36 am
Rafael
 Rafael
Miembro Moderator

Hola David,

He estado revisando tu caso y te propongo hacer lo siguiente:

Vete al apartado de Extensiones > Modulos

En ella, busca el módulo que tienes ahora en la posición showcase-a de acceso de virtuemart y bórralo 🙂

Luego, vuelve a crear uno nuevo en esta misma posición, pulsa en "nuevo" > datos de acceso web quedando de esta forma

Por último, te recomiendo activar las URLs amigables en tu Joomla 🙂

-> https://www.webempresa.com/blog/urls-amigables-en-joomla.html

Revisa si con esto ya visualizas el formulario correcto (sin que te redirija a virtuemart)

Saludos

ResponderCitar
Respondido : 06/06/2017 3:09 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación