Avisos
Vaciar todo

Error al instalar extensiones compatibles con Joomla 3.2.3  

 
Arcadi
 Arcadi
Usuario activo

Hola,

Os escribo ya que estoy intentando instalar nuevas extensiones compatibles con mi Joomla v. 3.2.3 pero siempre me aparece el mismo mensaje de error:

Advertencia

JFolder::create: La ruta no está entre las rutas del 'open_basedir'
JFolder: :files: La ruta no es una carpeta. Ruta: https:/www.artboxbcn.com/tmp/install_6140aeb772bb0
JFolder: :folder: La ruta no es una carpeta. Ruta: https:/www.artboxbcn.com/tmp/install_6140aeb772bb0
JFolder: :files: La ruta no es una carpeta. Ruta: https:/www.artboxbcn.com/tmp/install_6140aeb772bb0
JInstaller: :Instalar: No se ha podido encontrar el archivo XML de configuración de Joomla!

¿A qué puede deberse y como solucionarlo?

Os paso la configuración actual que corre en el administrator de mi Joomla:

PHP instalado sobre: Linux cp629.webempresa.eu 3.10.0-962.3.2.lve1.5.26.3.el7.x86_64 #1 SMP Wed Aug 14 08:29:59 EDT 2019 x86_64
Versión de la base de datos 10.3.31-MariaDB-cll-lve
Cotejamiento de la base de datos utf8_general_ci
Versión de PHP 5.6.40
Servidor web Apache
Interfaz de PHP litespeed
Versión de Joomla! Joomla! 3.2.3 Stable [ Ember ] 6-March-2014 14:30 GMT
Versión de la plataforma de Joomla! Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
Agente del usuario Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0

 

Espero vuestra ayuda para poder solventarlo.

¡Gracias!

Contenido solo visible a usuarios registrados

Citar
Respondido : 14/09/2021 4:29 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Arcadi, 

¿Puedes indicarnos cuáles son las extensiones que están intentando instalar?, de esta forma podemos verificar con mayor detalle lo que nos comentas

De manera general verifica bien los requisitos que solicitan para los complementos, por ejemplo veo que tienes instalado PHP 5.6 y puede ser que los complementos no sean compatibles con esta versión, prueba modificar la versión de tu PHP y comprueba si con ello no te muestra el error -> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Tambien comprueba las extensiones que intentas instalar, es posible que dentro del zip si lo descomprimes tengas otro zip o una carpeta donde esté el plugin para instalarlo, en ocasiones el archivo que se descarga suele venir con varias partes. Si es así tienes que descomprimir el archivo y dentro debería estar el propio instalador. Por ejemplo, hay temas o complementos cuyo archivo de descarga contiene tanto el instalador como otras cosas además del instalador principal.

PD: Recuerda antes de realizar cualquier instalación o cambios realizar una copia de seguridad de tu sitio web, de esta forma si se genera algún error puedes restaurarla

Un Saludo

ResponderCitar
Respondido : 14/09/2021 4:53 pm

Cursos Gratuitos WordPress

Arcadi
 Arcadi
Usuario activo

Hola @karen, los módulos que intento instalar son mod_popup_jt y modals-v11.9.3 los cuales he probado comprimidos y descomprimidos pero no funcionan cuando los intento instalar ya sea mediante administrador de archivos del CPanel o mediante el administrator de joomla, donde sale dicho error...

Espero vuestra ayuda.

Gracias

ResponderCitar
Respondido : 15/09/2021 12:06 am
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Arcadi,

Veo que ya mi compañera te lo ha recomendado pero te hago la consulta, has probado actualizar la version de PHP desde tu cpanel?

Saludos!

ResponderCitar
Respondido : 15/09/2021 12:45 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Arcadi
 Arcadi
Usuario activo

Hola de nuevo.

He probado de actualizar la versión de PHP en CPanel pero mi web solo admite la 5.6. La he cambiado y sigue saliendo el mismo mensaje al intentar instalar cualquier extensión (antes esto no ocurría)...

Espero vuestra ayuda.

Gracias

ResponderCitar
Respondido : 15/09/2021 10:20 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Arcadi.

Lo primero que tienes que hacer es actualizar Joomla a al ultima version de la rama 3x que es la 3.10.2

Una vez lo tengas modifica la version de PHP e instala la version 7.3

 

Ten en cuanta que las extensiones se actualizan segun aparecen nuevas versiones de Joomla y cambios de versiones de PHP, la mayoría necesitan versiones de la rama 7x

 

Después de eso revisa si puedes instalar las extensiones. 

 

Un saludo

ResponderCitar
Respondido : 15/09/2021 12:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Arcadi
 Arcadi
Usuario activo

Hola @pepesoler,

Antes que nada he ejecutado el asistente Virtual Stephan y me dice lo siguiente:

El sitio tiene mal configurada la ruta de log_path en el configuration.php, el valor actual es https://www.artboxbcn.com/logs y el correcto es /home/bcnsport/public_html/artboxbcn.com/logs
El sitio tiene mal configurada la ruta de tmp_path en el configuration.php, el valor actual es https://www.artboxbcn.com/tmp y el correcto es /home/bcnsport/public_html/artboxbcn.com/tmp

¿Donde puedo encontrar el archivo configuration.php para resolver esto?

Por otro lado también he visto que la web fue hackeada por un tal aan.txt, que he revisado y borrado en la mayoría de directorios de mi web. ¿Como puedo detectar si ha hecho algun cambio en la configuración de mi joomla?

Gracias

ResponderCitar
Respondido : 15/09/2021 2:37 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Arcadi.
Eso puede ser una de las causas por las cuales no puedes cargar las extensiones:

.- Accede a tu cuneta de cPanel -> Admisntrador de archivos

.- Accede a la carpeta del dominio.

.- edita el archivo " configuration.php "

.- Busca las variables " $log_path " y " $tmp_path "

screenshot cp5009.webempresa.eu 2083 2021.09.15 15 51 37

.- Modificalo por lo siguiente:

public $log_path = '/home/bcnsport/public_html/artboxbcn.com/logs';
public $tmp_path = '/home/bcnsport/public_html/artboxbcn.com/tmp';

 

 ¿Como puedo detectar si ha hecho algun cambio en la configuración de mi joomla?

No se puede saber, hay que ir revisando todo y ver que funcione sin problemas.

Ahora veo que la web esta limpia:

Contenido solo visible a usuarios registrados

 

Un saludo

 

 

ResponderCitar
Respondido : 15/09/2021 3:00 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Arcadi
 Arcadi
Usuario activo

Hola @pepesoler,

He actualizado los paths y ahora al intentar instalar la extensión en un .zip la página se queda en blanco y no sale ningún mensaje...

Eso si, he intentado actualizar algunos plugins que ya tenía instalados y me sale el siguiente mensaje de error de path: La ruta de actualización no existe (adjunto captura)

imagen

Por otro lado he revisado si puedo actualizar Joomla mediante 1 clic pero me dice que la 3.2.3 es la última versión disponible...

¿Como puedo actualizar la versión de joomla de 3.2.3 a la 3.9.27, que es la recomienda joomla en este enlace https://www.joomla.org/announcements/release-news/5836-joomla-3-9-27.html?

Gracias!

ResponderCitar
Respondido : 15/09/2021 3:15 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Arcadi.

.- Accede a Componentes -> Actualizar Joomla 

screenshot mary52.webempresa.eu 2021.09.15 16 29 06

Comprueba si apare alguna opción para actualizar Joomla.

Es posible que tengas que realizar varias actualizaciones ya que tienes un version muy desfasada

 

al intentar instalar la extensión en un .zip la página se queda en blanco y no sale ningún mensaje...

Antes de instalar alguna extension tienes que actualizar Joomla y modificar la version de PHP

 

Desde cuando estas notando los problemas ?

Una opción podría ser restaura la web a una fecha en la que todo funcionaba bien:

-> https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/#restaurar-web

 

Un saludo

 

 

 

ResponderCitar
Respondido : 15/09/2021 3:55 pm

Cursos Gratuitos WordPress

Arcadi
 Arcadi
Usuario activo

Hola @pepesoler,

Como te he dicho no me deja actualizar mediante esta opción. Además al intentar purgar la cache me aperece otro error.. (adjunto captura)

imagen

Prefiero actualizar mi versión antigua a la nueva versión de joomla 3.9.27, pero el administrator de joomla no me deja... ¿Qué puede hacer en este caso?

Gracias

ResponderCitar
Respondido : 15/09/2021 4:08 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Arcadi.

El aviso es por que no puedo abrir una URL, es decir intenta conectarse a esa URL y no existe o esta caída.

visto todos los errores lo mejor es que restaures la web a un punto en el que funcionaba bien y a partir de ahi actualizar.

 

Otra opción seria actualizar joomla manualmente:

-> https://docs.joomla.org/J3.x:Upgrading_from_Joomla_3.4.x_to_3.5/es

 

Puedes contactar con algún colaborador y te ayudaran a actualizar la web manualmente:

-> https://www.webempresa.com/directorio-colaboradores.html

 

Un saludo

 

ResponderCitar
Respondido : 15/09/2021 4:18 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress