Avisos
Vaciar todo

Error en CAPTCHA 2.0 registro usuarios  

 
JOSE LUIS
 JOSE LUIS
Usuario eminente

Hola !!! 

Por un usuario que ha tratado de darse de alta me he percatado de un error en el CAPTCHA de registro de mi portal. He comprobado que todo está correcto, de hecho el captcha funciona, pero cuando clicks se queda en bucle y no verifica.

Captura de pantalla 2023 12 05 a las 18.37.42

 

He probado varias cosas, como cambiar a re-Captcha invisible, cambiar las opciones predeterminadas de cpacha etc...sigue dando error: no permite el registro aunque aparece sin problemas cuando verificas se queda en bucle. 

 

Un saludo y gracias de antemano. 

Contenido solo visible a usuarios registrados

Citar
Respondido : 05/12/2023 5:39 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Jose,

Has verificado regenerar unos nuevos apis de google recaptcha para comprobar si generando uno nuevo en v2 no sucede esto? si no lo has hecho pruébalo y nos comentas que tal va la prueba.

Un saludo 🖐️ 

ResponderCitar
Respondido : 05/12/2023 7:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

JOSE LUIS
 JOSE LUIS
Usuario eminente

@argenisn pues he creado claves nuevas en versión 2.0 (hay v3 pero mi menú de capcha de Joomla no lo soporta, por eso no me he molestado en probarlo) y sigue con el mismo problema...el captcha se queda dando vueltas pero no verifica. He probado a crear una clave nueva, bajarlo el nivel de seguridad en las opciones del plugin, crear nuevas claves para el mismo dominio, generar un cpacha invisible y cambiar las opciones a CAPTCHA INVISIBLE en el plugin, en global y en usuarios...si activo el invisible, me desaparece en el formulario, pero al querer darse de alta me dice que no se ha verificado el captcha...

En la documentación avisa que hay que cargar un fragmento HTML en la web, entiendo que el propio PLUGIN de Joomla para captcha lo hace de por sí...entiendo que en esta parte no hay que tocar nada...

Gracias de antemano. 

ResponderCitar
Respondido : 10/12/2023 11:06 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Jose Luis.

Prueba con el siguiente plugin:

-> https://extensions.joomla.org/extension/authcaptcha-for-joomla/

 

Un Saludo

 

ResponderCitar
Respondido : 10/12/2023 4:28 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

JOSE LUIS
 JOSE LUIS
Usuario eminente

@pepesoler Hola. 

Instalado. Ahora pasa una cosa curiosa: en el login del portal me aparece un captcha, que verifica cuando metes un usuario y contraseña válido. Lo hace casi de forma instantánea. 

Si vas al apartado de alta de nuevo usuario, el captcha del final del formulario sigue haciendo lo mismo, quedándose en bucle, cuando metes la info y te quieres dar de alta...EN ESA MISMA WEB DE DARSE DE ALTA aparece también el pequeño captcha en el lateral de login que normalmente no aparece en el portal hasta que he instalado el plugin nuevo, y EN ESA WEB DE ALTA SI METES USUARIO Y CONTRASEÑA DE UN USUARIO en el recuadro de logueo hace lo mismo que el captcha del formulario de alta...se queda en bucle...

Lo digo por si el error pudiera estar relacionado con la página del formulario en sí, no con el captcha...

 

Gracias

ResponderCitar
Respondido : 10/12/2023 4:48 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Jose Luis,

Al probar el complemento compartido por mi compañero has desactivado las opciones por defecto de recaptcha que trae tu plantilla activa? 

Mencionas que en una instancia si funciona sin problemas pero persiste la carga infinita en el apartado donde se registra un usuario, esto puede deberse a que hay dos validaciones corriendo al mismo tiempo.

Valida y nos comentas, Saludos!

ResponderCitar
Respondido : 10/12/2023 5:38 pm

JOSE LUIS
 JOSE LUIS
Usuario eminente

@bruno-vichetti Hola...

sólo tengo la opción RECAPCHA en la plantilla en GLOBAL. Os adjunto captura. Si desactivo eso, los captchas desaparecen (todos). Si lo dejo en recaptcha pasa lo que os comento: en el recuadro de logueo si te logueas con un usuario y contraseña y tildas el captcha, OK...si lo haces en el apartado de alta de nuevo usuario ni en el recuadro de login ni en el de usuario verifica...

Captura de pantalla 2023 12 10 a las 19.11.52
Captura de pantalla 2023 12 10 a las 19.12.34
Captura de pantalla 2023 12 10 a las 19.12.13
Captura de pantalla 2023 12 10 a las 19.13.51
Captura de pantalla 2023 12 10 a las 19.15.50
Captura de pantalla 2023 12 10 a las 19.14.03

 

ResponderCitar
Respondido : 10/12/2023 6:20 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Jose Luis,

Gracias por las capturas, entiendo que el funcionamiento del recaptcha para iniciar sesion se resolvio al instalar el complemento https://extensions.joomla.org/extension/authcaptcha-for-joomla/ es correcto?

Si lo mantienes solo activo y desactivas los otros dos recaptcha que aparecen desde los módulos desaparecen por completo?

image

En la siguiente opción deberia aparecer el complemento agregado de Autocaptcha

image

Entre otras dudas, el problema se ha originado recientemente después de algún ajuste u actualización, ya que el comportamiento que presentes es curioso, tanto que dependiendo de cual sea su origen puede que sea necesario implementar acciones a medida https://groups.google.com/g/recaptcha/c/DPu8PhXvefE

Si este es el caso siempre podras restaurar a una version anterior por medio de Superbackup https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/

O en ultima instancia si se requiere ajuste a medida sea necesario el apoyo de nuestros colaboradores para que puedan evaluar a detalle el problema https://www.webempresa.com/directorio-colaboradores.html

Saludos!

ResponderCitar
Respondido : 10/12/2023 8:36 pm

Cursos Gratuitos WordPress

JOSE LUIS
 JOSE LUIS
Usuario eminente
Respondido por: @bruno-vichetti

Hola Jose Luis,

Gracias por las capturas, entiendo que el funcionamiento del recaptcha para iniciar sesion se resolvio al instalar el complemento https://extensions.joomla.org/extension/authcaptcha-for-joomla/ es correcto?

Si, la gracia es que en el login no usaba el recaptcha...desde que instalé el nuevo plugin no sólo aparece en el login de usuarios, en el lateral del portal, sino también en el login del backend...curioso. Y allí funciona perfectamente. 

Si lo mantienes solo activo y desactivas los otros dos recaptcha que aparecen desde los módulos desaparecen por completo?

image

Si, desaparecen...en ambos sitios: en el cuadro de login y en el formulario. Si el formulario lo rellenas, el captcha no aparece y cuando le das a registrar pone que no se ha rellenado el captcha...aunque no está 

En la siguiente opción deberia aparecer el complemento agregado de Autocaptcha

image

No, no aparece el módulo nuevo. Si activo el invisible aparecen los dos (recaptcha e invisible) pero el plugin nuevo no genera otra opcion en el desplegable. 

 

 

Entre otras dudas, el problema se ha originado recientemente después de algún ajuste u actualización, ya que el comportamiento que presentes es curioso, tanto que dependiendo de cual sea su origen puede que sea necesario implementar acciones a medida https://groups.google.com/g/recaptcha/c/DPu8PhXvefE

No he realizado actualización ninguna...ni siquiera cambio alguno...por lo que descarto que haya sido por algún cambio. 

Si este es el caso siempre podras restaurar a una version anterior por medio de Superbackup https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/

O en ultima instancia si se requiere ajuste a medida sea necesario el apoyo de nuestros colaboradores para que puedan evaluar a detalle el problema https://www.webempresa.com/directorio-colaboradores.html

Saludos!

 

ResponderCitar
Respondido : 10/12/2023 10:07 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Jose Luis,

Si no has realizado ninguna actualización reciente, quiere decir que es probable que el método de recaptcha en uso haya sido el que se ha actualizado y es por ello que entra en conflicto y causa el comportamiento que podemos apreciar.

Puedo dejarte algunas sugerencias que valdría la pena probar:

-Generar e instalar una nueva claves de recaptcha ademas de usar su version V3 de ser posible

-Evaluar desactivar el recaptcha por completo y probar el comportamiento de los formularios de registro e inicio de sesión, además validar si aparece en otras secciones de la página como en algun formulario de contacto

-Probar los siguientes módulos:

https://extensions.joomla.org/extension/custom-recaptcha/
https://extensions.joomla.org/extension/no-captcha-recaptcha/

Por último como te he comentado anteriormente, si el problema radica en la estructura de tu sitio web, al ser un ajuste a medida sería necesario el apoyo de nuestros colaboradores para que puedan evaluar a detalle el problema https://www.webempresa.com/directorio-colaboradores.html

Saludos!

ResponderCitar
Respondido : 11/12/2023 3:47 am

wpdoctor-revisa-la-salud-de-tu-wordpress