Avisos
Vaciar todo

Error Menú elementos etiquetados Joomla! 3.8.4  

Página 1 / 2
 
David
 David
Usuario experto

Buenas tardes,

Llevo días observando y revisando unas Lista de Elementos Etiquetados que utilizo hace años y que de repente han dejado de funcionar, creo que al instalar Joomla! 3.8.4.

Actualmente dan el típico error: 0 - "Call to a menmber fuction get() on string" y no localizo porque. Desconozco si es algún cambio de Joomla porque esta parte no la toco desde que la cree.

El fallo se produce en los 2 tipos de listas con elementos de menú:
* Listas compacta de elementos etiquetados.
* Elementos etiquetados.

Que en el mi menú izdo. son:
* Lista General
* Lista Piel de Toro
* Vídeos-DVD
* Libros
* imágenes

¿alguna idea? No localizo el error.
Muchas gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 03/02/2018 10:21 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

¿Has probado a activar PHP 7.0 o 7.1 para esta web actualizada a la versión 3.8.4?

Revisa el siguiente artículo donde explico como cambiar la versión de PHP de forma global o para una carpeta concreta desde tu cPanel:

- Versión de PHP en tu Hosting ¿cómo cambiarla rápidamente? - https://www.webempresa.com/blog/version-php-hosting-como-cambiarla-rapidamente.html

Saludos

ResponderCitar
Respondido : 04/02/2018 3:16 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario experto

Gracias Luis,

Ya he seguido detenidamente tus explicaciones y he cambiado al php 7.0.27 y al php 7.01.13 y el resultado es el mismo Error.

Yo creo que tiene más que ver con las Etiquetas, ya que son las únicas listas que fallan, las demás que listan artículos u otras cosas van bien.

¿alguna otra idea?

Muchas gracias.

ResponderCitar
Respondido : 04/02/2018 8:27 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

¿Puedes facilitar alguna captura del backend donde configuras una de esas listas que fallan para revisarlo?

- Los formatos de capturas admitidos son .jpg y .png (no .bmp)
- No las incrustes en archivos .docx de Word o similares, ni en PDFs.
- No las unifiques en una sola captura.
- No las recortes.

Indica también la url del tema que utilizas (no lo he encontrado por ninguna parte) y la versión "exacta" de Kunena que estás usando.

Quedo a la espera de tu respuesta.

ResponderCitar
Respondido : 04/02/2018 10:57 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario experto

Hola Luis,

Te adjunto las imágenes de todas las pestañas del backend de una de las listas.

Lo de la URL del tema no te entiendo muy bien, creo que te refieres a los enlaces de las listas en el menú, son estos

Enlaces a las listas de Elementos Etiquetados que no funcionan:

https://www.1pocodmusica.com/index.php/ct-menu-item-16/lista-general
https://www.1pocodmusica.com/index.php/ct-menu-item-16/lista-pdt
https://www.1pocodmusica.com/index.php/mas/videos-dvd
https://www.1pocodmusica.com/index.php/mas/libros
https://www.1pocodmusica.com/index.php/mas/imagenes

Respecto a la versión de KUNENA, ¿ahí puede estar el problema?
Versión KUNENA: 4.0.12
Plantilla prederterminada: Blue Eagle

No la he podido actualizar KUNENA, ya que fue una consulta que os hice en su día, que no encontré soporte en la nueva versión para la plantilla "Blue Eagle" y tuve que restaurar la página a la versión anterior, porque se desplazaban todos los elementos. Desconozco si actualmente se puede hacer algo.

Muchas gracias por vuestra atención.

ResponderCitar
Respondido : 05/02/2018 8:11 pm
David
 David
Usuario experto

Hola Luis,

Revisando otra vez el asunto de KUNENA, he encontrado una posible solución en esta dirección: https://www.kunena.org/download/templates/product/blue-eagle-5

The Blue Eagle "Extended support" for Kunena 5.0

Sabéis si alguien la ha probado.

Un saludo.

ResponderCitar
Respondido : 05/02/2018 8:42 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En la dirección que envías sólo veo un enlace para descarga.

Con respecto a tu problema, verifica si tienes actualizado.
Para probar lo que comentas entiendo que se necesita tener un usuario registrado para el front-end, envíanos algún usuario que tengas registrado para verificar.

Saludos.

ResponderCitar
Respondido : 05/02/2018 9:30 pm
David
 David
Usuario experto

Hola Jhon,

No sé como ponerlo esto oculto.

Te he puesto como Administrator, con estos datos:

Contenido solo visible a usuarios registrados

Un saludo.

ResponderCitar
Respondido : 05/02/2018 10:00 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

En este enlace se comenta que puede ser un problema de la versión PHP: https://github.com/Kunena/Kunena-Forum/issues/3934

Que versión estas utilizando en este momento?

Al parecer también necesitas actualizar la versión de Kunena. Yo te recomendaría que este procedimiento lo realices con una copia de seguridad en otro directorio: - https://www.webempresa.com/blog/copias-de-seguridad-con-xcloner-backup-en-joomla-15-25-y-30.html

ResponderCitar
Respondido : 06/02/2018 1:50 am
David
 David
Usuario experto

Hola Johnny,

¿Te quiero entender que me aconsejas lo contrario que me dijo Jhon?
¿En vez de actualizar a una versión más nueva de PHP, bajar a una más antigua?

Versión actual de PHP: 7.1.14
Versión actual de Joomla: 3.8.5

Sobre la versión de KUNENA, te repito lo que le puse a Luis:

Revisando otra vez el asunto de KUNENA, he encontrado una posible solución en esta dirección: www.kunena.org/download/templates/product/blue-eagle-5

The Blue Eagle "Extended support" for Kunena 5.0
¿Sabéis si alguien la ha probado?.

No la voy a actualizar si ya se que no funciona.
Un saludo.

ResponderCitar
Respondido : 06/02/2018 5:30 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Creo que podrías evaluar efectivamente la actualización de kunena, si lo que te esta frenando es el template para kunena, lo que te sugiero es :

Clonar tu sitio web en un carpeta, cambiar el template de kunena a alguno estanadard, luego probar actualizar kunena y verificar si te sucede lo mismo, la idea es ver si es un problema de actualización sin tener en cuenta el template.

Saludos.

ResponderCitar
Respondido : 06/02/2018 5:50 pm
David
 David
Usuario experto

Hola Jhon,

Lo de clonar a una carpeta y demás me parece un poco lío para mis limitados conocimientos, pero además no creo que va por ahí el problema. El foro Kunena funciona perfectamente en todo y todo tipo de listas, excepto en las Listas con Elementos Etiquetados.

Si no le veis otra solución, me pondré con paciencia a clonar el KUNENA y ha hacer la prueba.

Muchas gracias.

ResponderCitar
Respondido : 06/02/2018 6:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Algo que podrías probar es quitar las etiquetas a alguna lista y luego crear nuevas etiquetas y verificar si te sucede lo mismo.

De todas maneras si que sería bueno que en algún momento actualices kunena, ya nos comentas si decidiste hacer un clon de tu sitio para pruebas.

Saludos

ResponderCitar
Respondido : 06/02/2018 8:06 pm
David
 David
Usuario experto

Hola jhon,
He creado una nueva etiqueta y un nuevo elemento de menú con esa nueva etiqueta y hace lo mismo.

Son etiquetas que están en artículos y en cuanto pongo el "Tipo de contenido" - Artículo, falla igualmente con el mensaje. Si en vez de Artículo pongo otras cosa (Categoría de Artículos, Contacto, Etiqueta, ...) por lo menos sale el formulario con Buscador y diciendo que no ha ninguna que cumpla.

Respecto a clonar el sitio, tengo un problema, que me lo impide. Acabo de mirar en el Cpanel y estoy usando 1,71 GB de los 3 GB que tengo contratados o 57% ocupado, que es lo mismo.

¿Habría alguna forma de hacer esta prueba sin clonar todo el Sitio? ¿Clonando solo el foro KUNENA, por ejemplo?

Muchas gracias.

ResponderCitar
Respondido : 09/02/2018 6:11 pm

Cursos Gratuitos WordPress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

No es posible clonar solo el foro, si necesitas espacio puedes enviar un ticket al departamento técnico para que te dupliquen la cuenta por 24 horas y realices el clonado para pruebas.

Nunca se deben de realizar pruebas en un sitio web en producción que te podrá generar mas problemas en caso de algún cambio o actualización falle.

ResponderCitar
Respondido : 10/02/2018 12:54 am
Página 1 / 2