Avisos
Vaciar todo

No se muestran algunas páginas en el sitemap  

Página 1 / 2
 
Levantemedia
 Levantemedia
Honorable Member

Hola,

Me he dado cuenta que en el sitemap no aparecen todas las páginas de la web. En concreto las de menú archivo valefutbol. Algunos de estos artículos no están indexados por Google, y eso que los he mandado desde el Search Console. ¿Sabéis por qué puede ser?

Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 10/03/2016 2:09 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Entiendo que estás utilizando el Xmap o el MapX para crear tu mapa web. Fíjate que cuando configuras el mapa web se pueden seleccionar los menús que irán incluidos en el mapa. Es decir, no se genera un mapa web con todos los elementos de todos los menús, sino que tienes que ser tú el que elija que menús van incluidos.

Verifica la configuración que tienes puesta, para asegurarte que has añadido el menú que comentas.

ResponderCitar
Respondido : 10/03/2016 3:35 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Levantemedia
 Levantemedia
Honorable Member

Hola Pablo,

Lo que quiero decir es que en www.campodefutbol.net/sitemap.xml no salen estos artículos. No obstante, desde el componente del mapa del sitio sí que salen. Te mando los pantallazos.

ResponderCitar
Respondido : 10/03/2016 4:32 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Debes tener un fichero sitempa.xml en la raiz de tu cuenta de hosting que en algún momento generaste, elimina este archivo, la url que debes enviar a google es la que te genera xmap

Saludos.

ResponderCitar
Respondido : 10/03/2016 5:18 pm

Cursos Gratuitos WordPress

Levantemedia
 Levantemedia
Honorable Member

Hola,

No sé muy bien el link que tengo que añadir a Search Console como sitemap. He puesto este:

http://www.campodefutbol.net/index.php?option=com_xmap&view=xml&tmpl=component&id=1

Pero veo que Google no me indexa las páginas, ni enviándolas directamente. No sé muy bien qué pasa.

Para wordpress, el link que he puesto es este:

http://paginasparaverseries.com/page-sitemap.xml

Y veo que ese sí que lo indexa. Sin embargo para joomla no sé qué link es el bueno. A ver si me pueden ayudar por favor.

Gracias.

ResponderCitar
Respondido : 12/03/2016 11:09 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Joan.
Elimina primero el archivo sitemap.xml que se encuentra en la carpeta raíz del directorio de joomla.
Una vez eliminado genera de nuevo el archivo con xmap y la dirección resultante es la que tienes que mandar a google.

También puedes valorar utilizar otra extensión como OSMap:
Genera tu sitemap en Joomla 3.4 con OSMap

Un saludo

ResponderCitar
Respondido : 12/03/2016 11:24 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Levantemedia
 Levantemedia
Honorable Member

Hola,

Pero al crear un mapa del sitio nuevo el link que se crea sigue siendo este:

http://www.campodefutbol.net/index.php?option=com_xmap&view=xml&tmpl=component&id=2

Es correcto?

ResponderCitar
Respondido : 12/03/2016 11:43 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Joan.
Si te das cuenta te a creado otro con el ID2, Ten en cuenta que google no indexa las paginas al instante suele pasar un tiempo incluso hasta 24h.

Un saludo

ResponderCitar
Respondido : 12/03/2016 11:49 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Levantemedia
 Levantemedia
Honorable Member

Hola,

Lo que quiero saber es si es ese en enlace que debo mandar a Search Console y también poner en el archivo robots. Es raro que indexe solo algunas páginas y otras no. En las demás webs que tengo no he tenido este problema.

Este es el enlace que me genera: http://www.campodefutbol.net/index.php?option=com_xmap&view=xml&tmpl=component&id=2

Sin embargo, en el Search Console he leído que debería ser así: Sitemap: http://example.com/ubicacion_sitemap.xml

Por eso tengo dudas. Y otra duda que tengo es si se genera también el mapa html, al mismo tiempo que xml.

Gracias de nuevo.

ResponderCitar
Respondido : 14/03/2016 1:49 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El enlace Contenido solo visible a usuarios registrados que te genera el componente ya es válido, y sería el que tendrías que enviar a Google. Aunque podrías guardar el xml generado y colocarlo en la raíz con el nombre sitemap.xml, esto no es algo recomendable, ya que ese fichero sería estático y no se aplicarían los cambios que hagas en la web.

Sin embargo, con un fichero dinámico como el que te indicaba, Google siempre tendrá la última versión de la estructura de tu web.

El hecho que la url del sitemap acabe con .xml o no no debería influir en la indexación del mapa, lo importante es que el contenido generado tenga el formato adecuado.

ResponderCitar
Respondido : 14/03/2016 3:22 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Levantemedia
 Levantemedia
Honorable Member

Buenas tardes,

He dejado unos días de prueba a ver si indexaba bien con ese mapa xml, pero veo que sigue indexando solo seis páginas. Os mando una captura del Search Console. Deber haber algún error en algún lado. Los otros sites que tengo, haciendo lo mismo, sí que enlaza todas las páginas.

Saludos.

ResponderCitar
Respondido : 16/03/2016 5:46 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Ten en cuenta que el envío del sitemap no garantiza que se indexen las páginas más rápido o que se indexen todas, el sitemap es sólo una referencia para google.

En tus otros sitios web usaste el mismo tipo de url dinámica para tus sitemaps?

De manera general, si ya te ha detectado el sitemap con la url enviada y no se han producido errores, sólo sería cuestión de tiempo para que te realice la indexación de más páginas.

Saludos.

ResponderCitar
Respondido : 16/03/2016 5:54 pm

Cursos Gratuitos WordPress

Levantemedia
 Levantemedia
Honorable Member

Hola de nuevo. ¿Y cómo se explica que ayer tenía seis páginas indexadas y hoy solo dos de 28? Lo dicho, hay algo que no debe estar bien. Pero no tengo ni idea de qué pasa. A ver si a alguien se le ocurre algo.

Saludos.

ResponderCitar
Respondido : 18/03/2016 2:53 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por lo que veo Google está leyendo bien tu sitemap ya que, como se ve, ha detectado las 28 páginas que contiene, aunque solo haya indexado 2.

He probado las urls de tu sitemap y parecen correctas, por lo que te quedaría esperar para ver si en unos días aumenta el número de páginas indexadas.

ResponderCitar
Respondido : 18/03/2016 3:40 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Levantemedia
 Levantemedia
Honorable Member

Hola de nuevo,

Acabo de leer un artículo de vuestro compañero Luis Méndez en el cual recomienda quitar del robots.txt las líneas:
Disallow: /images/
Disallow: /media/
Disallow: /templates/
Disallow: /modules/
Disallow: /plugins/
Disallow: /cache/

Yo las tenía puestas en mi archivo robots.txt. Tal ves sea este el motivo por el cual Google no me indexaba algunas páginas. ¿Qué creéis? Las tenía puestas porque leí en otro artículo que era mejor ponerlas, pero ya veo que no. Actualmente tengo puestas las siguientes líneas:

Disallow: /administrator/
Disallow: /cli/
Disallow: /components/
Disallow: /includes/
Disallow: /installation/
Disallow: /language/
Disallow: /libraries/
Disallow: /logs/
Disallow: /tmp/

¿Me recomendáis quitar alguna más?

Saludos!

ResponderCitar
Respondido : 28/04/2016 2:28 pm
Página 1 / 2