Avisos
Vaciar todo

Pack Epimeteo no funciona con PHP 7  

 
Alceste
 Alceste
Noble Member

Hola,
Veo que el Pack Epimeteo no funciona con PHP 7+ y en la administración se advierte que debe pasarse a esta versión de PHP. Al hacerlo, la web dejó de funcionar. ¿Tenéis prevista alguna actualización para que pueda usarse con versiones de PHP 7+?

Saludos y gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 03/10/2018 1:39 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

¿Tenéis prevista alguna actualización para que pueda usarse con versiones de PHP 7+?
pues no, en principio los packs dejan de estar disponibles.

Hemos eliminado los instaladores de packs de todos nuestros servidores, por lo que ya no es posible instalar las plantillas que hemos estado ofreciendo hasta ahora con nuestros planes de hosting.

Los packs han sido un componente adicional que hemos incorporado durante años en nuestros servicios de alojamiento; estas plantillas preinstaladas utilizaban un componente llamado Gantry, el cual ya está obsoleto, y hemos considerado oportuno adaptar nuestras aplicaciones a una instalación básica con las actualizaciones de seguridad más modernas ya incluidas y comprobadas.

Los pack's que tengas instalados seguirán funcionando pero tienes que tener en cuenta que no recibirán actualizaciones.

Al hacerlo, la web dejó de funcionar.
Más que por plantilla casi me decanto por alguna extensión.

para probarlo puedes actualizar la versión de PHP y renombrar la carpeta modules, plugins y componentes.
Después de eso revisa si carga la web, por supuesto que no cargara bien ya que le falta las extensiones pero podrás comprobar si el problema es de la web o de alguna extensión.

Un saludo

ResponderCitar
Respondido : 03/10/2018 1:58 pm

Cursos Gratuitos WordPress

Alceste
 Alceste
Noble Member

Hola Pepe,
Entonces, ¿qué debemos hacer si el pack queda obsoleto? Debemos cambiar a otra plantilla y adquirirla directamente a un desarrollador o hay alguna opción dentro de las aplicaciones que ofrecéis en Webempresa?

Saludos

ResponderCitar
Respondido : 03/10/2018 2:10 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

Dentro de aplicaciones solo tienes los instaladores de joomla, wordpress y prestashop, son instalaciones limpias con las ultimas actualizaciones.

Debemos cambiar a otra plantilla y adquirirla directamente a un desarrollador
Si quieres cambiar de plantilla si,

En esta entrada del blog, tienes un articulo donde hay sitios para descargar plantilla gratuitas:
-> https://www.webempresa.com/blog/las-10-mejores-plantillas-gratuitas-responsive-para-joomla-3x.html

Un saludo

ResponderCitar
Respondido : 03/10/2018 2:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola Pepe,
No es que queramos cambiar de planilla pero por lo que comentas entiendo que está obsoleta ¿Lo he entendido bien?

estas plantillas preinstaladas utilizaban un componente llamado Gantry, el cual ya está obsoleto

Si están obsoletas, tendremos que cambiar más pronto que tarde, supongo. Si no fuera necesario hacerlo, mejor.
Por cierto, el error de carga de la web al pasar a PHP 7.1+ parece que se debía a un plugin, tal como indicabas.

Saludos y gracias

ResponderCitar
Respondido : 03/10/2018 2:34 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

Si están obsoletas, tendremos que cambiar más pronto que tarde, supongo. Si no fuera necesario hacerlo, mejor.

En principio no tendrás problemas en seguir actualizando los componentes tanto gantry como las demás extensiones que tengas, estos se siguen actualizando y mientras dure la rama 3x de joomla no creo que tengas problemas en utilizar la plantilla que tienes.

Puedes aprovechar e instalarte un aplicación en una carpeta independiente y empezar a trabajar con esa instalación.

Si vas a empezar desde cero prueba a utilizar Worpress con woocommerce, por ejemplo woocommerce tiene la siguiente plantilla que podrías utilizar para montar la tienda:

-> https://woocommerce.com/storefront/

En este enlace tienes mas plantilla gratuitas para wordpress y woocommerce:
-> https://justfreethemes.com/themes/woocommerce/

Un saludo

ResponderCitar
Respondido : 03/10/2018 2:53 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alceste
 Alceste
Noble Member

De acuerdo, cuando finalice la rama Joomla 3, veré si puedo pasarme a Worpress con woocommerce
Entretanto quería saber si estos errores pueden subsanarse ya que creo que el de REDJ es lo que origina que la web no cargue bien con PHP7.1+ Sobre todo me interesa el de RedJ ya que si van a fallar los redireccionamientos supongo que tendré que encontrar una alternativa a este componente o ver como importar las redirecciones... De lo contrario me fallará la web.

[03-Oct-2018 13:21:46 Europe/Berlin] PHP Fatal error: Uncaught TypeError: Argument 1 passed to plgSystemReDJ::customException() must be an instance of Exception, instance of Error given in /home/MICUENTA/public_html/MICARPETA/plugins/system/redj/redj.php:673
Stack trace:
#0 [internal function]: plgSystemReDJ::customException(Object(Error))
#1 {main}
thrown in /home/MICUENTA/public_html/MICARPETA/plugins/system/redj/redj.php on line 673

[04-Oct-2018 10:55:36 Europe/Berlin] PHP Warning: Division by zero in /home/MICUENTA/public_html/MICARPETA/templates/epimeteo/html/com_virtuemart/category/default.php on line 182

Saludos y gracias

ResponderCitar
Respondido : 04/10/2018 12:04 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alceste.

El problema viene por la versión de PHP.

¿ Que versión tienes del plugin ? por lo que veo en las características desde la versión 1.8.0 es compatible con php 7

-> https://extensions.joomla.org/extension/redj/

Revisa la versión de plugin y actualiza a la última versión que es la 1.9.0

Un saludo

ResponderCitar
Respondido : 04/10/2018 12:44 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola,
Ya he actualizado a esta versión. La web funciona con PHP, 7.0.32 pero no con PHP 7.1+ aunqué no estoy seguro de si se debe a este plugin. Con PHP 7.1+ en la web fallan solamente con algunos elementos del menú. Además me engaña :dry: tardan un poco en fallar (tema cache?) quiero decir que puedo navegar un poco sin problemas y de repente aparece el error. No alcanzo a ver qué componente o módulo puede estar dando el problema. He desactivado varios y no doy con la causa.
El error que muesta es este:

Error: 0 - [] operator not supported for strings

You may not be able to visit this page because of:

an out-of-date bookmark/favourite
a search engine that has an out-of-date listing for this site
a mistyped address
you have no access to this page
The requested resource was not found.
An error has occurred while processing your request.

De momento voy trabajando con PHP, 7.0.32. En unos dás actualizaré VM y veré si se soluciona. Ya hos informaré.
Saludos y gracias

ResponderCitar
Respondido : 04/10/2018 1:24 pm