Avisos
Vaciar todo

Problema al instalar unos modulo que uso habitualmente  

 
Thomas
 Thomas
Reputable Member

Estoy instalando el chronoforms 5 y el choronoconnecticity 5 que uso a menudo con las webs de mis clientes.

Pero ahora no me deja instalarlo.

No se si es por la versión de Joomla de esta instalacion 3.6 o por ser la web cabecera del servidor.

Este es el mensaje que me muestra al instalar el chornoforms 5

exception 'UnexpectedValueException' with message 'JTableMenu::_getNode(1, ) failed.' in /home/thomaswe/public_html/libraries/joomla/table/nested.php:1542 Stack trace: #0 /home/thomaswe/public_html/libraries/joomla/table/nested.php(784): JTableNested->_getNode(1) #1 /home/thomaswe/public_html/libraries/legacy/table/menu.php(208): JTableNested->store(false) #2 /home/thomaswe/public_html/libraries/cms/installer/adapter/component.php(1289): JTableMenu->store() #3 /home/thomaswe/public_html/libraries/cms/installer/adapter/component.php(848): JInstallerAdapterComponent->_buildAdminMenus('10083') #4 /home/thomaswe/public_html/libraries/cms/installer/adapter/component.php(233): JInstallerAdapterComponent->update() #5 /home/thomaswe/public_html/libraries/cms/installer/installer.php(453): JInstallerAdapterComponent->install() #6 /home/thomaswe/public_html/libraries/cms/installer/adapter/package.php(221): JInstaller->install('/home/thomaswe/...') #7 /home/thomaswe/public_html/libraries/cms/installer/installer.php(453): JInstallerAdapterPackage->install() #8 /home/thomaswe/public_html/administrator/components/com_installer/models/install.php(157): JInstaller->install('/home/thomaswe/...') #9 /home/thomaswe/public_html/administrator/components/com_installer/controllers/install.php(30): InstallerModelInstall->install() #10 /home/thomaswe/public_html/libraries/legacy/controller/legacy.php(730): InstallerControllerInstall->install() #11 /home/thomaswe/public_html/administrator/components/com_installer/installer.php(19): JControllerLegacy->execute('install') #12 /home/thomaswe/public_html/libraries/cms/component/helper.php(352): require_once('/home/thomaswe/...') #13 /home/thomaswe/public_html/libraries/cms/component/helper.php(332): JComponentHelper::executeComponent('/home/thomaswe/...') #14 /home/thomaswe/public_html/libraries/cms/application/administrator.php(98): JComponentHelper::renderComponent('com_installer') #15 /home/thomaswe/public_html/libraries/cms/application/administrator.php(159): JApplicationAdministrator->dispatch() #16 /home/thomaswe/public_html/libraries/cms/application/cms.php(251): JApplicationAdministrator->doExecute() #17 /home/thomaswe/public_html/administrator/index.php(42): JApplicationCms->execute() #18 {main}

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 25/02/2015 12:55 pm
Julen
 Julen
Miembro Admin

Hola,

Al parecer este error aparece cuando se intenta instalar algún componente y el instalador no puede crear el menu necesario de este componente en el area de administración. Debido a que no puede acceder a los permisos en la tabla menu de nuestra instalación.

Este mensaje solo te aparece cuando vas a instalar el modulo chronoforms o con todos?

Saludos

Saludos

ResponderCitar
Respondido : 25/02/2015 2:09 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Thomas
 Thomas
Reputable Member

Acabo de instalar un modulo SJLOGIN y funciona.

Como puedo arreglarlo??

TOMAS

ResponderCitar
Respondido : 25/02/2015 5:06 pm
Thomas
 Thomas
Reputable Member

Acabo de instalar el mismo modulo chronoforms en otra web con la ultima version de joomla y funciona bien. Osea parece problema de thomaswebb.es o de que sea cabecera.

TOMAS

ResponderCitar
Respondido : 25/02/2015 5:17 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Las versiones de Joomla son iguales en ambos sitios ? , es posible que ya hayas instalado chronoforms antes en la web en donde tienes problemas, verifica esto, puedes comprobar desde extensiones => gestor de extensiones

Saludos.

ResponderCitar
Respondido : 25/02/2015 6:58 pm
Thomas
 Thomas
Reputable Member

Si es la misma

Y he instalado y desintalado el choroforms varias veces en ambos sirios

y en escaparate.thomaswebb.es va bien pero en thomaswebb.es NO

ResponderCitar
Respondido : 25/02/2015 7:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba ir a Extensiones => Gestor de Extensiones , y luego Base de datos y prueba Corregir la BD

Tambíen en Menus => Gestor de menus => Reconstruir

Saludos.

ResponderCitar
Respondido : 25/02/2015 8:52 pm
Thomas
 Thomas
Reputable Member

lo he probado pero no ocurre nada.
He probado una version nueva que hay y tampoco

La opcion extensiones base datos reconstruir bien pero no veo cambios
la opcion menu gestor de menus reconstruir abre pagina en blanco y no hace nada de nada.

Que puedo hacer??

ResponderCitar
Respondido : 26/02/2015 10:28 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Thomas
 Thomas
Reputable Member

He comprobado que tampoco me deja actualizar modulos DA EL MISMO ERROR
Creo que el hecho que no me deje reconstruir menus es clave.

Algo pasa con esta instalacion que casualmente dio muchos problemas al ser la general de mi cuenta servidor

Puede ser algo de los ficheros htaccess ? No se algo hay
y solo me pasa con thomaswebb.es

TOMAS

ResponderCitar
Respondido : 26/02/2015 11:20 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que haya algún problema en esta web con algunos archivos de Joomla. Podrías probar a reinstalar la actualización de Joomla a la última versión para ver si así se corrigen los problemas. Puedes descargarla desde el sigiuente enlace (versión 3.4.0):

https://github.com/joomla/joomla-cms/releases/download/3.4.0/Joomla_3.4.0-Stable-Update_Package.zip

Es muy importante que antes de probar esto hagas una copia de seguridad completa (archivos y base de datos) de tu web, para poder volver al estado anterior en caso de que surjan problemas. Puedes hacerlo utilizando alguna extensión como Akeeba Backup o XCloner.

ResponderCitar
Respondido : 26/02/2015 2:01 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Thomas
 Thomas
Reputable Member

Nada. sigue dando errores a la hora de instalar extensiones.

Ya no se que puedo hacer.

TOMAS

ResponderCitar
Respondido : 26/02/2015 3:52 pm
Thomas
 Thomas
Reputable Member

He solucionado el problema

El problema está detallado aquí. Hay algo curioso.
https://tamainut.com/blog/software/joomla/item/solucion-al-error-jtablemenu-getnode
Creo que se debería seguir el asunto y tratar de averiguar porque ha podido pasar esto.

Un abrazo a todas y gracias.

TOMAS

ResponderCitar
Respondido : 26/02/2015 4:11 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Al parecer es por un bug de la actualizació de Joomla que elimina el registro del menú primario que que usa otro, esperemos que en versiones futuras se corrija

Saludos.

ResponderCitar
Respondido : 26/02/2015 5:04 pm