Problema con carrito de compra con modo Ajax activado  

Página 2 / 2
 
Juan Antonio
 Juan Antonio
Usuario activo

Buenas tardes,

Tengo un problema raro en mi web. En PC, cuando añado un producto al carrito mediante su botón correspondiente "AÑADIR A LA CESTA" de su página de producto, se realiza sin problema. Pero cuando lo hago a través de un smartphone existen productos que lo hacen correctamente, es decir, se carga su ventana emergente correspondiente (adjunto captura de pantalla) pero otros que no lo hacen (no aparece la ventana emergente), se quedan cargando, aunque si refrescas la página o vas a cualquier otra, se ve el producto añadido en el icono de la cesta (margen superior derecho) ¿qué ocurre?

Pongo un enlace de producto que no se realiza correctamente:
Contenido solo visible a usuarios registrados

Citar
Respondido : 16/12/2019 5:15 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Juan Antonio.

Parece que es un problema de Cookies.

Prueba a recargar la página una vez añadido el cupón con la tecla ( F5 ) y revisa si se muestra las opciones de +-

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 09/01/2020 12:51 pm

Cursos Gratuitos WordPress

Juan Antonio
 Juan Antonio
Usuario activo

Buenos días,

Recargando la página con F5 se muestra las opciones de +-, pero si vuelvo a introducir el código vuelve a pasar lo mismo, por lo que no está bien. He probado en varios navegadores y hace lo mismo. Además, por otro lado, sigue también sin resolverse la otra parte:

En la página de MI CESTA, cuando introduzco un código de descuento en su casilla correspondiente, los botones para aumentar o disminuir la cantidad de cada uno de los productos desaparece y en su lugar aparece un recuadro feo para introducir un número. Además, si después le doy a la X para quitar el código de descuento introducido, no se quita, sino que tengo que darle a recargar la página o irme a otra para que se ejecute dicha acción, al igual que les pasaba a algunos de los productos cuando los añadía a la cesta. Adjunto capturas de pantalla.

Seguís sin contestarme a lo otro ¿qué ocurre?

Me contestasteis pero no hicisteis referencia a estos archivos que me dijisteis que comprobara si existen, y que como le pongo arriba, no existen. Por eso les pregunto que qué pasa si no existen? ¿puede deberse los errores a esto?

Gracias y saludos.

ResponderCitar
Respondido : 10/01/2020 9:06 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Juan antonio.

sigue también sin resolverse la otra parte
No veo en la consola ningún aviso sobre esos archivos, no creo que sea ese el problema.

Lo que veo es que no tienes actualizado prestashop, estás trabajando con al version 7.5.0
.- Actualizar prestashop a la última versión que es la 1.7.6.2

Si tienes una versión de pruebas podrias probar si cambiando de tema el problema se soluciona o persiste, con eso descartas si es de el propio prestashop oo es de tu plantilla.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 10/01/2020 12:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan Antonio
 Juan Antonio
Usuario activo

Hola,

No puedo actualizarlo a la última versión porque varios de los módulos que tengo no funcionarían correctamente, ya me pasó hace unas semanas y tuve que hacer una restauración ¿Puede ser un problema de JavaScript? ¿Cómo lo solucionamos?

Saludos.

ResponderCitar
Respondido : 10/01/2020 12:42 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Juan Antonio.

No, no hay ningún problema de java, en al consola no muestra nada al respecto, por eso te decía de probar con otra plantilla por si el problema lo tienes en la plantilla.

varios de los módulos que tengo no funcionarían correctamente,
Prueba en un clon no el la web que tienes en producción, deshabilitas los módulos que te dan los problemas y pruebas actualizar, revisas si con la actualización se soluciona, si no se soluciona pruebas con otra plantilla, si ves que con otra plantilla funciona todo bien, ya sabes que el problema es de la plantilla que estas utilizando.

Nosotros no podemos probarlo, la plantilla ya que es de pago y no se puede descargar

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 10/01/2020 1:15 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Página 2 / 2

Por favor Iniciar Sesión o Registro