Avisos
Vaciar todo

Problema modulo Stripe en prestashop  

Página 2 / 2
 
LHW
 LHW
Estimable Member

Buenos días,
Tengo instalado el módulo de Stripe desde hace un año aprox.
Desde hace unos días, no funciona. no aparece en la web. Me he dado cuenta hoy :blush:
En lugar de los datos para la tarjeta aparece lo siguiente:

Por probar, si le doy a "comprar ahora" no me lleva tampoco a la página de pago, simplemente cambia la url a la siguiente: Contenido solo visible a usuarios registrados

Citar
Respondido : 04/10/2019 12:19 pm
LHW
 LHW
Estimable Member

Buenas tardes,
Voy a intentar resumir porque pasan cosas raras (raras para mi)
- He comprobado que las claves de la API Stripe son correctas - OK
- He puesto la versión anterior de Stripe restaurando a días antes. No funciona Stripe.
- He actualizado Stripe a la última versión que según ellos si es válida para Prestashop 1.6 . No funciona.
- Desesperada, he cambiado la plantilla Amaltea a la plantilla por defecto de Prestashop con Stripe actualizado. Stripe SI funciona, pero todo se ve mal por no ser la plantila.
- Sin hacer mas cambios, vuelvo a poner mi plantilla, Amaltea, y Si funciona Stripe. (Es decir, actualizando Stripe y activando y desactivando la plantilla, funciona Stripe) Peeero no puedo acceder al menú porque desaparece y se desconfigura la plantilla. Es decir, al entrar las categorías se queda en blanco.
Es decir.
Ahora mismo, funciona Stripe, pero se han desconfigurado la plantilla Amaltea de Webempresa y ha desaparecido el menú.
¿Qué puede ser?
Gracias.
Saludos.

ResponderCitar
Respondido : 04/10/2019 10:14 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola LHW,

Creo que debemos iniciar reparando la carga de contenido mixto en tu web, por favor revisa la siguiente guía -> https://guias.webempresa.com/preguntas-frecuentes/contenido-mixto-tras-activar-ssl-web/

Una vez que tu web cargue todo mediante el protocolo HTTPS, podemos continuar reparando tu web.

Saludos.

ResponderCitar
Respondido : 04/10/2019 10:56 pm
LHW
 LHW
Estimable Member

Buenas noches,
He realizado lo que me dices y el test me dice lo siguiente:
SSL Certificate Info

Certificate Issuer
cPanel, Inc.
Certificate Type
cPanel, Inc. Certification Authority
Issued On
2019-08-21

Force HTTPS
Your webserver is not forcing the use of SSL.
You may want to add a redirect to ensure a secure connection is used. More Info
Valid Certificate
Your SSL Certificate is installed correctly.
Domain Matching
Your SSL certificate matches your domain name!
Protected Domains:

ociostore.com
cpanel.ociostore.com
mail.ociostore.com
ociostore.piscilandiapiscinasdesmontables.com
webdisk.ociostore.com
webmail.ociostore.com
www.ociostore.com
www.ociostore.piscilandiapiscinasdesmontables.com

Signature
Your SSL certificate is using a sha256 signature!
Expiration Date
Your SSL certificate is current. Your SSL certificate expires in 46 days. (2019-11-19)
Protocols
You currently have TLSv1 enabled.
This version of TLS is being phased out. This warning won't break your padlock, however if you run an eCommerce site, PCI requirements state that TLSv1 must be disabled by June 30, 2018.
Mixed Content - Errors
Hard Failure
A file with an insecure url of "http://fonts.googleapis.com/css?family=Merriweather+Sans:300italic,700,300&subset=latin,latin-ext" was loaded on line: 142 of https://www.ociostore.com/es/.
This URL will need to be updated to use a secure URL for your padlock to return.
Hard Failure
A file with an insecure url of "http://fonts.googleapis.com/css?family=Lato:400,700,900&subset=latin,latin-ext" was loaded on line: 143 of https://www.ociostore.com/es/.
This URL will need to be updated to use a secure URL for your padlock to return.

Pero no se como solucionar ese error.
Gracias.
Saludos.

ResponderCitar
Respondido : 04/10/2019 11:06 pm

Cursos Gratuitos WordPress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola LHW!

Bien he revisado con detalle tu web y creo que es necesario que mediante tickets contactes con soporte técnico y comentes que has superado los limites de consumo de recursos de tu hosting debido a los cambios que has realizado en los últimos días, ellos te darán una solución inmediata. Una vez que te den solución veremos cómo se comporta tu sitio, puede ser que la carga de contenido mixto no sea un problema al que debamos prestarle atención.

Saludos.

ResponderCitar
Respondido : 04/10/2019 11:44 pm
LHW
 LHW
Estimable Member

Buenos días,
Desde los tickets me dicen que mi sitio es estable, me han recomendado que desactive un módulo para no consumir tanto recurso (ya lo he hecho).
Volviendo a Stripe, en principio ya funciona.
Porque al hacer esto:

- Desesperada, he cambiado la plantilla Amaltea a la plantilla por defecto de Prestashop con Stripe actualizado. Stripe SI funciona, pero todo se ve mal por no ser la plantila.
- Sin hacer mas cambios, vuelvo a poner mi plantilla, Amaltea, y Si funciona Stripe. (Es decir, actualizando Stripe y activando y desactivando la plantilla, funciona Stripe) Peeero no puedo acceder al menú porque desaparece y se desconfigura la plantilla. Es decir, al entrar las categorías se queda en blanco.
Es decir.
Ahora mismo, funciona Stripe, pero se han desconfigurado la plantilla Amaltea de Webempresa y ha desaparecido el menú.

Y viendo que los módulos de pago si funcionaban realizando la desactivación y activación de la plantilla, me ha parecido mas rápido configurar de nuevo la plantilla.

El único "pero" que tengo actualmente es que el módulo de stripe se muestra asi:

Y se debería ver asi:

O, en su defecto, agregar una fotito o texto donde se indique "Pago con tarjeta"

Cómo puedo hacerlo?
Gracias.
Saludos.

ResponderCitar
Respondido : 05/10/2019 10:59 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola LHW,

Adjunto captura de cómo se muestra desde Chrome:

Según veo el código fuente generado por la página web el campo correspondiente a Pago con tarjeta mediante stripe se inserta mediante un Iframe que llama a funciones propias de Stripe, no creo que sea un problema de tu sitio. ¿En tu cuenta de Stripe no se te permite elegir el estilo del formulario que deseas mostrar al comprador? o desde el módulo de configuración de stripe en tu sitio web, ¿No hay alguna opción que te permita elegir el estilo? ¿Podrías indicarme qué módulo estás utilizando como pasarela de pago? Por favor.

Saludos.

ResponderCitar
Respondido : 05/10/2019 11:30 am
LHW
 LHW
Estimable Member

Buenos días,
¿En tu cuenta de Stripe no se te permite elegir el estilo del formulario que deseas mostrar al comprador? o desde el módulo de configuración de stripe en tu sitio web, ¿No hay alguna opción que te permita elegir el estilo? - No, he revisado todo, desinstalado y reinstalado y no veo ninguna opción que se ajuste a ese detalle.

En cuanto a los módulos, estos son los que tengo actualmente activados:

Y este el módulo de carrito:

Activando y desactivando opciones de ambas sigue igual
¿Qué puedo hacer?
Gracias.
Saludos.

ResponderCitar
Respondido : 09/10/2019 2:12 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

LHW
 LHW
Estimable Member

Buenas tardes,
Continuo.
Después de mi anterior mensaje, he realizado una prueba de pago real y el problema que daba era tremendo: A mi me daba error de pago. Pero cargaba el importe en la tarjeta. Y sin embargo la web no reconocía el pedido "no devolvía a la web correctamente la orden". No existian los pedidos realizados en estos días. Pero en Stripe si.. y el importe cargado. En fin! Un desastre total.
Antes de meterme en un lio gordo, he desinstalado Stripe, y vuelto a instalar otro Stripe diferente (también de Prestashop Addons, pero en lugar de ser gratis, es de pago) Bueno, pues.. funciona!!
(Resumiendo, la solución era retirar el módulo gratuito de Stripe y poner el de pago)
Pero bien, este nuevo módulo que funciona correctamente, no está en castellano, lo que es una faena. Está el Front End en inglés.
No existe la carpeta "Translations" para Español en el módulo.
Aparece asi:

Y Necesito cambiar "Stripe Payment" por "Pago por Tarjeta" y eliminar la frase "order procedesed will be faster"
Cómo lo hago?
Gracias.
Saludos.

ResponderCitar
Respondido : 09/10/2019 5:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Has revisado usando la herramienta de traduccion del propio PrestaShop? Internacional -> Traducciones (Ver imagen), busca traducir los módulos

Si es un módulo de pago si que debería estar pensado para que sea traducible en varios idiomas, has consultado esto con los desarrolladores?

Saludos.

ResponderCitar
Respondido : 09/10/2019 6:20 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

LHW
 LHW
Estimable Member

Buenas tardes,
Si lo he mirado, pero no hay ninguna expresión de las que necesito cambiar.
En cuanto al módulo, yo también creo que debería ser traducible. Pero no lo es, y lo pone de entrada: Idiomas: Inglés.

Hay alguna manera de traductirlo a través de los archivos?
Con la herramienta de Firefox puedo cambiarlo:

Pero luego no soy capaz de localizar el archivo en el administrador de archivos.
Gracias.
Saludos.

ResponderCitar
Respondido : 09/10/2019 6:46 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es posible que entonces las cadenas de texto esten dentro del módulo incluído en la programación.

Al ser un módulo de pago no podemos probar, algo que puedes hacer es el archivo .zip del módulo, descomprimirlo en tu máquina local y luego con alguna herramienta como notepad++ buscar esos textos en toda la carpeta, te localizará los archivos que necesitas cambiar.

Si tienes dudas envíanos capturas de pantalla.

PD. Mejor abre un nuevo hilo de discusión por este problema con el título adecuado, de esta manera mantenemos orden en el foro.

Saludos.

ResponderCitar
Respondido : 09/10/2019 8:18 pm

Cursos Gratuitos WordPress

Página 2 / 2