Avisos
Vaciar todo

Idioma, configuración por defecto  

 
David
 David
Prominent Member

Buenas tardes,
Nos escriben clientes de fuera de España diciéndo que les sale un error al escribir www.ispmusica.com Hemos solicitado capturas de pantalla y vemos que el problema está en que si la IP es de fuera de España, el navegador selecciona la página en inglés, directamente Idioma, http://www.ispmusica.com/index.php?lang=en , la cuál da un error 404 (porque estamos justo ahora con el tema de los idiomas).

Queremos que por defecto cargue la Española http://www.ispmusica.com/index.php?lang=es y suponemos que se trata de un parámetro de configuración. Por fovr ¿Podéis decirnos dónde cambiar este parámetro para que fuera de España no salga ahora mismo este error?

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/12/2013 6:17 pm
David
 David
Prominent Member

Buenas tardes,
Nos escriben clientes de fuera de España diciéndo que les sale un error al escribir www.ispmusica.com Hemos solicitado capturas de pantalla y vemos que el problema está en que si la IP es de fuera de España, el navegador selecciona la página en inglés, directamente Idioma, http://www.ispmusica.com/index.php?lang=en , la cuál da un error 404 (porque estamos justo ahora con el tema de los idiomas).

Queremos que por defecto cargue la Española http://www.ispmusica.com/index.php?lang=es y suponemos que se trata de un parámetro de configuración. Por fovr ¿Podéis decirnos dónde cambiar este parámetro para que fuera de España no salga ahora mismo este error?

Adjuntamos captura. Supongo que la cosa va por aquí (captura adjunta). Hemos cambiado a "Selección de idioma para visitantes nuevos" IDIOMA DEL SITIO y cambio del idioma automático "NO". Antes estaba en idioma del navegador y cambio automatico SI. De todos modos no podemos confirmar si desde fuera (países que no tienen lengua hispana) ahora carga bien o no. ¿Algún comentario o ayuda al respecto? Gracias.

ResponderCitar
Respondido : 19/12/2013 8:24 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

¿Que idioma tienes establecido por defecto en el Gestor de Idiomas?

Entiendo que Español para el frontend por lo menos ¿correcto?.

Trabajas con Multiidiomas y no con JoomFish ¿correcto?.

Saludos

ResponderCitar
Respondido : 19/12/2013 8:24 pm
David
 David
Prominent Member

Hola David,

¿Que idioma tienes establecido por defecto en el Gestor de Idiomas?

Entiendo que Español para el frontend por lo menos ¿correcto?.

Trabajas con Multiidiomas y no con JoomFish ¿correcto?.

Saludos

Hola Luis,
En efecto, hemos quitado Joomfish y trabajamos con Multiidiomas (aunque aún apenas hemos empezado, la web ya está preparada, con los primeros pasos). Está en Español si. Por defecto. Ahora he cambiado los parámetros que indicaba en el post de hace unos segundos. Gracias. Un saludo.

ResponderCitar
Respondido : 19/12/2013 8:27 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

Se que soy un pesado 😀 pero lee la documentación:

- Módulo Estatus Multilenguaje (1ª parte de multi-idiomas en Joomla! 2.5): https://www.webempresa.com/blog/modulo-estatus-multilenguaje-1-parte-de-multi-idiomas-en-joomla-25.html

- Artículos, menús y módulos en multilenguaje (2ª parte de multi-idiomas en Joomla! 2.5):

- Plantillas en un Joomla! con varios idiomas (3ª parte de multi-idiomas en Joomla! 2.5): https://www.webempresa.com/blog/plantillas-en-un-joomla-con-varios-idiomas-3-parte-de-multi-idiomas-en-joomla-25.html

Saludos

ResponderCitar
Respondido : 19/12/2013 8:30 pm
David
 David
Prominent Member

Hola Luis,

La estoy leyendo detenidamente para iniciar el proceso bien desde el principio. Consultaba porque tengo un cliente, europeo, con el que se está cerrando una campaña de todo el año, y desde que hemos pasado a Joomla -multiidioma- (según nos ha indicado hoy) no puede ver la página. Lo cuál pone en peligro nuestra negociación de campaña y no está el horno para bollos.

Lo leo.
Gracias.

ResponderCitar
Respondido : 19/12/2013 8:34 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

Extraño ¿no puede ver el backend o tampoco el frontend?, ¿no será que tiene su IP bloqueada?.

La funcionalidad de desbloqueo de IPs desde tu Área de Cliente se ha mejorado y ya no se encuentra en la pantalla del servicio de hosting.

Esta tarea ahora podrás realizarla cuantas veces necesites desde el asistente Stephan que encontrarás al pulsar en crear ticket desde el Área de Cliente, te permitirá desbloquear la IP desde la que te encuentres logeado en tu Área de Cliente y te devolverá los resultados por pantalla, la nueva versión además de mostrar más información sobre tu cuenta de hosting te indicará el motivo del bloqueo y en el caso que se haya bloqueado por una regla de seguridad te desbloqueará la regla de seguridad en tu cuenta de hosting para que no vuelva a bloquearse por el mismo motivo.

Para solicitar el Desbloqueo y un análisis de tu cuenta de hosting sigue los siguientes pasos:

Accede a tu Área de Cliente www.webempresa.com/areacliente.php y pulsa en "Crear Ticket", verás una nueva pantalla que te permite usar el nuevo Asistente Virtual Stephan, pulsa en "Pedir una revisión automática a Stephan", escoge la cuenta de hosting que quieres revisar y pulsa en "Revisar Cuenta", al cabo de unos 30 segundos te mostrara el resultado del análisis y si no resuelve tu problema podrás crear un nuevo ticket pulsando en la parte inferior en "Quiero crear un nuevo Ticket".

Saludos

ResponderCitar
Respondido : 19/12/2013 9:08 pm
David
 David
Prominent Member

Hola Luis,
El problema no es de bloqueo de IP. Es un error 404 y veo que le carga por defecto la página acabada en EN, es decir que es algo de los idiomas.

El problema de los vídeos (éste y otros que me pasáis en ocasiones) es que no son actuales, y no cuadran con lo que yo veo. Por ejemplo, me pones un enlace de como debo activar el módulo Multi lenguaje y en mi backend, no aparece ese módulo, ni ninguno llamado Status, ni Multilenguaje...

De este modo, es muy dificil que me sirva de ayuda, porque no coincide con mi Backend. Y dedicar tiempo a ver cosas que no me resuelven los problemas, ni se parecen a lo que yo veo..... es poco productivo.

En el vídeo habla de un Plugin que no existe en el backend. Adjunto captura.

Un saludo

ResponderCitar
Respondido : 19/12/2013 9:21 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

A juzgar por tu respuesta me da la sensación que que no has visto el primero vídeo sobre la instalación de idiomas y su correspondiente activación.

¿Puedes facilitar la siguiente captura?

Saludos

ResponderCitar
Respondido : 19/12/2013 9:31 pm
David
 David
Prominent Member

Voy a revisarlo, a ver si se me escapa algo pero el primer video habla del Modulo Status Multilenguaje. Y ese módulo no está entre los mios (o yo no lo veo). Releo.

El primer video que me indicas comienza así:

"Para publicar el módulo Estatus Multilenguaje, hemos de acceder a la administración de Joomla! -> extensiones -> gestor de módulos -> administrador -> editar Multilanguage status -> seleccionar la posición status y publicarlo. Entonces nos tiene que aparecer en la parte superior derecha de la administración de Joomla! 2.5 tal como se muestra en la imagen:"

O hay otro vídeo previo, o da por hecho que existe un módulo que en mi panel no está.

La captura que me comentas

ResponderCitar
Respondido : 19/12/2013 9:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola David,

Verifica cambiando los parámetros del plugin:

Selección de idioma para los nuevos visitantes: configuración global
Quitar prefijo del idioma predeterminado: No

Por otro lado parece ser un problema del multilenguaje si forzamos al español funciona: Contenido solo visible a usuarios registrados sin embargo no veo la bandera o la opción para cambiar a ingles.

Saludos.

ResponderCitar
Respondido : 20/12/2013 3:22 am
David
 David
Prominent Member

Buenos días,

Me asaltan varias dudas sobre el tema abordado en este hilo y quedaron sin respuesta ayer.

1. En el vídeotutorial al que Luis me ha remitido dos veces, se habla de un plugin que no existe por defecto en nuestra plantilla. He mirado en tres proyectos y no está en ninguno de los tres. STATUS MULTILENGUAJE. No es posible seguir el tutorial tal y como se describe. Ruego indicaciones al respecto.

2. En nuestro caso empezamos por virtuemart. Siguiendo un video-tutorial de Jhon. Aunque no nos aparece la bandera inglesa, si la posibilidad de traducir todos los productos y categorias etc. Jhon habla de tres menus. Uno en castellano, uno en inglés y otro "neutro" ¿Para que sirve el neutro? Nosotros solo tenemos dos (en menú principal) Español e inglés. De todos modos NO NOS APARECE LA BANDERA INGLESA, ni en backend (el grafico bandera) ni en el frontend.

Rogamos ayuda, porque además los clientes (que no son españoles) nos dicen que no se ve, y es que les carga por defecto la página en inglés, que ahora mismo da un error 404.

Estamos atascados y no sabemos por dónde seguir.

Gracias de antemano

ResponderCitar
Respondido : 20/12/2013 10:02 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Sobre el módulo de estatus multilenguaje lo deberías de tener instalado ya que viene con el propio Joomla. Otra cosa distinta es que no te salga en el listado de módulos de la administración porque no tengas ninguna instancia del mismo.

Vete al gestor de módulos y vete a los módulos de administración. Ahora pulsa en el botón Nuevo y comprueba si te deja crear un módulo de tipo Estatus multilenguaje. De ser así lo podrás crear y situarlo en la posición status.

Sobre la traducción de Virtuemart, los productos y categorías entiendo que ya los puedes traducir a los 2 idiomas, por lo que no debes preocuparte del menú neutro sino de comprobar que cuando te encuentras en el idioma inglés salgan los productos en inglés y cuando estés en españos salgan los productos en español.

Sobre lo último que comentas, si has realizado los cambios que te ha comentado Johnny en el plugin deberían de quedar solventados los problemas. Ahora bien, si un usuario a entrado en tu web antes de aplicar el cambio el posible que le haya guardado el idioma en la cookie, por lo que al entrar ahora todavía le mantendría el idioma inglés. Podrías comentar a alguno de esos clientes con problemas que prueben a borrar las cookies de tu página para ver si el problema persiste.

ResponderCitar
Respondido : 20/12/2013 11:09 am
David
 David
Prominent Member

Gracias Pablo.
Solucionado.

ResponderCitar
Respondido : 20/12/2013 9:19 pm

Cursos Gratuitos WordPress