Avisos
Vaciar todo

vista del modulo buscar productos  

Página 2 / 4
 
Manuel Casas González
 Manuel Casas González
Usuario experto

Hola.
Mirando las opciones básicas del módulo "buscar productos", seleccioné "yes" en "botón de buscar" y también "yes" en "botón como imagen". Después los coloqué ambos en "no".
El caso es que se ha quedado un "0" en la derecha del cajetín "buscar productos..." de la vista de la página web.
Lo podeis ver entrando en nuestra página.
¿Cómo lo podemos quitar?
Otra cosa, que es lo que pretendía mirando las opciones de este módulo: ¿se puede hacer que sea al pulsar el dibujo de la lupa del cajetín cuando haga la búsqueda? (en lugar de darle a "Enter" o de tener que mostrar el "botón buscar")

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 12/09/2012 6:32 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Francisco,

Si despublicas el modulo, desaparece el buscador junto con el cero?

Saludos.

ResponderCitar
Respondido : 21/09/2012 4:24 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Manuel Casas González
 Manuel Casas González
Usuario experto

Exactamente.
Desaparece el buscador junto con el "0".

ResponderCitar
Respondido : 21/09/2012 9:11 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Francisco,

¿ Has realizado alguna actualización de Virtuemart ?

Saludos

ResponderCitar
Respondido : 21/09/2012 9:51 am

Cursos Gratuitos WordPress

Manuel Casas González
 Manuel Casas González
Usuario experto

sí.
de virtuemart 2.0.6 a 2.0.8e
Después de hacerlo no observamos nada anómalo.
Pero el módulo buscar productos no lo habíamos intentado configurar con el 2.0.6, sino hasta unos dias después de actualizar a la 2.0.8e.

ResponderCitar
Respondido : 21/09/2012 9:58 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Francisco García,

Deberías, previa copia de seguridad actualizarte a VirtueMart 2.0.10 estable, que soluciona unas cuantos cosas importantes, algunas relativas a vistas de themes.

Saludos

ResponderCitar
Respondido : 21/09/2012 11:15 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Manuel Casas González
 Manuel Casas González
Usuario experto

Hola, Luis.
Acabo de hacer la copia de seg con el akkeba y me disponía a actualizar virtuemart tal y como comentas.
Ya os digo algo.
Un saludo y gracias a todos.

ResponderCitar
Respondido : 21/09/2012 11:26 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Francisco García,

Previa copia de seguridad con Akeeba Backup, yo volveria al estado anterior a:

Ubica la carpeta:
/templates/gk_boutique/html/mod_virtuemart_search

Y renombrala por
templates/gk_boutique/html/backup_mod_virtuemart_search

Verifica si con eso aún sigue apareciendo el cero.

Saludos

ResponderCitar
Respondido : 21/09/2012 11:55 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Manuel Casas González
 Manuel Casas González
Usuario experto

Muchas Gracias Luis, me has avisado justo a tiempo.

ResponderCitar
Respondido : 21/09/2012 11:59 am
Manuel Casas González
 Manuel Casas González
Usuario experto

Hola. Ya he actualizado. No observo cambios.
Todo funciona bien todo se ve bien...
... incluso se sigue viendo el dichoso "0".

Otra cosa: Cuando busco algo en la web, en la pantalla de los resultados sale "escoger tipo de producto", con su cuadro de "seleccionar": ¿cómo podría hacer para que esto desaparezca y no se vea más?

ResponderCitar
Respondido : 21/09/2012 12:26 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Francisco García,

Perdona que insista en el tema ¿seguro que no modificaste el módulo "search" de la plantilla en /html o en otro archivo y se te colo ese cero (0)?

Veo que está incrustado en el div:

Saludos

ResponderCitar
Respondido : 21/09/2012 12:40 pm
Manuel Casas González
 Manuel Casas González
Usuario experto

Me haces dudar, pero... hay alguna forma de que lo modificara sin darme cuanta? ¿sin editar ese archivo? es queno se me ocurre cómo podría haberlo modificado. Yo ahí no he entrado nunca. Ni siquiera sabría situar ni encontar el código que me indicas.
Cuando apareció el "0", yo lo único que estuve modificando fueron las opciones de configuración del módulo.
No sé... modifiqué el número de caracteres de 20 a 30, y metí una ristra de digitos para ver si entraban 20 o 30 o qué. A lo mejor se salió el cero por el final.
En fin...
De todas formas, si teneis localizado ese "0" en el código, ¿no bastaría con borrarlo para solucionar este tema?
Ah! también toque el módulo VM - Search in Shop que estaba habilitado y las opciones de configuración parecen iguales que las de "buscar productos". Sólo toqué las opciones de configuración, desde luego. Y no observé cambios. Luego me di cuenta que lo que sí provocaba cambios era en "buscar productos" y me olvidé del VM - Search in Shop (creo que lo dejé configurado tal y como estaba, aunque no creo que esto tenga que ver.

ResponderCitar
Respondido : 21/09/2012 1:01 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Francisco García,

Cuando apareció el "0", yo lo único que estuve modificando fueron las opciones de configuración del módulo.

Facilitanos una captura de esa configuración a ver si vemos algo extraño 🙂

Saludos y ánimo!! 😉

ResponderCitar
Respondido : 21/09/2012 1:47 pm
Manuel Casas González
 Manuel Casas González
Usuario experto

Hola, Luis.
Te adjunto dos primeras pantallas: los detalles del gestor de módulos y la de opciones avanzadas (en esta última nunca he tocado nada).
La captura opciones básicas 0 es la configuración con la que sale el cero. El cero se mueve según configuremos de una forma o de otra en "posición de buscar" (derecha, izquierda y principio son las tres capturas que os paso).
La captura opciones basicas 1 te muestra... bueno, ya lo ves. Desaparece el cero cuando marcamos "botón de búsqueda:yes". Esta función la he recuperado cuando actualicé a VM 2.0.10 esta mañana. La había perdido desde el mismo momento en que apareció el cero. De todas formas es que no nos gustó como quedaba (además habría que cambiar el nombre del botón de búsqueda, quitar "search" y poner "buscar" u otra cosa, y no sé como), y por eso al querer dejarlo como al principio, que nos parecía más limpio y presentable, fue cuando vimos el cero.
Si de verdad no hay forma de quitar ese cero (insisto: si lo teneis localizado en "el código" no bastaría con borrarlo?), nos resignaríamos a tener el botón de búsqueda, pero cambiando "search" por "buscar", aunque lo vemos repetitivo y que no aporta nada.
De hecho, nos metimos en este jaleo sólo por ver si podíamos hacer "activa" la figura de la lupa que aparece en el cuadro de busqueda de producto, osea, que lo que ahora es el botón "search" pudiera ser el dibujo de la lupa.
Bueno, algo hemos avanzado.
Esperamos sugerencias en un sentido uo en otro.
Gracias.

ResponderCitar
Respondido : 21/09/2012 6:15 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Manuel Casas González
 Manuel Casas González
Usuario experto

Parece que no se ha publicado una de las capturas.
Es esta.

ResponderCitar
Respondido : 21/09/2012 6:17 pm
Manuel Casas González
 Manuel Casas González
Usuario experto

no sé porque no la carga. a ver ahora que la hecho nueva y pesa menos

ResponderCitar
Respondido : 21/09/2012 6:30 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 2 / 4