[Resuelto] TPV Virtual ha dejado de funcionar.  

 
Carlos Omar
 Carlos Omar
Usuario experto

Buenas tardes.

HE actualizado la plantilla que tenía antes (HELENA). Y he comprado la plantilla de PORTO.

La página la tengo ya operativa. He recibido correctamente pagos por paypal, pero los pagos por el TPV virtual no están pasando.

El plugin que estoy utilizado es el siguiente Redsys WooCommerce Versión 2.8.2 | Por Redsys

Esto ha ocurrido al cambiar la plantilla.

Me urge solución, ya que no estoy recibiendo pedidos  por la TPV virtual.

Muchas gracias de antemano

Captura web 8 2 2021 224541 jalapenostugitana.es

 

Adjunto captura de pantalla.

Contenido solo visible a usuarios registrados

Respondido : 08/02/2021 9:54 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Carlos,

Veo un par de errores en tu WordPress que podrían estar relacionados con el problema que nos planteas:

  • Las entradas de las filas site_url y home de la tabla wp_options no coinciden, para reparar este error de configuración revisa el siguiente artículo -> urls-de-dominio-en-wordpress-configuralas-correctamente, ambos registros deberían coincidir y deben ser: Contenido solo visible a usuarios registrados
Para este segundo problema te sugiero desactivar el plugin de RokCommon Library.
 

Luego de realizar lo anterior prueba nuevamente con el TPV, si vuelve a dar error entonces desactiva todos los plugins excepto el del TPV y Woocommerce. 

Nota: Doy por echo que tus plugins y template se encuentran completamente actualizados, si me equivoco, por favor, actualízalos.

Saludos 🙂

Respondido : 08/02/2021 10:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Carlos Omar
 Carlos Omar
Usuario experto

@bulmaro-webempresa

Hola Bulmaro.

Gracias por la pronta respuesta.

Tengo una duda porque antes de actualizar la plantilla el TPV iba de maravilla y ahora no va.

Respondido por: @bulmaro-webempresa

Las entradas de las filas site_url y home de la tabla wp_options no coinciden

Sobre el primer error que me comentas si siempre lo he tenido así y antes no había dado problemas. ¿Porque lo debería de cambiar?. Es que me da nervios tocar eso y que luego no vaya bien otra cosa.  Te envío captura de pantalla de como esta.

 

Screenshot 2021 02 08 wp config php Administrador de archivos cPanel v3
Respondido por: @bulmaro-webempresa

jalapeno/public_html/productosfrescosmexicanos.es/wp-content/plugins/wp_rokcommon/RokCommon/Service/ContainerImpl.php:195

En cuanto a esto es un dominio que no estoy utilizando. No creo que tenga que ver con el problema inicial. Corrígeme si me equivoco.

 

Saludos

 

Respondido : 08/02/2021 10:38 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@biroscahotmail-com

Hola Carlos, 

Eso que me muestras corresponde a la ocnfiguración del fichero wp-config.php si no me equivoco, el problema que yo veo y que quizás algo tenga que ver es que desde el administrador de Wordpress estos valores son distintos. Si quieres mantenerlos distintos y crees que no tem prejudican puedes dejarlos así. Mi recomedación es que los datos sean consistentes.

¿Has probado ya descativando todos los plugins excepto Woocommerce y el del TPV? Si ya lo hiciste y el problema persiste entonces prueba cambiando temporalmente de template. 

Saludos

Respondido : 08/02/2021 11:46 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Carlos Omar
 Carlos Omar
Usuario experto

@bulmaro-webempresa

Buenos dias.

He realizado lo siguiente.

  • Actualizo plugin de Versión 2.8.2 a Versión 3.1.1 Con la actualización se ha solucionado el problema.

Pueden cerrar el tema.

Muchas gracias

Respondido : 09/02/2021 6:58 am