Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

No me deja actualizar ni instalar Plugins  

 
Ana Laura
 Ana Laura
Usuario activo

Cuando ingreso a mi WordPress, y quiero instalar un plug-ins, me dice instalación fallida, o si quiero actualizar uno me dice actualización fallida

Contenido solo visible a usuarios registrados

Citar
Respondido : 27/02/2023 3:33 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana Laura, 

Por ahora veo que Learndash está generando un error fatal en tu sitio web, es posible que este sea él causando que no logres instalar nuevos plugins

[27-Feb-2023 14:32:36 UTC] PHP Fatal error: Uncaught TypeError: Argument 2 passed to LearnDash\Hub\Component\Projects::look_project() must be of the type array, object given, called in /home/inibepco/public_html/inibep.com/wp-content/plugins/learndash-hub/src/controller/class-projects-controller.php on line 239 and defined in /home/inibepco/public_html/inibep.com/wp-content/plugins/learndash-hub/src/component/class-projects.php:268

Verifica desactivar este plugin de forma temporal y comprueba si al hacerlo puedes instalar nuevamente plugins sin problemas, verifícalo y nos comentas como va todo

Un Saludo 

ResponderCitar
Respondido : 27/02/2023 3:44 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ana Laura
 Ana Laura
Usuario activo

@karen Hola, muchas gracias por escribirme, lo desinstalé e intenté instalar un plugin y me sigue saliendo Instalación fallida, lo raro que tengo un clon del sitio web, y en ese no está pasando esto.

Adicional cuando ingreso a los plugins los menú de alrededor desaparecen, es muy raro, todos los plugins y el wordpress se encuentran actualizados

image
ResponderCitar
Respondido : 27/02/2023 4:31 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Ana Laura, 

En este caso revisa si tienes todos los plugins actualizados relacionados con tu sitio web, si no es así actualízalos. De igual forma comprueba las versiones PHP que tienes en el clon y en tu sitio web activo, si tienes una diferente asigna la misma versión PHP para tu sitio web activo. 

Por último veo que la apariencia del backend de tu sitio web cambia, entiendo que lo añades con algun plugin. Desactiva esta opción y añade la vista por defecto de WordPress luego de ello verifica si al hacerlo los plugins funcionan de forma correcta. 

Verifica estas opciones y nos comentas como va todo

Un Saludo 

ResponderCitar
Respondido : 27/02/2023 4:36 pm

Cursos Gratuitos WordPress

Ana Laura
 Ana Laura
Usuario activo

@karen voy a realizar los cambios que me sugieren, con respecto a la apariencia aún desconozco de donde se realizó esto, actualmente soy la webmaster del sitio web y estoy en ese proceso de conocimiento con los plugins que mi cliente tiene instalados, incluso noté eso, que este wordpress en un poco diferente al que he usado normalmente

ResponderCitar
Respondido : 27/02/2023 4:45 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Ana Laura, 

Tal como comenta mi compañera la interfaz de tu WordPress se ve distinta a lo que seria regularmente, desde el asistente virtual stephan he podido validar que utilizas un complemento externo llamado extendify el cual al parecer modifica en gran medida el aspecto del administrador del sitio.

Tambien dicha herramienta es de paga por lo que no podemos validar su funcionamiento

Toma en consideración los comentarios valiosos de mi compañera, consulta sobre el estatus del sitio y tu nivel de usuario, mientras nosotros estaremos atentos

Saludos!

ResponderCitar
Respondido : 27/02/2023 5:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ana Laura
 Ana Laura
Usuario activo

@bruno-vichetti Ya revisé y siguiendo los pasos que me indican todo está bien, incluso las versiones de php coinciden todo muy bien, pero me sale todavía las actualizaciones e instalaciones fallidas, entonces lo que hice fue restaurar una copia anterior para descartar que haya sido por alguna actualización, después de restaurarla el menú de los plugins apareció y si me deja actualizar, pero instalar nuevos plug-ins no deja, me sale el error de instalación fallida.

No se me ocurre que más puedo ser el problema que lo está causando

ResponderCitar
Respondido : 28/02/2023 5:03 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ana Laura.

Vamos hacer un aprueba.

.- Accede a tu cuenta de wePanel -> Administrador de archivos.

.- Accede a la carpeta donde tienes la instalación y renombra el archivo .htaccess por ejemplo .htaccess_old

.- Accede al administrador de WordPress.

.- Accede ajustes -> Enlaces permanentes y sin realizar ningún cambio pulsa en el botón de Guardar.

Revisa si con eso se solucione y nos comentas.

 

Una cosita mas veo que tienes problemas con un par de plugins:

[28-Feb-2023 04:59:26 UTC] PHP Fatal error: Uncaught TypeError: Argument 2 passed to LearnDash\Hub\Component\Projects::look_project() must be of the type array, object given, called in /home/inibepco/public_html/inibep.com/wp-content/plugins/learndash-hub/src/controller/class-projects-controller.php on line 239 and defined in /home/inibepco/public_html/inibep.com/wp-content/plugins/learndash-hub/src/component/class-projects.php:268
Stack trace:
#0 /home/inibepco/public_html/inibep.com/wp-content/plugins/learndash-hub/src/controller/class-projects-controller.php(239): LearnDash\Hub\Component\Projects->look_project('wordpress-seo', Object(WP_Error))
#1 /home/inibepco/public_html/inibep.com/wp-includes/class-wp-hook.php(307): LearnDash\Hub\Controller\Projects_Controller->filter_plugins_api(false, 'plugin_informat...', Object(stdClass))
#2 /home/inibepco/public_html/inibep.com/wp-includes/plugin.php(191): WP_Hook->apply_filters(false, Array)
#3 /home/inibepco/public_html/inibep.com/wp-admin/includes/plugin-install.php(150): apply_filters('plugins_api', fal in /home/inibepco/public_html/inibep.com/wp-content/plugins/learndash-hub/src/component/class-projects.php on line 268
[28-Feb-2023 04:59:30 UTC] PHP Warning: Declaration of Forminator_Group::markup($field, $views_obj) should be compatible with Forminator_Field::markup($field, $settings = Array) in /home/inibepco/public_html/inibep.com/wp-content/plugins/forminator/library/fields/group.php on line 103

 

Estos errores hacen referencia al plugin forminator y learndash-hub, el que más preocupa es el plugin learndash-hub que no está actualizado, tienes que actualizarlo, el otro es un aviso que no tiene porque afectar al funcionamiento 

 

Un Saludo

ResponderCitar
Respondido : 28/02/2023 10:13 am

Ana Laura
 Ana Laura
Usuario activo

@pepesoler Ya realicé lo de el .htaccess pero no me sigue dejando instalar plugins.

Lo más raro es que hice una copia del sitio web, y  en esa copia si me deja instalar plugins, porque la idea del clon es poder actualizar los plugins sin hacerlo en el original, de igual forma veo que hay backups diario con webempresa y puedo restaurar facilmente, pero de igual forma la copia funciona y el original no, incluso verifiqué sus versiones de php y son las mismas

Parece que Leandarsh no se actualiza desde ahí, creo que debo descargar la nueva versión desde la cuenta de LearnDash, lo intentaré

ResponderCitar
Respondido : 03/03/2023 4:07 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Ana

Leandarsh se actualiza desdes las opciones del plugin siempre que tengas la licencia añadida en el plugin.

.- Desactiva el plugin UiPress y comprueba si la administración de WordPress vuelve a su forma normal y puedes actualizar los plugins sin problemas.

 

Un saludo

 

ResponderCitar
Respondido : 03/03/2023 10:31 am

wpdoctor-revisa-la-salud-de-tu-wordpress