Problema con Lightbox no del todo desconocido  

Página 1 / 2
 
Urko
 Urko
Usuario experto

Hola. Veréis, uno de los mayores problemas con las imágenes de mi web es que no he encontrado un sólo plugin que me convezca. El caso, es que hasta día de hoy, utilizaba el plugin simple lightbox con todas las imágenes de mi web, y la verdad es que no he tenido nunca un sólo problema.

Más adelante, comencé a utilizar también Galería NextGEN, un plugin de pago con el que hacer galerías bonitas. El problema? Es que las imágenes subidas a este plugin me ocupan espacio en el servidor, y para cuando me di cuenta había subido ya un montón de imágenes que ahora mismo no me apetece estar editando.

Así pues, decidí descargarme otro plugin de pago. El Flick Album Gallery Pro, y aquí ya comenzaron los problemas. Con este plugin, se me añadió un recuadro en el footer de mi página, como si hubiera una especie de slideshow permanente sin imágenes. Os escribí aquí sobre dicho problema, y escribí también en la web oficial de dicho plugin. Estuve probando diferentes soluciones, y no di con ninguna solución. Sopesé el problema, y viendo que en el resto de los aspectos el plugin funcionaba bien, y que las imágenes subidas no me ocupaban espacio en el servidor, decidí dejarlo esperanzado por que algún día, al lanzar alguna actualización de dicho plugin (que parece no llegar nunca, y no se si lo hará) se pudiera solucionar este pequeño problema que ya he visto en la red que no es un caso aislado.

El caso es que el lightbox con las imágenes utilizados tanto en ambos plugins, funcionan a la perfección, pero las imágenes alojadas en otros servidores, o incrustadas mediante código html y que antes se mostraban en lightbox cuando se pinchaba sobre ellas, ahora tan sólo se abren mostrando la imagen en una nueva ventana.

Me estoy volviendo loco, he desactivado los plugins comentandos uno a uno para ver de cual de ellos puede proceder el problema, y no he visto cambio alguno. He mirado el css y no encuentro tampoco nada que me de una pista de por que mis imágenes alojadas en el propio servidor de wordpress, o las alojadas en otros como imageschak, no se muestran en lightbox.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/03/2017 9:02 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Urko,

Comprueba que tu versión de PHP en el Hosting sea al menos PHP 5.6

Verifica si la ruta "upload_path" la tienes configurada correctamente en tu web.

Revisa este artículo donde lo explico:
- No dejes que "upload_path" te la juegue en WordPress - https://www.webempresa.com/blog/corrige-la-ruta-upload-path-en-wordpress.html

Si usas NextGEN prueba a deshabilitar plugins como "Simple Lightbox" ya que por defecto NextGEN ya gestiona "lightbox" teóricamente por jQuery.

Asegúrate que NetxGEN no entra en conflicto con las librerías de JS o jQuery que pueda usar DISQUS. Si deshabilitas DISQUS temporalmente puedes hacer pruebas que te permitan evaluar si hay conflictos.

Instalar más plugins de "ligthbox" no necesariamente es la solución, la solución pasa por tener bien configurado WordPress, reducir el uso de plugins a los necesarios y usar plugins estables, que no entren en conflicto con JS o jQuery de tu tema y que estén bien programados.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/03/2017 10:59 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Urko
 Urko
Usuario experto

Gracias Luis. El link que me has dejado del upload_path no funciona. En lo referente al PHP, como puedo saber que versión de PHP tengo ya?

He entrado en phpMyAdmin y me salen varios datos:

Servidor de la base de datos:
Versión del servidor: 5.6.35-cll-lve - MySQL Community Server (GPL)

Servidor web:
Versión del cliente de base de datos: libmysql - 5.1.73

phpMyAdmin:
Acerca de esta versión: 4.0.10.14

ResponderCitar
Respondido : 19/03/2017 11:48 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Urko,

En el siguiente artículo explico como saber que versión de PHP tienes activada y como cambiarla por la deseada:

- Versión de PHP en cPanel ¿cómo cambiarla? - https://www.webempresa.com/blog/version-php-cpanel-como-cambiarla.html

La versión de PHP no tiene relación directa con la versión de phpMyAdmin, son cosas diferentes.

La url del artículo que te cité antes se modificó y yo veo que la tenía mal almacenada, discúlpame. La correcta es esta:

- Corrige la ruta upload path en WordPress - https://www.webempresa.com/blog/corrige-la-ruta-upload-path-en-wordpress.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/03/2017 1:23 am

Cursos Gratuitos WordPress

Urko
 Urko
Usuario experto

Pues ya he podido verificar mi versión de PHP: Versión PHP: 5.6.20

En cuanto a lo de Uploads parece estar bien configurado...

ResponderCitar
Respondido : 20/03/2017 7:21 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Lo que te muestra en la parte inferior no es correcto, un cuadro blanco en espera, es posible que el theme que usas entre en conflicto con el plugin, para descartar esto prueba haciendo un clon de tu sitio e instala el plugin en el clon cambia de theme por uno por defecto (twenty seveenteen por ejemplo) y verifica.

Para clonar tu sitio revisa:
https://www.webempresa.com/blog/clonar-wordpress-en-3-clics-sin-perder-tiempo.html

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/03/2017 10:53 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Urko
 Urko
Usuario experto

Si, ese problema viene derivado por el plugin de Flick. Ya intenté solucionarlo, y escribí en la página oficial de dicho plugin, pero la verdad es que no me da la sensación de que hagan demasiado caso. Aún así, desde que tengo ese problema, las imágenes se mostraban correctamente en forma de lightbox.

Al intentar ponerle remedio a ese problema, fue cuando comenzaron los problemas con el resto de imágenes. Me dijeron que pusiera un código css donde las imágenes se dejarían de ver en lightbox, y al ver el efecto en el resto de las imágenes, borré dicho código css (que por cierto iba implementando en un recuadro del propio plugin que podías editar desde el propio ecritorio de tu wordpress).

ResponderCitar
Respondido : 21/03/2017 8:48 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Urko.

Revisando tu cuenta veo que tienes instalada la versión 5.3 de PHP.

Cambia la versión para que trabaje con la 5.6.
Para cambiarlo solo tienes que eliminar la linea:

AddHandler application/x-httpd-php53 .php

que encontraras en tu archivo .htaccess que encontraras antes de la carpeta Public_html ( no es el .htaccess que tienes en public_html )

Te dejo enlace de con información de como cambiarlo, si ves que tienes problemas para modificarlo, manda un ticket a soporte y mis compañeros realizaran el cambio.

Versión de PHP en cPanel ¿cómo cambiarla?

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 21/03/2017 9:16 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Urko
 Urko
Usuario experto

Vale, ya he leído el tutorial. Tengo una duda. He guardado el original con otro nombre por si al editarlo me creaba algún problemas.

He abierto el archivo con Sublimetext y la única linea que tenía era la que me decías que tenía que eliminar. Así lo he hecho, y el archivo se ha quedado vacio (no pesa nada...) Es lo correcto? Digo por que el problema con las imágenes sigue siendo el mismo. No he notado ningún cambio, aunque ahora borraré el historial y demás...

ResponderCitar
Respondido : 21/03/2017 8:37 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Puedes indicarnos un enlace donde tengas este problema se presenta?.

Por ejemplo veo que no en todas las paginas falla.

Para saber que versión de PHP utilizas puedes ejecutar Stephan: https://guias.webempresa.com/preguntas-frecuentes/como-crear-un-ticket/

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/03/2017 3:19 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Urko
 Urko
Usuario experto

En esa página misma que tu has mostrado, las imágenes grandes, que no están siendo usadad por el plugin de flick, como la de arriba, la de abajo del todo y una por el medio, que están siendo mostradas en un tamaño mayor, no hacen lightbox. Concretamente las que dices si, por que están siendo mostradas con el plugin de flickr. El problema viene derivado de todas las imágenes que no utilizan dicho plugin.

ResponderCitar
Respondido : 22/03/2017 9:31 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Si te refieres a las imágenes grandes que muestras en los post, es por que no estas añadiéndolas en un PopUp

Estas imágenes si que están añadidos en un popup:

Si te das cuenta en el código veras que añade una clase fancybox para abrir la imagen en un PopUp.

Para esas imágenes puedes utilizar el plugin Rokbox, una vez instalado solo tienes que añadir el código para la opción que desees mostrar, 1 imagen, una galería, etc...

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 22/03/2017 12:28 pm

Cursos Gratuitos WordPress

Urko
 Urko
Usuario experto

Gracias!!! Pero no hay una solución que no pase por instalar un nuevo plugin? Es decir, estas imágenes (las que no usan el pop-up por el plugin de flickr) antes si que se visualizaban en formato lightbox sin problema, gracias al plugin de simple lightbox, lo que no entiendo es por que ahora ya no...

ResponderCitar
Respondido : 22/03/2017 3:15 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Tienes algún plugin de optimización o cache en tu sitio?, verifica limpiando cache o desactivando el plugin.

De manera general si es un conflicto de plugins tendrías que evaluar reemplazar alguno de ellos.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/03/2017 8:14 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Urko
 Urko
Usuario experto

Bueno, he limpiado la caché, y he desactivado los dos plugin que podían estar ocasionando el error de las imágenes, que era el de Flickr y el de Nextgen gallery, dejando tan sólo activado el plugin de Simple Lightbox. El resultado es el mismo, las imágenes siguen sin verse con el efecto lightbox...

ResponderCitar
Respondido : 22/03/2017 8:41 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro