Problema con plugin MRW  

 
Nadejda
 Nadejda
Usuario activo

Hola.

Tengo una tienda online con Woocommerce y llevo una semana intentando que reconozca el plugin de MRW (woocommerce-mrw-carrier-v1.8.1) para gestionar los envíos. He probado a instalar el plugin en una versión de la página que tengo en el servidor local y funciona a la primera. Aparece reflejado en la página de Finalizar compra sin tener que hacer ninguna configuración extra. En mi página alojada en vuestro servidor me resulta imposible que aparezca.

He aplicado a la página en el servidor local las mismas modificaciones del style.css y functions.php que tiene la versión alojada en Webempresa, por si pudiese influir. También he probado a activar y desactivar todos los plugins. No hay manera. Dejando las dos páginas iguales en todos los aspectos (mismas modificaciones de código, mismas versiones actualizadas de todos los plugins y la plantilla) el plugin funciona en la versión del servidor local y en la versión alojada en el hosting de Webempresa no hay manera.

Se os ocurre cual puede ser el problema?

Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 22/09/2016 9:10 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es posible que tenga requerimientos mínimos, es una extensión de pago?, de ser el caso has consultado con el soporte del plugin?

Que versión de PHP tienes en tu máquina local?, cuando lo instalas en el servidor aparece algún tipo de error, verifica pasando una revisión con la herramienta Stephan (desde tu área de cliente al hacer un ticket) y verifica si te aparecen mensajes de error recientes.

Saludos.

ResponderCitar
Respondido : 22/09/2016 11:51 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Nadejda
 Nadejda
Usuario activo

Los requerimientos mínimos (librería SOAP y Ajax) los consulté en un ticket y me dijeron que estaban correctos. No es una extensión de pago y el soporte del plugin ya ha intentado solucionarlo sin éxito. Es un plugin que no requiere configuración avanzada. En mi máquina local funcionó con los valores por defecto nada más instalarlo.

Los del soporte han dicho que también han hecho una tienda de pruebas y se les instala sin problemas, al igual que puedo hacerlo yo en mi máquina local. Es la primera vez que les pasa esto.

La versión de PHP en mi máquina local es 5.3.4. y no hay registro de errores en el servidor de Webempresa por la instalación del plugin.

ResponderCitar
Respondido : 23/09/2016 12:40 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Puedes consultar enviando un ticket a soporte si cambiándote a la versión 5.3 te funciona dicho plugin aunque esta versión ya esta quedando obsoleta.

ResponderCitar
Respondido : 23/09/2016 5:28 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Nadejda
 Nadejda
Usuario activo

Ya hice la prueba cambiando la versión de PHP. No hay cambio alguno.

ResponderCitar
Respondido : 23/09/2016 4:17 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Instala un nuevo WordPress de pruebas en una carpeta de tu cuenta de hosting, en este WordPress desde cero instala el plugin y verifica si funciona, con esto se descartaría problema con la configuración de tu cuenta en el servidor.

Saludos.

ResponderCitar
Respondido : 23/09/2016 8:05 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Nadejda
 Nadejda
Usuario activo

El plugin funciona perfectamente a la primera y sin configuración alguna en el sitio de prueba creado. Entiendo que esto significa que el problema radica en la instalación raíz de Wordpress de mi sitio principal.

¿Tiene alguna solución?

ResponderCitar
Respondido : 23/09/2016 9:02 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En que punto exactamente ocurre el problema?, el plugin si se instala en tu sitio web? o es cuando lo activas?

Te aparece algún mensaje de error?

Saludos.

ResponderCitar
Respondido : 23/09/2016 10:59 pm

Cursos Gratuitos WordPress

Nadejda
 Nadejda
Usuario activo

No aparece en ningún momento ningún mensaje de error.

El plugin sirve para automatizar los costes de envío en base a los códigos postales. Tras instalarlo, sin configuración adicional de la sección de Envío de Woocommerce, debería figurar automáticamente en la página de 'Finalizar compra' la opción de envío por mensajería con la tarifa por defecto y la opción de recalcular los gastos en base al código postal.

El plugin se instala y se activa sin problemas en el sitio web. Lo puedo configurar pero no aparece en la página de Finalizar compra. Es como si no existiera.

ResponderCitar
Respondido : 24/09/2016 6:30 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Nadejda.

Si en una plantilla limpia no tienes el problema, me temo que es algo de configuración
¿ Puedes adjuntarnos una captura del modulo y su configuración. ?

Un saludo

ResponderCitar
Respondido : 24/09/2016 3:32 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Nadejda
 Nadejda
Usuario activo

El tema es que es funciona perfectamente en una plantilla idéntica que tengo en mi máquina local. Esta misma mañana estuve comprobando sección a sección que todos los ajustes de Woocommerce fuesen idénticos tanto en la versión local como en la versión de vuestro servidor y lo son. Al igual que los ajustes de CSS y demás modificaciones.

He probado también con versiones anteriores de Woocommerce y pasa lo mismo: se activa el plugin, el módulo de Woocommerce lo reconoce (pues aparece como Activado en la sección de Opciones de envío), pero al ir a la página de Finalizar compra, sale el mensaje de "No hay métodos de envío disponibles".

ResponderCitar
Respondido : 24/09/2016 3:45 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si te aparece algún fichero error_log que haga referencia al plugin: https://www.webempresa.com/blog/que-es-un-error-500-y-como-localizarlo-en-nuestra-web.html

ResponderCitar
Respondido : 24/09/2016 5:12 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Nadejda
 Nadejda
Usuario activo

No hay ficheros error_log que hagan referencia al plugin.

ResponderCitar
Respondido : 24/09/2016 5:48 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Una opción también es desactivar todos los plugins menos el afectado y verificar si funciona, en caso de funcionar estaría entrando en conflicto con otro plugin: https://www.webempresa.com/blog/desactivar-todos-los-plugins-de-wordpress-sin-tocar-la-base-de-datos.html

ResponderCitar
Respondido : 24/09/2016 6:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress