problema con qtranslate x  

 
Juanra
 Juanra
Usuario activo

Tengo un problema con qtranslate x y mi web, y no funciona correctamente no se si porque está tomando el idioma predefinido del mismo que figura en el apartado de actualizaciones donde solo sale el en-US
http://screencast.com/t/tLvbRnVlQ

Eso o no se si hay una cookie o algo similar que haga que a veces me salga mal el idioma por defecto que está configurado en el plugin como el español y cuando cambio el idioma no me cambia el idioma del menú …o puede que algo funcione mal con el theme, no se...

Tengo configurado que en el idioma por defecto no añada /es a la ur pero en el selector de banderas del menu sale la dirección con el /es y duplica le contenido de la web sin directorio

Me puedes orientar por favor?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 23/12/2016 4:13 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El problema sólo se presenta en el menú principal?, prueba crear un widget del mismo menú y ubícalo en otra posición de tu theme y verifica si al cambiar de idioma el texto del menú cambia.

Saludos.

ResponderCitar
Respondido : 23/12/2016 6:51 pm

Cursos Gratuitos WordPress

Juanra
 Juanra
Usuario activo

Hola!! muchas gracias por tu respuesta

He creado un widget con el menu en el footer y me sigue pasando lo mismo. He hecho clic en el menu en inglés y cambia todo excepto los menus que los sigo viendo en castellano. Lo he dejado puesto por si quieres verlo

Saludos!

ResponderCitar
Respondido : 23/12/2016 11:45 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Es probable que el problema se encuentre en el menú, verifica si el siguiente enlace te es de ayuda: https://www.webempresa.com/blog/multiidiomas-en-wordpress-con-qtranslate-x-anade-un-selector-de-idioma-en-el-menu.html

Te adjunto una serie de artículos para que revises en caso de que hayas cometido algún error:

- Multiidiomas en WordPress con qTranslated X - Instalacion y Configuracion - https://www.webempresa.com/blog/item/1823-multiidiomas-en-wordpress-con-qtranslated-x-instalacion-y-configuracion.html
- Migrando las traducciones de qTranslate y mqTranslate a qTranslate X - https://www.webempresa.com/blog/item/1746-migrando-las-traducciones-de-qtranslate-y-mqtranslate-a-qtranslate-x.html
- Multiidiomas en WordPress con qTranslated X - Conmutador de Idiomas - https://www.webempresa.com/blog/item/1824-multiidiomas-en-wordpress-con-qtranslated-x-conmutador-de-idiomas.html
- Multiidiomas en WordPress con qTranslated X - Traduciendo post y entradas - https://www.webempresa.com/blog/item/1827-multiidiomas-en-wordpress-con-qtranslated-x-traduciendo-post-y-entradas.html
- Multiidiomas en WordPress con qTranslate X - Traduciendo Widgets - https://www.webempresa.com/blog/item/1830-multiidiomas-en-wordpress-con-qtranslate-x-traduciendo-widgets.html
- Multiidiomas en WordPress con qTranslate X - Añade un selector de idioma en el Menú - https://www.webempresa.com/blog/item/1831-multiidiomas-en-wordpress-con-qtranslate-x-anade-un-selector-de-idioma-en-el-menu.html
- Multiidiomas en WordPress con qTranslate X - Redirección del idioma - https://www.webempresa.com/blog/item/1838-multiidiomas-en-wordpress-con-qtranslate-x-redireccion-del-idioma.html

ResponderCitar
Respondido : 24/12/2016 12:20 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juanra
 Juanra
Usuario activo

Hola! gracias por tu respuesta

Ya había repasado todas esos temas que me envías antes de postear en el foro. Todo aparentemente está hecho según se describe en esos estupendos posts.

La primera vez que doy a la banderita del otro dioma se muestra la traducción del contenido excepto el del menu. Si inmediatamente después le doy a la tecla de f5 para actualizar entonces esa segunda vez si que carga el menu traducido correctamente...

Un saludo!

ResponderCitar
Respondido : 24/12/2016 12:37 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Por el momento visualizo otra web, lo recomendable es que mantengas la web afectada para poder revisarlo.

ResponderCitar
Respondido : 24/12/2016 5:08 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Juanra
 Juanra
Usuario activo

Hola, yo no he tocado nada, debería estar la misma web ....no entiendo que has podido ver

ResponderCitar
Respondido : 24/12/2016 12:24 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Juanra.

Veo que comentas

Si inmediatamente después le doy a la tecla de f5 para actualizar entonces esa segunda vez si que carga el menu traducido correctamente...

Esto quiere decir que los cambios los realiza bien pero el problema viene mas bien de la cache.

¿ Utilizas algún plugin para la cache de wordpress tipo W3 o Super cache ?
Si es así prueba a desactivarlos y revisa si realiza bien los cambios.

Con esto comprobaremos si el problema viene por alguno de los plugin's de cache.

Un saludo

ResponderCitar
Respondido : 24/12/2016 1:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juanra
 Juanra
Usuario activo

Hola Pepe, gracias!!
No tengo aún ningún plugin de caché instalado, peor pienso que algo debe de pasar en ese sentido, no se que puede ser
Es curioso porque ahora cuando he entrado y he puesto la url sin nada más me ha salido directamente la versión con /en cuando lo tengo configurado para que muestre la versión de acuerdo con el idioma del pc (es español) . Debe de ser porque la última vez que lo cerré debí de hacerlo con la versión en inglés
Saludos!

ResponderCitar
Respondido : 24/12/2016 1:27 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Si, me da la impresión que es tema de cache del navegador.
Para comprobar esto prueba a realizar los mismos pasos en un equipo que no suelas utilizar para acceder a al web ( Otro equipo distinto que puedas tener a mano )

Si ves que todo funciona bien, el problema lo tendrías en la cache de tu navegador, para solucionarlo te dejo un enlace a nuestra guía interna donde se explica como borrar la cache según el navegador que estés utilizando:

Limpiar la caché del navegador

Un Saludo

ResponderCitar
Respondido : 24/12/2016 2:21 pm

Cursos Gratuitos WordPress

Juanra
 Juanra
Usuario activo

Hola!! he probado en distintos pcs y navegadores y pasa lo mismo, incluso en el móvil tb
Saludos!

ResponderCitar
Respondido : 24/12/2016 2:53 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juanra,

Trabajo con qTranslate X (en sus diferentes versiones desde que era qTranslate y luego mqTranslate) desde 2014 y nunca he tenido el problema que comentas en este hilo del Foro.

Para poder ver cual podría ser la causa tendría que ver una captura de las configuraciones globales y de idioma por defecto aplicadas en qTranslate X.

Si en la misma instalación de xxxxxxxxx utilizas el plugin CodeStyling Localization desactívalo porque entrará en conflicto con qTranslate X

Quedo pendiente de tus capturas, gracias!!

Saludos

ResponderCitar
Respondido : 24/12/2016 8:34 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juanra
 Juanra
Usuario activo

Hola, he desactivado el plugin CodeStyling Localization y sigue pasando lo mismo
Ahora solo tengo activos estos 5 plugins
http://screencast.com/t/ilZMCd8NBka

Adjunto las pantallas de configuración del qtranslate x
http://screencast.com/t/o1wlJawcD2w
los idiomas
http://screencast.com/t/XDvq7F9ch
y esta es la configuración avanzada aunque aquí no he tocado nada
http://screencast.com/t/y0xgbrxMzD

A ver si damos con ello. Muchas gracias por el esfuerzo!!
Un saludo!

ResponderCitar
Respondido : 25/12/2016 11:59 am
Juanra
 Juanra
Usuario activo

ya di con ello!!!
hay una característica del theme stokholm que utilizo para lograr transiciones y que acabo de desactivar y era lo que entraba en conflicto con el plugin
es esta parte de la configuración por si le pasa a otra persona
http://screencast.com/t/15Pk256Q

Si borráis la url de la web del mensaje de Luis Alejo os lo agradezco
muchas gracias!
Felices fiestas!

ResponderCitar
Respondido : 25/12/2016 12:07 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Juanra.
Felices Fiestas!!!!! de todo el equipo de Webempresa..... :cheer:

Me alegra que dieras con el problema 😉

Si borráis la url de la web
Por supuesto aquí tu decides 😉

Cerramos el tema.

Un saludo y Felices Fiestas !!!

ResponderCitar
Respondido : 25/12/2016 12:39 pm