Avisos
Vaciar todo

W3 Total caché error 503  

Página 2 / 3
 
Iago
 Iago
Usuario activo

Hola, al activar el plugin w3 total cache mi sitio web devuelve error, tanto en dispositivos móviles como en ordenadores. Es un error 503, normalmente ya desde la portada (guerz.com), pero sino el error salta al navegar por páginas/entradas. Probé desactivando el resto de plugins y dejando solo w3 total caché activo, aunque el error se mantiene. Si desactivo w3 total cache, aun dejando el resto de plugins activos, la web carga correctamente. El motivo por el que instalé w3 es porque los tiempos de carga son altos (page speed de google). La configuración que tengo para el plugin es la que se indica en esta página de webempresa, ya que también uso Magic Caché con el plugin WE-Varnish-Cache: https://guias.webempresa.com/preguntas-frecuentes/magic-cache/

Configuración para w3 total cache:

  • Page Cache: Desactivado
  • Minify: Desactivado
  • Opcode Cache: Déjala como está ( debería aparecerte por defecto como Opcode: Zend Opcache o bien como Not Available , ambos serían valores válidos)
  • Database Cache: Activado
  • Object Cache: Activado
  • Browser Cache: Activado
  • CDN: Desactivado
  • Reverse Proxy: Desactivado


Cualquier ayuda, indicación o sugerencia es apreciada. Si es necesario alguna captura en concreto, puedo aportarla. Un saludo

Contenido solo visible a usuarios registrados

Citar
Respondido : 14/06/2024 10:04 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Iago, 

Los plugins que se recomiendan para Magic caché son:

  • Autoptimize
  • WP Rocket
  • W3 Total Cache

Aunque este último está dando problemas, no veo algo que lo esté ocasionando. Puedes revisar si es algo en tu base de datos que ha quedado incompleto, para ello puedes probar optimizarla con un plugin como → https://co.wordpress.org/plugins/wp-optimize/ tienes un tutorial sobre su uso en esta entrada → https://www.webempresa.com/blog/tutorial-wp-optimize.html

Puedes probarlo y ver como va todo

Un Saludo 

 
Esta publicación ha sido modificada el hace 1 mes por Karen Rios
ResponderCitar
Respondido : 18/06/2024 7:17 pm

Cursos Gratuitos WordPress

Iago
 Iago
Usuario activo

Yo no sé qué es, pero desde que empecé una consulta en Sitemas por un error que me daba al usar un plugin, hasta ahora, solo he seguido punto por punto las indicaciones de unos y otros, sin hacer ninguna otra cosa. Y ahora, el resultado, es un desastre. Si antes tenía un problema por el uso del plugin, ahora se han multiplicado los errores. Durante este proceso de tickets hubo una modificación que hicieron, que según me comentaron fue renombrar un plugin para evitar el error 503. Pues desde esa resulta que ya no puedo desinstalar w3 total cache, porque si lo hago, wordpress da error crítico. Puede estar desactivado, pero no desinstalado. Ahora no tengo web. Esto me parece muy heavy, la verdad. Son ya muchos días y todo está peor. No lo entiendo. 

ResponderCitar
Respondido : 18/06/2024 7:54 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Iago, 

En este caso nosotros desde foro solo podemos darte indicaciones sobre cuál puede ser el problema que sucede, no podemos indicarte de forma precisa porque no podemos acceder a tu sitio web. Una recomendación del plugin de WP Optimice, precisamente es para revisar si tienes algún rastro de plugin anteriores en tu base de datos que puedan generar este conflicto. 

De igual forma, desde cuando comenzaste a experimentar este error?, una alternativa es restaurar la versión de tu sitio web a una fecha donde todo funcione de forma correcta y luego ir revisando como activar el plugin de caché que necesitas, ya sea este u otro. 

Un Saludo 

ResponderCitar
Respondido : 18/06/2024 8:25 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Iago
 Iago
Usuario activo

Hola. Para que no haya lugar a dudas, hago referencia al ticket XPS-159315. Anteriormente y por algún motivo que desconozco, al activar el plugin w3 total cache WordPress comenzaba a generar errores de memoria y otros. Acabo de restaurar la web a un punto previo a la instalación de w3 total cache, es decir a un punto previo a cualquier error. Me gustaría saber si se puede implementar alguna política de caché con este u otro plugin gratuito que mejore la velocidad del sitio web. No valoro en estos momentos comprar wp rocket. Actualmente, los resultados en GTmetrix son malos (una D+) y los de Page Speed de Google son de 50/100 en móviles y 63/100 en escritorio. Soy consciente de que el sitio usa muchas imágenes y no siempre están en el mejor formato. El lazy load que tenía en w3 total cache ya no lo tengo ahora puesto que no tengo el plugin. El sitio web tiene el plugin WE-Varnish-Cache (Magic Cache) instalado y activo, junto con otros 4 plugin activos más. Hay dos plugin inactivos, que los utilizo periódicamente.

Me acaban de comunicar de nuevo y también he leído varias veces que WP Super Cache no es compatible con Magic Cache. De hecho en esta misma guía de Magic Cache de webempresa lo indica: https://guias.webempresa.com/preguntas-frecuentes/magic-cache/

Probé wp-optimize pero no mejoraba los resultados, a veces incluso bajaban ligeramente, aunque puede ser que no sepa configurarlo adecuadamente (incluso viendo la guía de webempresa de este plugin).

Si es posible implementar alguna política de caché gratuita compatible con Magic Cache de forma segura en mi sitio web, agradecería los pasos concretos a seguir. 

ResponderCitar
Respondido : 19/06/2024 12:53 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iago.

Como plugin de Caché, aunque sea de pago, el que mejor rendimiento obtengo es con el de WP Rocket 

Como alternativas puedes utilizar WP Fastest Cache que es compatible con Varnish:

-> https://es.wordpress.org/plugins/wp-fastest-cache/

Otro plugin compatible con varnish puede ser Comet Cache:

-> https://wordpress.org/plugins/comet-cache/

 

Puedes probar a volver a instalar el plugin W3 Total Cache :

-> https://wordpress.org/plugins/w3-total-cache/

.- Pasa el asistente y deja los valores por defecto no modifiques nada.

Cuando lo tengas lo indicas y lo revisamos, comprueba que todo cargue bien.

 

Un saludo

ResponderCitar
Respondido : 19/06/2024 2:35 pm

Iago
 Iago
Usuario activo

Hola de nuevo. Ya he instalado w3 total caché y he pasado el asistente, dejando todas las opciones que vienen por defecto (adjunto las imágenes). No he tocado ni modificado nada más. He navegado por todo el sitio en modo incógnito desde varios dispositivos, de escritorio y móviles, sin encontrar errores. Un saludo.

Asistente w3   Cache de objetos
Asistente w3   Cache navegador
Asistente w3   Cache de pagina
Asistente w3   Carga diferida
Asistente w3   Optimizacion de imagen
Asistente w3   Cache base datos

 

ResponderCitar
Respondido : 19/06/2024 3:48 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Iago, 

De acuerdo, probemos activar las configuraciones generales sobre el plugin, accede a Rendimiento Ajustes Generales y activa las siguientes opciones como se muestran en la imagen

image
image
image

Guarda los cambios y vacía la caché de Varnish, navega en el sitio web y comprueba como se muestra todo. De igual forma revisa la prueba de velocidad 

Un Saludo 

 

ResponderCitar
Respondido : 19/06/2024 4:43 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Iago
 Iago
Usuario activo

Hola de nuevo. He activado las configuraciones generales de w3 total cache tal y como muestran las imágenes, y vaciado la caché de Varnish. Al navegar en modo incógnito por el sitio web tras estos cambios, carga la portada correctamente y sin errores. Las entradas y las páginas sí que dan error (adjunto captura de portada, entrada y página). Un saludo.

Error entradas tras ajustes iniciales w3 total cache
Error páginas tras ajustes iniciales w3 total cache
Portada tras ajustes iniciales w3 total cache

La prueba de velocidad baja ligeramente para dispositivos móviles. Antes de los cambios era de 53/100 y después de estos cambios es de 42/100. Para escritorio no hay variación. Aquí las capturas de pantalla:

PageSpeed ANTES de ajustes iniciales w3 total cache   portada del sitio
PageSpeed DESPUES de ajustes iniciales w3 total cache   portada del sitio
Esta publicación ha sido modificada el hace 1 mes 3 veces por Iago
ResponderCitar
Respondido : 19/06/2024 5:25 pm
Iago
 Iago
Usuario activo

Hola, alguna novedad? El sitio está totalmente caído.

ResponderCitar
Respondido : 20/06/2024 9:16 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iago.

Restauraste la Web o hiciste algo ?

Veo que no carga bien y eso no es de el plugin de cache:

screenshot guerz.com 2024.06.20 13 00 37

Restaura la web a uan fecha donde cargaba bien.

Una vez restaurada, comprueba que carguen los estilos y se muestra bien.

.- Desinstala el plugin de W3

.- Accede a tu cuenta de wePanel -> Administrador de archivos

.- Accede a la carpeta donde tienes la web.

.- Accede a la carpeta wp-content y elimina el archivo db.php

.- Vuelve a instalar el plugin de cache

 

Ten en cuenta que nosotros no tenemos nada que ver con w3 total cache y en su soporte ya reportaron algunos usuarios

-> https://github.com/impress-org/givewp/issues/4267

 

Prueba lo que te indico y vamos viendo si podemos solucionarlo.

 

Haz una cosa para no tener la web caída, cuando restaures realiza un clon de la web:

-> Clonar WordPress

.- En al web en producción desactiva el plugin de W3 Total Cache para no tener el error

.- En el clon activa el plugin de cache

 

Con eso tendras la web en producción activa y hacemos las pruebas en ese clon.

 

Un saludo

 

ResponderCitar
Respondido : 20/06/2024 12:18 pm
Iago
 Iago
Usuario activo

@pepesoler Hola. No, yo no volví a tocar nada desde ayer a las 17:25 pm cuando envié las capturas de pantalla tras haber seguido los pasos para activar las configuraciones generales de w3 que me indicó tu compañera Karen. Desde ayer a esa hora no hice nada de nada. 

Ahora, tras leer tu mensaje, solamente he desactivado el plugin w3 total cache y a mi la web me carga bien. He probado a acceder desde escritorio y móvil, en ambas me carga. No hice nada más, solo desactivé el plugin. 

Indícame por favor si hago el clon de todos modos, que supongo que sí. Un saludo

ResponderCitar
Respondido : 20/06/2024 12:35 pm

Cursos Gratuitos WordPress

Iago
 Iago
Usuario activo

Por cierto, hoy han sacado una actualización del plugin w3 total cache, aún no la he aplicado. ¿La aplico?

ResponderCitar
Respondido : 20/06/2024 12:37 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iago.

Por cierto, hoy han sacado una actualización del plugin w3 total cache, aún no la he aplicado. ¿La aplico?

Si actualízalo.

Si despues de actualizarlo sigues con el error, clona la web y lo revisaremos en ese clon, con eso tendras la web en producción activa mientras revisamos en el clon que puede estar pasando.

 

Un Saludo

 

ResponderCitar
Respondido : 20/06/2024 12:45 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Iago
 Iago
Usuario activo

@pepesoler Hola de nuevo Pepe. Actualicé el plugin y comprobé que con él activo no hay error 503 (al menos por ahora), pero seguía mostrando la web rara (como si perdiera los estilos CSS). Entonces desactivé el plugin, instalé el clon de wordpress en el dominio principal seguido de /pruebas/ y luego activé el plugin solamente en el wordpress clonado. 

He revisado el hilo que me enviaste y el forum del plugin en wordpress. Leí que algunos usuarios tuvieron el error 503 hace tiempo. No sé si esto es lo mismo. Hace cosas raras. A veces da error, a veces carga todo bien, a veces solo carga la portada y el resto de páginas da error, y a veces carga el contenido pero pierde los estilos CSS. Eso es lo que yo puedo ver. Y todo esto sin modificar nada.

Un saludo

ResponderCitar
Respondido : 20/06/2024 2:14 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iago.

ok, vamos a revisar el clon y te respondemos en esta misma consulta.

 

Un Saludo

ResponderCitar
Respondido : 20/06/2024 2:26 pm

Página 2 / 3