Avisos
Vaciar todo

W3 Total caché error 503  

Página 1 / 3
 
Iago
 Iago
Usuario activo

Hola, al activar el plugin w3 total cache mi sitio web devuelve error, tanto en dispositivos móviles como en ordenadores. Es un error 503, normalmente ya desde la portada (guerz.com), pero sino el error salta al navegar por páginas/entradas. Probé desactivando el resto de plugins y dejando solo w3 total caché activo, aunque el error se mantiene. Si desactivo w3 total cache, aun dejando el resto de plugins activos, la web carga correctamente. El motivo por el que instalé w3 es porque los tiempos de carga son altos (page speed de google). La configuración que tengo para el plugin es la que se indica en esta página de webempresa, ya que también uso Magic Caché con el plugin WE-Varnish-Cache: https://guias.webempresa.com/preguntas-frecuentes/magic-cache/

Configuración para w3 total cache:

  • Page Cache: Desactivado
  • Minify: Desactivado
  • Opcode Cache: Déjala como está ( debería aparecerte por defecto como Opcode: Zend Opcache o bien como Not Available , ambos serían valores válidos)
  • Database Cache: Activado
  • Object Cache: Activado
  • Browser Cache: Activado
  • CDN: Desactivado
  • Reverse Proxy: Desactivado


Cualquier ayuda, indicación o sugerencia es apreciada. Si es necesario alguna captura en concreto, puedo aportarla. Un saludo

Contenido solo visible a usuarios registrados

Citar
Respondido : 14/06/2024 10:04 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iago.

Prueba a desactivar la caché de navegador " Browser Cache: Desactivado "

Revisa si con eso se soluciona y nos comentas.

 

Un Saludo

ResponderCitar
Respondido : 14/06/2024 10:33 am

Cursos Gratuitos WordPress

Iago
 Iago
Usuario activo

@pepesoler Hola, gracias por el mensaje. Aparentamente sigue dando el mismo error, tanto en ordenador como en móvil. 

ResponderCitar
Respondido : 14/06/2024 11:08 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Iago, 

Actualmente tienes activo el plugin?, si no es así actívalo y nos comentas cuando lo tengas para revisar con mayor detalle lo que sucede. 

Si ingreso al sitio web veo está cargando de forma correcta y no me muestra un error 503

Un Saludo 

ResponderCitar
Respondido : 14/06/2024 1:30 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Iago
 Iago
Usuario activo

@karen hola, sí está activo el plugin. El problema no surge al momento, surge al navegar por el sitio. La portada la carga bien, algunas entradas también. Al cabo de un rato navegando, da error. Me ha pasado varias veces en diferentes dispositivos. En móvil da más errores que en ordenador, aunque en ambos da error. Por ejemplo: https://guerz.com/shopping/ a mí siempre me da error. Es una de ellas. Probé varios dispositivos y diferentes navegadores, en modo incógnito. 

ResponderCitar
Respondido : 14/06/2024 1:39 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iago.

El error 503 es por falta de comunicación con el servidor y suele aparecer por tema de recursos pero no veo picos de consumo y veo que el servidor está estable:

jvrrpvdb

Veo Que tienes Varnish activo.

Descarga el plugin y lo instalas, puedes descargar el plugin desde tu cuenta de WePanel -> otras herramientas -> Magic Cache:

screenshot cp7012.webempresa.eu 2443 2024.06.14 16 08 39

.- Accede al plugin y activa la ache dinámica

.- Accede a tu cuenta de WePanel -> Administrador de archivos

.- Accede a la carpeta donde tienes la instalación y renombra el archivo .htaccess 

.- Accede a la administración de WordPress -> Ajustes -> enlaces permanentes y sin realizar ningún cambio pulsa en el botón de Guardar

.- Vacia la cache de Varnish y la de W3 Total caché

 

Revisa si con eso mejorar la carga.

 

Un Saludo

ResponderCitar
Respondido : 14/06/2024 3:14 pm

Iago
 Iago
Usuario activo

Hola Pepe. El plugin de Magic caché ya lo había descargado de wepanel e instalado. Lo tenía desactivado pq había desactivado todos los plugin excepto w3. En cualquier caso, lo volví a activar y seguí los pasos que me indicas. Cuando dices que renombre .htaccess entiendo que es renombrarlo pero después dejarlo igual, con el mismo nombre, ¿es así?. Eso fue lo que hice, seguí los pasos que me diste, inclyendo vaciar ambas cache pero el sitio da error 503. Ahora mismo están activos w3 y Varnish Cache (este último con la caché dinámica activa). El resto de plugin los dejo desactivados esperando a resolver el problema.

Esta publicación ha sido modificada el hace 4 semanas 2 veces por Iago
ResponderCitar
Respondido : 14/06/2024 10:59 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Iago,

Con respecto al archivo no es así, debes renombrarlo, agregarle al final algo como un _2 o un indicativo de que es un respaldo, luego de esto hacer lo que indico Pepe para que generes un nuevo archivo .htaccess. 

Ingresar a Ajustes > enlace permanente, sin hacer algún cambio, hacer clic en guardar los cambios, para que esto genere un nuevo archivo limpio.

Un saludo 🖐️ 

ResponderCitar
Respondido : 14/06/2024 11:28 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Iago
 Iago
Usuario activo

Hola Argenis, gracias por tu mensaje. No había entendido lo del htaccess. He realizado los cambios y sigue pasando lo mismo, al principio parece que funciona pero al navegar un rato termina dando error. Tanto en ordenador como en móvil. 

ResponderCitar
Respondido : 14/06/2024 11:45 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Iago,

Puedes vaciar las caches y desactivar ambos plugins antes de hacer de nuevo el proceso y generar un archivo htaccesss en blanco, lo que buscamos es que se genere todo como debería estar sin plugins de caché activos.

Realiza esta prueba y nos comentas, pero recuerda primero vaciar la cache de Varnish y la de W3 Total caché.

Un saludo 

ResponderCitar
Respondido : 15/06/2024 12:23 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Iago
 Iago
Usuario activo

Hola de nuevo. Todo sigue igual. Repetí el proceso (teniendo desactivados el resto de plugins), vacié la cache de ambos w3 y varnish, los desactivé, renombré el archivo htaccess, fui a administración de WordPress -> Ajustes -> enlaces permanentes y sin realizar ningún cambio pulsé en el botón de Guardar. Sigue dando error 503 en todos los dispositivos. También si me podéis indicar si puedo eliminar los htaccess antiguos (_2, _3). 

Un saludo.

ResponderCitar
Respondido : 17/06/2024 3:32 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iago.

Pues la verdad que no veo que tengas problemas de recursos que puedan provocar ese error, casi que me inclino mas por alguna regla que tengas en el servidor.

Por favor manda un ticket a soporte para que vean si alguna regla puede estar provocando ese error.

 

Un saludo

ResponderCitar
Respondido : 17/06/2024 4:09 pm

Cursos Gratuitos WordPress

Iago
 Iago
Usuario activo

Hola de nuevo. Me indican en el departamento de sistemas que vuelva aquí, al foro . El problema continúa: parece que el plugin w3 total cache sigue provocando que el sitio web de error la mayor parte del tiempo. Los resultados de PageSpeed de google mejoraban significativamente las pocas veces que pude medirlo cuando el plugin no daba error estando activado. Sin ese plugin, los resultados son muy pobres. Gracias

ResponderCitar
Respondido : 18/06/2024 3:26 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Iago,

En este caso puedes verificar con otro de nuestra lista de plugins para mejorar la caché:

https://www.webempresa.com/blog/plugins-cache-wordpress.html

Entre estos destacan el plugin de wp súper caché, del cual también tenemos una guía:

https://www.webempresa.com/blog/mejora-la-carga-de-wordpress-con-wp-super-cache.html

De la misma forma puedes intentar con wp rocket, sin embargo, este es de pago:

https://www.webempresa.com/blog/como-acelerar-wordpress-plugin-wp-rocket.html

Dale un vistazo y una prueba a estos por si también te funcionan de una forma similar a como lo hace w3.

Un saludo 🖐️ 

ResponderCitar
Respondido : 18/06/2024 4:32 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Iago
 Iago
Usuario activo

Hola. Tengo entendido que al tener Magic Caché no tiene sentido usar WP Super Cache, ya que solo funcionaría uno o no serían compatibles. No sé si es asi, o no, pero hay otros hilos de este foro en el que se dice eso: https://www.webempresa.com/foro/plugins-wordpress/compatibilidad-de-varnish-cache-con-wp-super-cache

También en esta guía de webempresa sobre varnish: https://guias.webempresa.com/preguntas-frecuentes/magic-cache/

Desconozco si con otros plugins como WP-Rocket pasaría lo mismo, pero prefiero no pagar para comprobarlo, o evitarlo si es posible. He probado WP Fastest Cache, por probar alguno... pero da error 503 también (adjunto), tarda mucho en dar el error, hay que navegar por varias páginas, pero acaba dando error. Lo tengo con esta configuración que adjunto. No sé tampoco si es compatible o no con magic cache. 

error 503 WP Fastest Cache

 

configuracion fast cache

 

ResponderCitar
Respondido : 18/06/2024 6:53 pm
Página 1 / 3