Ayuda. Algo hace qu...
Avisos
Vaciar todo

Ayuda. Algo hace que el prosador esté al 100% y no funcione la página  

 
Sergio
 Sergio
Estimable Member

          Hola:

 

                Por favor, a ver si nos podéis ayudar. Llevamos ya 3 días sin la tienda y no sabemos que hacer. El tema es que si la tenemos en mantenimiento y funcionando sólo para nosotros, va perfectamente. En cuanto la ponemos en producción, utiliza el 100% de los recursos del procesador y se bloquea. Siempre funcionó bien, nunca tuvimos problemas, y hemos probado de todo: Hemos restituido la base de datos, hemos desconectado prácticamente todos los módulos, hemos subido una copia antigua de todos los ficheros, borrado la base, cambiado la contraseña ..... todo. Lo más curioso es que hecho una copia exacta en otro dominio (www.ferreteroonline.es), modificando claro la base de datos para que apunte a ese dominio ... y perfecto. Funciona sin problemas. 

            Tras mucho trastear hemos pensado que se trataba de un ataque DDoS, y nos pusimos en contacto con vuestros compañeros de servicio técnico mediante un ticket. Ellos detectaron que efectivamente estábamos recibiendo multitud de peticiones del bot de bing, y bloquearon el mismo, pero al parecer indican que el problema real, real está en que algún módulo de pago genera consulta a la base por cada visita que recibimos, con lo que al recibir las visitas de los bots de indexación, parece que satura el servidor. Sin embargo, ayer intentamos funcionar sin ningún módulo (ni de pago, ni de estadísticas ni prácticamente más que los del theme) y el tema seguía igual ....

         ¿Vosotros podéis hecharnos una mano para ver qué está pasando? Ahora ya no nos deja ni entrar en el backoffice para pasarla a mantenimiento, y la tienda es nuestra fuente de ingresos.

 

                       Gracias de antemano por vuestra ayuda. Os mandamos un cordial saludo.

Contenido solo visible a usuarios registrados

Citar
Respondido : 18/04/2021 8:34 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Sergio.

Nosotros desde aquí no podemos comprobar tu servidor.

Lo que si que veo es que tienes problemas con el modulo ps_facetedsearch

[18-Apr-2021 11:29:26 Europe/Madrid] PHP Fatal error:  
Uncaught TypeError: Argument 1 passed to PrestaShop\PrestaShop\Core\Product\Search\ProductSearchResult::setProducts()
must be of the type array, boolean given, called in
/home/ferret26/public_html/ferreteronline.com/modules/ps_facetedsearch/src/Product/SearchProvider.php
on line 141 and defined in /home/ferret26/public_html/ferreteronline.com/src/Core/Product/Search/ProductSearchResult.php:61

Este modulo suele hacer conexiones con la base de datos.

.- Accede a tu cuenta de cPanel -> Administrador de archivos

.- accede a la carpeta modules y renombra el archivo " ps_facetedsearch "

Pide a soporte por ticket si puedes matar esos procesos y revisa los resultados.

 

Un saludo

ResponderCitar
Respondido : 18/04/2021 10:54 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Sergio
 Sergio
Estimable Member

@pepesoler

Hola, Pepe: Gracias por la respuesta. Intentamos lo que nos has indicado, pero no nos díó ningún resultado (el servidor no bajaba su carga). Al final, estamos tan desesperados que hemos decidido instalar de cero todo, es decir, instalar prestashop, módulos, tema ... y después intentar restablecer la configuración de todo a través de la base de datos que tenemos guardada.

     Ahora nos encontramos con otro problema y es que no conseguimos instalar Prestashop (queremos montar la misma versión que teníamos 1.7.6.3 para luego no tener problema al recuperar datos), pero nos da un error 500 cuando está instalando los modulos addons. Vamos a abrir otro hilo para este fallo, para no mezclar unos con otros.

 

              Gracias de nuevo por tu ayuda. A ver si conseguimos poner en marcha la tienda. Los clientes nos están mandando mensajes indicando que no pueden acceder. 

 

                   Un saludo.

ResponderCitar
Respondido : 18/04/2021 5:50 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es muy raro que no puedas instalar PrestaShop, estas usando los instaladores del Cpanel de tu cuenta de hosting?

Si vas a empezar un nuevo sitio por qué quieres instalar la misma versión?, lo ideal sería hacer una migración de tus datos y no usar la misma BD ya que igual la BD que tienes puede ser que te este generando el problema.

Si, sería recomendable que abras otro hilo si tienes aún dudas sobre este último tema.

Saludos.

Esta publicación ha sido modificada el hace 6 meses por Jhon
ResponderCitar
Respondido : 18/04/2021 6:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación