Hosting WordPress Divi con Soporte en Español

Error 500 tras rellenar formulario de registro de clientes con prestashop 1.7  

Página 1 / 2
 
Jesus
 Jesus
Usuario activo

:sick: Buenas noches,

Tengo un grave problema. En mi web Contenido solo visible a usuarios registrados

Citar
Respondido : 28/10/2019 7:35 pm
Jesus
 Jesus
Usuario activo

Añado los errores más recientes que me aparecen en la herramienta de localización de errores del cpanel (en la sección métricas), por si son de ayuda:

[28-Oct-2019 19:02:04 Europe/Madrid] PHP Warning: include(): Failed opening '/home2/allstore/public_html/allstore.es/vendor/composer/../guzzlehttp/guzzle/src/Message/MessageFactory.php' for inclusion (include_path='/home2/allstore/public_html/allstore.es/vendor/pear/pear_exception:/home2/allstore/public_html/allstore.es/vendor/pear/console_getopt:/home2/allstore/public_html/allstore.es/vendor/pear/pear-core-minimal/src:/home2/allstore/public_html/allstore.es/vendor/pear/archive_tar:.:/opt/alt/php70/usr/share/pear') in /home2/allstore/public_html/allstore.es/vendor/composer/ClassLoader.php on line 444

[28-Oct-2019 19:02:04 Europe/Madrid] PHP Warning: include(/home2/allstore/public_html/allstore.es/vendor/composer/../guzzlehttp/guzzle/src/Message/MessageFactory.php): failed to open stream: No such file or directory in /home2/allstore/public_html/allstore.es/vendor/composer/ClassLoader.php on line 444

ResponderCitar
Respondido : 28/10/2019 7:38 pm

Cursos Gratuitos WordPress

Bulmaro
 Bulmaro
Miembro Moderator

Hola Jesus,

¿Restauraste o actualizaste tu Prestashop? De ser así, ¿Qué versión tenías y a cuál migraste?
Te sugiero eliminar el caché desde el Backoffice de Prestashop, en caso de que no tengas acceso o surja algún error en el proceso entonces elimina el contenido de la carpeta App/Cache desde el administrador de archivos de cPane y probar.

De no solucionarse el problema ejecuta un análisis con el asistente virtual de Stephan y compártenos los resultados.

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 28/10/2019 8:02 pm
Jesus
 Jesus
Usuario activo

Inicialmente el dominio eraContenido solo visible a usuarios registradoscomo dominio principal. No se si esto es lo que genera el problema.

En la carpeta app/ no tengo ninguna carpeta cache adjunto captura. Pero le he dado dentro del backoficce , en rendimiento, a borrar cache y el problema persiste.

ResponderCitar
Respondido : 28/10/2019 8:12 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jesus
 Jesus
Usuario activo

Es prestashop 1.7 y con el cpanel he probado a poner el php 7 y también persiste el problema,.

ResponderCitar
Respondido : 28/10/2019 8:29 pm
Jesus
 Jesus
Usuario activo

Adjunto el informe de stephan.

ResponderCitar
Respondido : 28/10/2019 8:40 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jesus
 Jesus
Usuario activo

Perdón..no se añadió. Lo añado de nuevo.

Link a post de foro, solo visible a usuarios registrados
ResponderCitar
Respondido : 28/10/2019 8:42 pm
Bulmaro
 Bulmaro
Miembro Moderator

Hola Jesús,

Gracias por tu colaboración. Sigo revisando las información que me has proporcionado.

Ahora que el asistente virtual Stephan ha corregido los permisos prueba eliminar el caché nuevamente desde el administrador de PS. Si no funciona, accede al administrador de archivos de cPanel y renombre la carpeta vendor a _vendor, luego accede a. https://www.prestashop.com/es/versiones-anteriores, descarga el prestashop que corresponda a la versión que está utilizando tu sitio y mediante FTP sube la carpeta vendor a tu hosting.

Veo el modulo de prestashop auto upgrade, ¿Actualizaste tu prestashop en las últimas semanas? Cuando modificaste el dominio, ¿Qué procedimiento seguiste? ¿Se mostró algún error o aviso al realizar el cambio?

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 28/10/2019 9:35 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jesus
 Jesus
Usuario activo

Hola de nuevo Bulmaro.

Acabo de terminar esa operación. He renombrado la carpeta vendor como _vendor y he subido una nueva de mi misma versión de prestashop mediante FTP y borrado la caché. Y por desgracia, sigue dando el error 500.

Te respondo:
Esta web era allstore.es y estaba en Prestashop 1.6 hice una nueva web en prestashop 1.7 importé todo el contenido y la dejé en el directorio principal del dominio y elimine el prestashop 1.6. Esto lo hice hace un tiempo y la web estuvo completamente funcional. Por lo que no se daba el error 500.

Más recientemente, la semana pasada aproximadamente cambié el dominio por chollobar.com apuntandolo a la carpeta public_html/allstore.es y poniéndolo como principal y dejando allstore.es como dominio apuntado. Creo que estuvo funcionando bien, pero no te lo puedo garantizar. Porque ha sido muy reciente. Y podría estar relacionado con al causa de este error 500 que se produce exactamente cuando el cliente completa la ficha de registro. Y que en modo debug sale lo que puse en la captura del primer mensaje que he mandado.

ResponderCitar
Respondido : 28/10/2019 11:23 pm
Bulmaro
 Bulmaro
Miembro Moderator

Hola Jesús,

Justo ahora ha desaparecido el error 500 en el formulario para actualizar o agregar una nueva dirección de envío. ¿Identificas algún otro donde se presentase el problema?

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 29/10/2019 12:20 am

Cursos Gratuitos WordPress

Jesus
 Jesus
Usuario activo

A mi me sigue saliendo el error. Entro en modo ventana de incognito. Compro un articulo. Y al darme de alta como nuevo cliente, pongo la dirección y al dar a aceptar...error 500.

ResponderCitar
Respondido : 29/10/2019 12:24 am
Bulmaro
 Bulmaro
Miembro Moderator

Hola Jesús,

Es cierto, sin embargo si regresas a la página anterior se visualiza correctamente la información y datos de registro. Por alguna razón, desde consola puedo notar que se cargan 2 archivos psajax.php y ajaps.php al hacer envíos de formulario, ambas muy similares, pertenecientes al modulo de appagebuilder, uno ubicado en la carpeta modules de tu tema y el otro en modules dentro del directorio de themes.

Entonces puedes realizar lo siguiente:

1. Ejecuta nuevamente el asistente virtual Stephan para identificar nuevos o distintos errores.
2. Revisa si tienes los módulos duplicados y activos.
3. Prueba cambiando la versión de PHP.
4. Verifica si tienes módulos con actualizaciones disponibles o muy antiguos (estos últimos deshabilitalos si no tienen actualizaciones para tu PS), prueba tambien deshabitando todos los modules que no son parte del tema que estás utilizando.
5. Realizar una nueva instalación de PrestaShop en un nuevo directorio, puedes utilizar un subdominio y probar.
6. Realizar un backup de tu sitio mediante las copias de seguridad.

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 29/10/2019 2:09 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jesus
 Jesus
Usuario activo

Tal como dices, veo que el módulo appagebuilder tiene una carpeta en dos sitios de la carpeta allstore.es a la que apunta el dominio chollobar.com
la carpeta public_html/allstore.es/themes
y en public_html/allstore.es/modules

pero también en la carpeta public_htlm directamente:
en la carpeta public_html/themes
y en public_html/modules

No se por que está como repetido todo, si es pro ser la web principal de este hosting.
Pero lo que si veo es que el contenido dentro de themes y de modules de este modulo no es idéntico y de hecho, si paso el de uno a otro, peta. He probado tambien uno por uno, a poner _ delante del nombre de appagebuilder en los cuatro sitios, y nada!.

Estoy ya aburrido.

Te adjunto el nuevo informe de estephan.

Link a post de foro, solo visible a usuarios registrados
ResponderCitar
Respondido : 29/10/2019 3:00 am
Jesus
 Jesus
Usuario activo

por cierto, el php ya probé a cambiarlo antes de nada.
Los modulso estan todos actualizados y además todo lo que no uso, incluidos los de estadisticas estan eliminados.

ResponderCitar
Respondido : 29/10/2019 3:01 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jesus
 Jesus
Usuario activo

HE usado el superbackup del cpanel y lo he restaurado al 18 de octubre, que funcionaba bien...y sin embargo no se a arreglado. Porque lo he probado en una ventana de incognito.

Ahora si que crece mi desesperación con el tema.

ResponderCitar
Respondido : 29/10/2019 3:38 am
Página 1 / 2

Hosting WordPress Divi con Soporte en Español

Por favor Iniciar Sesión o Registro