Lentitud en la fich...
Avisos
Vaciar todo

Lentitud en la ficha de producto, desaparición de los permisos del equipo (acceso denegado)  

Página 1 / 2
 
Cristóbal
 Cristóbal
Usuario activo

Hola, me presento, ya que es mi primera vez en este foro, mi nombre es Antonio y soy el responsable del dpto. de mkt. de la empresa Events San Cristóbal, s.l.u., tenemos contratado con ustedes un hosting de alto rendimiento donde tenemos ubicadas varias webs, unas de mayor relevancia que otras y en este caso el problema lo tenemos con la que más relevancia tiene para nuestra empresa.

Solycarpa es una web con la que trabajamos cada día y la que más ventas hace, por lo que cada día se añade mucho contenido, tanto de productos como de pedidos que se van realizando, el problema que estamos teniendo y que he puesto en conocimiento de vuestros compañeros es que esta web está presentando problemas varios desde hace un mes, entre ellos la lentitud de carga de imágenes en la ficha de producto e incluso cuando se intentan borrar, dando a veces errores inesperados de código en rojo o error 500 en otras ocasiones, este es ahora es una gran problema porque no dificulta el trabajo, luego se ha ido detectando otros fallos como sin venir a cuento la eliminación de la tabla donde el tema warehouse almacena la homepage, aunque este se ha solucionado haciendo una nueva restaurando el módulo que fue afectado, pero no deja de ser muy extraño, y ahora, ayer nos dejó sin acceso a los permisos por lo que cuando queremos añadir un atributo nos dice que el usuario no tiene permiso, algo que me ha extrañado, ya que el mío y de mi compañera somos administradores y a ambos nos ha afectado, en este punto debo indicar que por optimizar la base de datos, hice lo que en un foro vuestro se aconseja del truncamiento de algunas tablas que almacenan registros en gran cantidad.

 

Bueno este es mi problema, vuestros compañeros me han dicho que ustedes me podéis ayudar de manera directa, ya que aunque yo puede hacer restauraciones de copias, no me atrevo a peder todo el trabajo desde la copia donde todo iba bien, ya que un mes de trabajo en esta web, es mucha información almacenada tanto de imágenes, pedidos, clientes nuevos, etc..

Contenido solo visible a usuarios registrados

Citar
Respondido : 08/07/2022 10:59 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Antonio.

Veo varias cosas en tu instalación.

La plantilla veo que no esta actualizada, tienes la version 4.5.0 y la ultima version de la plantilla Warehouse es la 4.5.3.

.- Actualiza la plantilla a la ultima versión:

https://www.youtube.com/watch?v=eYJh5k8VQKo&t=6s

 

Veo que utilizas la version 1.7.8.0 de prestashop y la ultima version es la 1.7.8.6

.- Actualiza prestashop a la ultima version que es la 1.7.8.6

 

Otra cosa veo es que estas utilizando CloudFlare, si después de actualizar sigues con el problema prueba a cambiar las DNS para que apunten a las de tu cuenta de Webempresa.

-> https://www.webempresa.com/blog/error-520.html

 

Un saludo

 

 

ResponderCitar
Respondido : 08/07/2022 11:55 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Cristóbal
 Cristóbal
Usuario activo

@pepesoler Gracias por la respuesta, era una opción que estaba barajando, pero claro esto no sé si puedo tener problemas en hacerlo en producción porque si lo hago en pruebas, con la cantidad de trabajo que se mete en la web, habría que restaurar la información, no sé, que me aconsejas, podría tener problemas si la actualizo en producción y el warehouse creo que se debe de ir actualizando de una versión a otra, es correcto?

ResponderCitar
Respondido : 08/07/2022 2:52 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Antonio.

En principio no creo que tengas problemas porque son actualizaciones menores pero bueno puedes probar a clonar prestashop y realizar primero la actualización en ese clon.

Revisa lo siguiente:

-> https://soporteforo.webempresa.eu/guia/clonar-prestashop-1-7/

 

el warehouse creo que se debe de ir actualizando de una versión a otra

Pues en eso no sabria que decirte ya que es de pago y no la conozco como para poder informarte, eso es mejor que lo consultes con su soporte.

 

Un saludo

 

 

Esta publicación ha sido modificada el hace 2 años por Pepe
ResponderCitar
Respondido : 08/07/2022 2:59 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Cristóbal
 Cristóbal
Usuario activo

@pepesoler Hola Pepe, he actualizado el prestashop a la última versión pero sigo teniendo el mismo problema con el acceso a los atributos, es decir, me deniega poder hacer cualquier cambio, te dejo la captura de pantalla, no he actualizado el warehouse porque ya no tenemos mantenimiento con ellos y no creo que tenga nada que ver con este problema y con la lentitud y comunicación en la ficha de productos cuando intentamos subir imágenes o borrarlas.

https://drive.google.com/file/d/1BrwzxueqtHPdOEhp2iDuKbhf_NFY9EE9/view?usp=sharing

Por cierto, cómo se adjunta imágenes en este foto en respuesta?

Esta publicación ha sido modificada el hace 2 años por Cristóbal
ResponderCitar
Respondido : 12/07/2022 9:25 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Cristobal.

Actualizaste de prestashop 1.6 a 1.7 ?

Ese error que muestras suele producirse por una actualización de versiones mayores de prestashop 

Tendras que hacer algunas modificaciones en la Base de datos.

 

.- Accede a tu cuneta de WePanel.

.- Accede a phpMyAdmin.

.- Selecciona la base de datos que utiliza la instalación.

.- Exporta la base de datos para tener una copia.

screenshot cp7157.webempresa.eu 2443 2022.07.12 12 34 41

.- Selecciona las tablas " ps_access y ps_authorization_role "

screenshot cp7182.webempresa.eu 2443 2022.07.12 12 39 28

.- Elimina las tablas " ps_access y ps_authorization_role "

.- Descomprime el archivo que tienes adjunto:

.- Selecciona " importar "

.- Selecciona el archivo que descomprimiste y lo importas.

screenshot cp7157.webempresa.eu 2443 2022.07.12 12 44 20

Esto creara de nuevo las tablas que eliminaste con los valores correctos.

 

Revisa si con estos pasos se soluciona y puedes crear nuevos campos.

 

Nota: personalmente lo aprobaría primero en un clon de la instalación.

-> https://soporteforo.webempresa.eu/guia/clonar-prestashop-1-7/

 

cómo se adjunta imágenes en este foto en respuesta?

-> https://soporteforo.webempresa.eu/guia/subir-imagenes-a-consultas-en-foro/

 

Un saludo

 

ResponderCitar
Respondido : 12/07/2022 11:48 am

Cristóbal
 Cristóbal
Usuario activo

@pepesoler Buenos días Pepe, del procedimientos que me dices que haga, se hace en el phpmyadmin directamente en producción o saco copia y hago los cambios en la copia, eso no me ha quedado claro, pasaría algo si elimino los ficheros directamente de la base da datos y, aparte esto solo solucionaría el acceso de los permisos, la lentitud de la web para subir imágenes o quitarlas seguiría igual, no?. Gracias.

ResponderCitar
Respondido : 13/07/2022 8:25 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Cristobal.

se hace en el phpmyadmin directamente en producción o saco copia y hago los cambios en la copia

Puedes hacerlo en la web en producción si no quieres probarlo primero en un clon pero antes recuerda descargar una copia de Base de datos por si pasara algo poder restaurarla.

esto solo solucionaría el acceso de los permisos

Soluciona lo de los permisos, una vez tengamos esa parte solucionada vemos lo de las imágenes.

 

Un saludo

 

ResponderCitar
Respondido : 13/07/2022 9:06 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Cristóbal
 Cristóbal
Usuario activo

@pepesoler Ok, tengo la copia y procedo al cambio, a ver que pasa.

ResponderCitar
Respondido : 13/07/2022 10:31 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Cristobal.

Ok dejo el hilo abierto.

 

Un saludo

ResponderCitar
Respondido : 13/07/2022 11:07 am

Cursos Gratuitos WordPress

Cristóbal
 Cristóbal
Usuario activo

@pepesoler Hola Pepe, primer problema reparado, ya podemos acceder a los permisos y a la sección de atributos, estoy eliminando bases de datos que no se están utilizando, pero seguimos con la lentitud de la subida de productos, el prestashop ya está en su última versión y tengo desactivados algunos módulos, que pensaba podrían ser los culpables. Ya me dices, un saludo.

ResponderCitar
Respondido : 14/07/2022 8:46 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Cristobal.

El problema es que tarda mucho a la hora de subir imagenes o es en la carga de la pagina ?

 

Lo que veo es que hay tablas con muchos registros:

ps_pagenotfound... tiene 114996 registros en la Base de Datos: gruposa4_11277
ps_ets_superspeed_cache_page_hook... tiene 132300 registros en la Base de Datos: gruposa4_VYiPwt8K
ps_log... tiene 458489 registros en la Base de Datos: gruposa4_VYiPwt8K
ps_connections... tiene 101593 registros en la Base de Datos: gruposa4_factory
ps_guest... tiene 700749 registros en la Base de Datos: gruposa4_factory
mco_connections... tiene 121305 registros en la Base de Datos: gruposa4_mundocarpas
mco_guest... tiene 141192 registros en la Base de Datos: gruposa4_mundocarpas
mco_pagenotfound... tiene 163303 registros en la Base de Datos: gruposa4_mundocarpas
ps_guest... tiene 541144 registros en la Base de Datos: gruposa4_nueva
ps_guest... tiene 548538 registros en la Base de Datos: gruposa4_solycarpa
ps_search_index... tiene 107602 registros en la Base de Datos: gruposa4_solycarpa2021
ps_statssearch... tiene 174009 registros en la Base de Datos: gruposa4_solycarpa2021
ps_search_index... tiene 134155 registros en la Base de Datos: gruposa4_solycarpanew
ps_statssearch... tiene 170052 registros en la Base de Datos: gruposa4_solycarpanew

 

Instala el siguiente modulo:

-> https://mypresta.eu/modules/administration-tools/database-optimization.html

Una vez instalado accede al modulo y pulsa en el boton de limpiar de todas las opciones:

screenshot www.masquecms.es 2022.07.14 10 45 24

 

Un saludo

ResponderCitar
Respondido : 14/07/2022 9:47 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Cristóbal
 Cristóbal
Usuario activo

@pepesoler Ok, lo voy mirando, pero tengo que comentarte algo que ha pasado y es que al restaurar las tablas de ps_access y ps_autotentication_rol, en permisos han desaparecido los permisos de los módulos instalados y claro por ejemplo no puedo acceder a nada del Warehouse que es el más importante.

¿Cómo lo soluciono?

ResponderCitar
Respondido : 14/07/2022 11:16 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Cristobal.

.- Actualiza la plantilla que veo que no la actualizaste.

 

Un saludo

ResponderCitar
Respondido : 14/07/2022 11:55 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Cristóbal
 Cristóbal
Usuario activo

@pepesoler Hola Pepe, he actualizado la plantilla y sigo sin acceso a sus módulos, ¿Qué puedo hacer ahora?

ResponderCitar
Respondido : 14/07/2022 1:42 pm
Página 1 / 2