Avisos
Vaciar todo

No funciona el buscador ni página de la marca para visitantes o invitados  

 
Enrique
 Enrique
Usuario experto

Hola a todos/as

Soy nuevo por aquí tras realizar una migración desde otro hosting y la primera impresión que me llevo de webempresa es más que positiva.

Ahora vamos con el problema que tenemos:

1) El buscador de la web solo funciona para usuarios que han iniciado sesión en la web. Es decir, esta URL dominio.com/index.php?controller=search&s=producto solo muestra resultados para usuarios que han iniciado sesión. Para usuarios invitados me devuelve el mensaje: Sorry for the inconvenience.
Search again what you are looking for.

2) Lo mismo ocurre con la página de las marcas, por ejemplo esta URL dominio.com/index.php?id_manufacturer=3&controller=manufacturer&id_lang=1 solo muestra contenido para usuarios que han iniciado sesión. Para usuarios que no han iniciado sesión se muestra el siguiente mensaje: Sorry for the inconvenience. Search again what you are looking for.

Datos por si sirven de ayuda para resolver el problema:
- Tenemos 3 perfiles de usuarios: usuario final, usuario profesional nacional y usuario profesional extranjero. He entrado en la configuración del grupo de clientes y los 3 grupos tienen los mismo módulos activados.

- Estos problemas descritos anteriormente nos pasan tanto con el theme que estamos trabajando como con el classic. Por lo que descarto que sea un problema del theme.

¿Alguien tiene idea de qué puede estar pasando?

Muchas gracias por adelantado.

Un saludo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 29/03/2018 9:54 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Enrique,

Bienvenido a Webempresa, espero y deseo que tu estancia aquí sea una experiencia muy positiva 🙂

Sobre lo que comentas y a la espera de que puedas facilitar alguna captura de la configuración del módulo de búsquedas, por si fuese la causa, revisa este hilo donde mi compañero Pepe explica que puedes revisar para verificar si es la causa de que no funcione la búsqueda a usuarios no registrados.

https://www.webempresa.com/foro/41-Preguntas-sobre-PrestaShop/157914-Buscador-no-funciona-correctamente.html#298596

Saludos

ResponderCitar
Respondido : 29/03/2018 10:11 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Usuario experto

Hola Enrique,

Bienvenido a Webempresa, espero y deseo que tu estancia aquí sea una experiencia muy positiva 🙂

Sobre lo que comentas y a la espera de que puedas facilitar alguna captura de la configuración del módulo de búsquedas, por si fuese la causa, revisa este hilo donde mi compañero Pepe explica que puedes revisar para verificar si es la causa de que no funcione la búsqueda a usuarios no registrados.

https://www.webempresa.com/foro/41-Preguntas-sobre-PrestaShop/157914-Buscador-no-funciona-correctamente.html#298596

Saludos

Hola Luis, gracias por la respuesta.

Sin embargo, no sirve para el problema que tengo. Ya que como decía en el post, el buscador funciona perfectamente (y la página de la marca) para los usuarios que han iniciado sesión en la web.

Un saludo.

ResponderCitar
Respondido : 29/03/2018 10:15 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué versión exacta de PrestaShop tienes?, verifica si tienes actualizaciones pendientes

De manera general, tienes algún tipo de restricción para mostrar productos por pefiles de usuarios?

Saludos.

ResponderCitar
Respondido : 29/03/2018 10:27 pm

Cursos Gratuitos WordPress

Enrique
 Enrique
Usuario experto

- Versión: 1.7.3.0
- No, no hay restricciones ni para productos ni para categorías. En la edición de categorías, por ejemplo, todos los grupos de usuario tienen acceso a todas las categorías.

Un saludo.

ResponderCitar
Respondido : 29/03/2018 10:44 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Como logro reproducir el error?, realizo una búsqueda y muestra algunos productos.

ResponderCitar
Respondido : 30/03/2018 3:06 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique
 Enrique
Usuario experto

Hola,

Como logro reproducir el error?, realizo una búsqueda y muestra algunos productos.

Hola Johnny!

Ayer por la noche empecé a ir atando cabos pero no logro entenderlo del todo.
En PARÁMETROS AVANZADOS > RENDIMIENTO desactivé la opción GRUPOS DE CLIENTES (tal y como se muestra en la captura)

Así todo parece funcionar bien pero no le veo sentido alguno.

ResponderCitar
Respondido : 30/03/2018 8:06 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tal vez sea algún tipo de Bug

Si desactivas esta funcionalidad pierdes la funcionalidad de grupos que has configurado?

Saludos.

ResponderCitar
Respondido : 30/03/2018 10:18 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Usuario experto

Hola

Tal vez sea algún tipo de Bug

Si desactivas esta funcionalidad pierdes la funcionalidad de grupos que has configurado?

Saludos.

Entiendo que si. En cualquier caso estoy haciendo pruebas con diferentes perfiles de usuarios para ver si todos ven lo que les corresponde sin que esto afecte al buscador y los problemas descritos en el post.

Un saludo.

ResponderCitar
Respondido : 30/03/2018 10:28 pm
Enrique
 Enrique
Usuario experto

El problema persiste...

Si tengo los GRUPOS DE CLIENTES activados el buscador NO funciona para usuarios "visitantes".

¿Alguna solución? Necesito tener activada la opción GRUPOS DE CLIENTES por los descuentos que se les aplica a cada grupo...

ResponderCitar
Respondido : 16/04/2018 7:46 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Usuario experto

No es problema del THEME, lo he probado con el CLASSIC y ocurre exactamente lo mismo.

En el momento que activo GRUPOS DE CLIENTES (CONFIGURAR > PARAMETROS AVANZADOS > RENDIMIENTO > CARACTERISTICAS OPCIONALES) el buscador y la página de marcas deja de funcionar para los "visitantes" (usuarios que no inician sesión con su cuenta).

¿Qué está pasando? ¿Qué estoy haciendo mal?

ResponderCitar
Respondido : 16/04/2018 9:16 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si actualizando la versión de PrestaShop el problema se soluciona, las ultimas versiones están mostrando un sin numero de errores 🙁

ResponderCitar
Respondido : 16/04/2018 10:15 pm

Cursos Gratuitos WordPress