Página en blanco en Prestashop  

 
Alexis Nicolas
 Alexis Nicolas
Usuario activo

Hola, tenemos un problema en Prestashop tras trasladarlo y actualizarlo. Nos queda la página en blanco y al activar el modo debug, nos aparece este error:

Warning: openssl_decrypt(): IV passed is only 12 bytes long, cipher expects an IV of precisely 16 bytes, padding with in /home2/velasdel/public_html/xxxxxxxx.xx/classes/Rijndael.php on line 85

No podemos redirigir el dominio hasta que la tienda funcione adecuadamente.
Agradeceríamos un poco de luz para resolver el problema.

Saludos,

Manel

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 08/03/2018 9:36 pm
Alexis Nicolas
 Alexis Nicolas
Usuario activo

Hemos puesto el valor de PS_CIPHER_ALGORITHM en 0 como recomiendan, y ahora no aparece el error pero sigue apareceindo una página en blanco.

ResponderCitar
Respondido : 08/03/2018 9:41 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Si te muestra la web en blanco seguramente se generó un error 500. Verifica si existe el fichero error_log y envíanos las ultimas lineas actualizadas para revisar el error: https://www.webempresa.com/blog/que-es-un-error-500-y-como-localizarlo-en-nuestra-web.html

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/03/2018 1:25 am
Alexis Nicolas
 Alexis Nicolas
Usuario activo

Buenas tardes, disculpad el retraso, estuve trabajando con el dueño del plugin que fallaba y que nos facilitó la nueva versión, la hemos actualizado esta tarde, y ahora nos vuelve la página en blanco, pero en el blog de errores aparece esto:

[13-Mar-2018 17:14:36 Europe/Madrid] PHP Fatal error: Call to undefined method Link::getNewsPostLink() in /home2/velasdel/public_html/velasdelaballena.es/modules/newsiw/newsiw.php on line 64
[13-Mar-2018 17:14:47 Europe/Madrid] PHP Fatal error: Call to undefined method Link::getNewsPostLink() in /home2/velasdel/public_html/velasdelaballena.es/modules/newsiw/newsiw.php on line 64
[13-Mar-2018 17:14:55 Europe/Madrid] PHP Fatal error: Call to undefined method Link::getNewsPostLink() in /home2/velasdel/public_html/velasdelaballena.es/modules/newsiw/newsiw.php on line 64
[13-Mar-2018 17:15:25 Europe/Madrid] PHP Fatal error: Call to undefined method Link::getNewsPostLink() in /home2/velasdel/public_html/velasdelaballena.es/modules/newsiw/newsiw.php on line 64

No hay manera de poder abrir la tienda...

Gracias por vuestra ayuda.

Manel

ResponderCitar
Respondido : 13/03/2018 5:24 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

El plugin que fallaba es : newsiw ?

Has comentado estos errores recientes con los desarrolladores?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/03/2018 5:42 pm
Alexis Nicolas
 Alexis Nicolas
Usuario activo

Hola, no, el que fallaba era el Custom Gallery, no he comentado nada con los desarrolladores de newsiw, este error es nuevo, parece que este fallado en cadena? 🙁

ResponderCitar
Respondido : 13/03/2018 5:52 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alexis Nicolas
 Alexis Nicolas
Usuario activo

Hemos desactivado el módulo newsiw y ahora la home carga, pero al hacer click en un producto, vuelve la página en blanco y el blog muestra esto:

[13-Mar-2018 17:55:22 Europe/Madrid] PHP Notice: Trying to get property of non-object in /home2/velasdel/public_html/velasdelaballena.es/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 180
[13-Mar-2018 17:55:22 Europe/Madrid] PHP Notice: Trying to get property of non-object in /home2/velasdel/public_html/velasdelaballena.es/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 183
[13-Mar-2018 17:55:22 Europe/Madrid] PHP Notice: Trying to get property of non-object in /home2/velasdel/public_html/velasdelaballena.es/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 185
[13-Mar-2018 17:55:22 Europe/Madrid] PHP Fatal error: Uncaught --> Smarty: Unable to load template file '/home2/velasdel/public_html/velasdelaballena.es/themes/sp_solo/./productdetail-full.tpl' in '/home2/velasdel/public_html/velasdelaballena.es/themes/sp_solo/product.tpl' <--
thrown in /home2/velasdel/public_html/velasdelaballena.es/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 129

ResponderCitar
Respondido : 13/03/2018 5:59 pm
Alexis Nicolas
 Alexis Nicolas
Usuario activo

Tras activar el modo debug, vemos que al acceder a un producto, aparece una página en blanco pero devuelve este error, pro si la información os ayuda a darnos pistas a nosotros 🙂

Fatal error: Call to undefined method Link::getGalleryLink() in /home2/velasdel/public_html/velasdelaballena.es/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 44

ResponderCitar
Respondido : 13/03/2018 8:49 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El único mensaje de error que veo ahora es el que esta relacionado con esta ruta:
/home2/velasdel/public_html/velasdelaballena.es/themes/sp_solo/product.tpl

Prueba recompilando smarty, desde: Parámetros Avanzados > Rendimiento > Smaryt > Forzar Recompilación

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/03/2018 8:51 pm
Alexis Nicolas
 Alexis Nicolas
Usuario activo

Probado, y ahora la home vuelve a presentar una página en blanco.

ResponderCitar
Respondido : 13/03/2018 9:11 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Has probado a reemplazar el fichero original de la plantilla: /home2/velasdel/public_html/velasdelaballena.es/themes/sp_solo/product.tpl y comprobar si de esta manera te carga la web?

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2018 3:25 am
Alexis Nicolas
 Alexis Nicolas
Usuario activo

Probado, sustituido por el original y sin cambios. White page.

ResponderCitar
Respondido : 14/03/2018 12:42 pm

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alexis

Si accedo a uno de los productos veo que carga bien:

¿ Es solo con un articulo en concreto ? por que estoy navegando por la web y no veo ningun error de pagina en blanco.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 14/03/2018 12:54 pm
Alexis Nicolas
 Alexis Nicolas
Usuario activo

si vas al dominio www.velasdelaballena.es si se ve bien porque es la web en el servidor antiguo, la nueva, la que hemos trasladado a webempresa, está aquí:

http://velasdel-cp89.webprestashop.com/velasdelaballena.es/es/

Yo por lo menos sigo viendo página en blanco, si tú la ves bien, el poltergeist es ya mayúsculo... 🙂

ResponderCitar
Respondido : 14/03/2018 4:46 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué versión de PrestaShop tienes?

Se siguen generando los mismos errores?, algo que podrías probar es cambiar temporalmente de theme, usar el theme que viene por defecto y verificar.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2018 5:30 pm

Por favor Iniciar Sesión o Registro