Problema con transportistas, províncias y regiones en Prestashop 1.5.6.2  

Página 1 / 2
 
Pedro
 Pedro
Usuario eminente

Hola, buenos días:

Miren, estoy creando una tienda online sobre Prestashop 1.5.6.2 y me ha surgido el siguiente problema. He creado una serie de transportistas que aparentemente están bien configurados y activados. También tengo el la zona, el país (España), las províncias y las regiones activadas y bien configuradas.

El cliente en cuestión solicitaba que además se pudiesen hacer compras en su ciudad, con lo que busqué e instale un módulo de osCommerce de envío por código postal (este). La instalación se realizó normalmente, pero no he conseguido identificar dónde está el módulo... de hecho creo que ha debido haber algún problema. El caso es que al buscarlo, aproveché para actualizar algunos módulos y a partir de aquí, creo que es donde ha podido surgir el siguiente problema -a menos que sea otra cosa-:

Cuando hago una prueba de compra real, en el primer paso han desaparecido tanto el desplegable de las provincias y regiones como los transportistas... No entiendo que ha podido pasar y espero que no sea algo gordo. Soy novato en Prestashop.

A continuación os facilito una secuencia de imágenes:
· Zonas (01.png)
· Paises (02.png)
· País (03.png)
· Estados / Províncias (04.png)
· Transportistas (05.png)
· Pantalla de envío (06.png)

Les agradezco desde ya su ayuda.

Un saludo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 28/05/2014 1:03 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si el siguiente articulo de blog te es de utilidad:

Curso PrestaShop: 5. Métodos de pago y tarifas de envío
https://www.webempresa.com/blog/item/1353-tienda-prestashop-5-metodos-de-pago-y-tarifas-de-envio.html

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/05/2014 2:49 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pedro
 Pedro
Usuario eminente

Hola Jhonny, buenos días:

Muchas gracias por responder. He repasado todo el curso y creo que está todo bien. No obstante, lo he repetido según mostrábais en el curso y siguen sin aparecer ni el transportista ni las províncias...

Un saludo.

ResponderCitar
Respondido : 29/05/2014 12:09 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Mikel,

Parece que tienes los productos sin gastos de envío. He probado en uno e indicaba gratuito.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 29/05/2014 1:11 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pedro
 Pedro
Usuario eminente

Hola Jordi, buenos días:
Sí, es cierto. Bueno, pues ya he colocado el precio; aún así sigue sin salir ni los transportistas ni las províncias... Muchas gracias.

Un saludo

ResponderCitar
Respondido : 29/05/2014 1:34 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Mikel

Si lo que comentas que antes funcionaba correctamente y luego de actualizar han desaparecido estas opcones, es posible que sea un problema de la actualización de tu theme.

Primero realiza un backup y prueba cambiar de theme por alguno por defecto y verifica si te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/05/2014 10:36 pm

Cursos Gratuitos WordPress

Pedro
 Pedro
Usuario eminente

Hola Jhon, buenos días:

De acuerdo, voy a hacer la prueba y os voy contando.

Muchas gracias.

ResponderCitar
Respondido : 30/05/2014 10:37 am
Pedro
 Pedro
Usuario eminente

Hola Jhon, buenas tardes,

Bueno, pues he hecho la prueba que me comentabas y con la plantilla por defecto aparecen tanto los transportistas como el desplegable de províncias... :blink: Adjunto os dejo un pantallazo.

¿A qué puede deberse? ¿Cómo lo puedo solucionar?...

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 02/06/2014 5:48 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Mikel

Eso significa que es un problemma de tu theme, veo que no es un theme de los packs, verifica si tienes actualizaciones de este theme

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/06/2014 11:58 pm
Pedro
 Pedro
Usuario eminente

Hola Jhon, buenos días,

He visitado la web donde adquirí el tema (aquí) y aparentemente dice que sí tendo actualizaciones y asistencia gratuíta para la plantilla. Supongo que esa actualización se debe llevar a cabo a través del módulo 1-click Upgrade ¿no?

Ahora bien, he estado mirando el tema de la actualización y según he leido, parece ser que si actualizo la plantilla, todas las modificaciones que he hecho sobre el tema -traducciones, CSS, etc...- desaparecerían... ¿Es eso cierto? Y si es así, ¿hay alguna manera de evitar ese desastre? También me surge la duda -en el caso de que no hubiese otra solución que actualizar la plantilla-, de si debería activar el botón que muestro en el pantallazo que muestro debajo de este texto... Dice "poner su tienda en mantenimiento".

En fin, esto pinta complicado.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 03/06/2014 2:17 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En primer lugar, veo que comentabas que habías instalado un módulo de OsCommerce en tu PrestaShop. Esto no puede funcionar nunca, ya que se tratan de CMS distintos y los módulos no son compatibles entre sí. Es más, hacer esto puede generar errores en tu PrestaShop.

Por otro lado indicas de usar el módulo 1-click Upgrade para actualizar el tema. No es así. Esta opción sirve para actualizar el propio PrestaShop, no el tema (plantilla) de PrestaShop que estás utilizando. No te recomiendo que hagas esto sin asegurarte que el tema de PrestaShop que estás utilizando es compatible con PrestaShop 1.6.

Tendrías que consultar con los desarrolladores del tema la forma de actualizarlo. Normalmente hay que activar otro tema, desinstalar el que tienes y volver a instalar el tema.

Es muy probable que durante este proceso pierdas las personalizaciones que hayas aplicado en el tema, por lo que sería mejor opción que consultaras con los desarrolladores el problemas con los transportistas, ya que es posible que se arregle cambiando un único fichero.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 03/06/2014 5:54 pm
Pedro
 Pedro
Usuario eminente

Hola Pablo, buenas tardes,

De acuerdo. Consultaré al desarrollador y en cuanto sepa algo os lo comento.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 03/06/2014 6:18 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pedro
 Pedro
Usuario eminente

Hola a todos, buenos días,

Como decía Pablo ayer, los creadores del tema me comentan que debo eliminar el tema instalado y sustituirlo por el que hay por defecto. Una vez realizada esta acción, debo volver a instalar la plantilla que tenía. El riesgo: perder las personalizaciones realizadas. Parece que esta va a ser la única vía de solución ya que sólo si realizo esta acción, atenderán los problemas derivados del uso de su plantilla, así que si no me sugerís otra alternativa me voy a poner con ello y con lo que sea os comunicaré los resultados.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 04/06/2014 11:46 am
Pedro
 Pedro
Usuario eminente

Hola,

Bueno, pues una vez desinstalado el tema y reinstalado según las instrucciones dadas, el problema de las provincias y de los transportistas persiste. Consultaré de nuevo al proveedor de la plantilla ya que he cumplido con el requisito de la reinstalación del tema.

Con lo que sea, os voy contando. Si se os ocurre cualquier cosa, os agradezco que me la comentéis.

Muchas gracias.

Un saludo.

ResponderCitar
Respondido : 04/06/2014 12:46 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por lo que comentas, parece que el problema está provocado por el tema que estás usando.

De todas formas, para futuras consultas que hagas a los desarrolladores pregúntales por el archivo concreto a instalar, ya que hacer una resinstalación completa puede ser un paso innecesario.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/06/2014 3:55 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro