Problema prestashop...
Avisos
Vaciar todo

[Resuelto] Problema prestashop al enlazar con Blog wordpress  

 
Jose
 Jose
Usuario experto

Buenas Tardes,
Tenemos un problema con nuestro blog, desde hace poco no funciona, nuestra web es en prestashop y el blog de wordpress está en una carpeta dentro de la carpeta principal BLOG, siempre ha funcionado correctamente, y hoy no funciona, si pueden ayudarnos a detectar el problema se lo agradecemos.

He contactado con soporte y me comentan:
Parece queel problema está en que no interpreta el apartado "blog" como una web independiente y la tramita como si fuera parte del acceso de la web principal de PrestaShop.
Debido a esto, envía el acceso a un error 404 ya que esa Url no es reconocida por PrestaShop.

Tendrías que revisar la configuración de PrestaShop para integrar el blog como parte de la web y que lo interprete como una web independiente sin problemas.

Si no das encontrado la forma de hacerlo, lo mejor es que te pongas en contacto con nuestros compañeros del foro, ya que nosotros estamos especializados en el soporte a nivel de servidor, no de CMS.


Gracias
Saludos

Contenido solo visible a usuarios registrados

Respondido : 27/03/2021 5:16 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola,

¿Ya revisaste tu configuración de ambas plataformas y su integración?¿En qué momento empezó el problema? ¿Realizaste alguna instalación de plugin en una u otra plataforma? ¿Has probado desactivando los módulos de Prestashop y plugins de Wordpress? El siguiente artículo puede serte de utilidad -> https://www.webempresa.com/blog/como-anadir-un-blog-a-prestashop.html

Por útimo, considera la opcón de restaurar tu sitio a una fecha anterior en el tiempo en el que recuerdes que el sitio funcionaba, considera que en esta opción perdwrás todos latos creados posteriores a esa fevcha -> https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/

Respondido : 28/03/2021 4:57 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose
 Jose
Usuario experto

Gracias Por la respuesta,

Pues la verdad que hacía tiempo que no entraba al blog, por lo menos unas semanas, así que no se desde cuando falla...

He probado en prestashop desactivar los plugings de redireccionamiento, seo, url amigables... y el problema continua, la verdad que es muy raro, no recordamos haber realizado cambios que hayan podido afectar, Nose si será algo de htacces pero no hemos modificado nada

Nose si me pueden dar alguna recomendación más para detectar el problema

Muchas Gracias

SAludos

Respondido : 29/03/2021 12:29 pm
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Jose.

Prueba a desactivar lso idiomas deja solo el idioma en Español y que no cargue con tudominio.xxx/es.

Revisa si quitando los idiomas carga bien el blog.

 

Un saludo 

Respondido : 29/03/2021 2:53 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose
 Jose
Usuario experto

@pepesoler Gracias por la respuesta,

He probado desactivar el módulo de idiomas pero sigue igual, no creo que sea ese el problema por que siempre ha estado activa la web en varios idiomas, sigo buscando la solución pero no doy con ella.

Agradezco cualquier ayuda, 

gracias

SAludos

 

Respondido : 29/03/2021 3:25 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose,

Veo que aun el sitio web esta cargando con la ruta de los idiomas, prueba desactivarlos por completo y nos indicas para revisar nuevamente que puede estar ocurriendo. Por otro lado puedes probar regenerar el archivo .htaccess y verificar si con ello funciona.

Para ello debes ingresar a tu cPanel -> Administrador de Archivos -> public_html dentro de este ingresa a la carpeta donde tienes los archivos de tu wordpress y renombra el archivo .htaccess por ejemplo a .htaccess_old

Luego ingresa al backend de tu sitio al apartado Parámetros de la tienda -> Trafico & SEO en la sección Configuración de URLs  prueba desactivar las URL amigables y guardar los cambios, luego activalas nuevamente y guarda los cambios.

Comprueba si con ello logras ingresar de forma correcta a tu sitio web y blog

PD: Siempre manten una copia de seguridad de tu sitio web, de esta forma si se genera algún error puedes reataurarla

Un Saludo

Respondido : 29/03/2021 3:43 pm

Cursos Gratuitos WordPress

Jose
 Jose
Usuario experto

@karen Gracias! En el momento que renombro el .htacces de la carpeta blog (wordpress), funciona la entrada al blog, pero falla si dentro del mismo hago click sobre un artículo o cualquier enlace dentro del blog : https://www.buckerbook.es/blog/

el paso de desactivar las URL amigables lo he realizado y como seguia fallando los enlaces dentro del blog lo he vuelto a activar.

creo que el problema está en el htacces, que no hay htacces dentro del blog funciona la página principal del blog por lo menos...

 

Respondido : 29/03/2021 4:09 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose,

Veo que ya logras carga la pagina blog, en este caso prueba lo siguiente ingresa a la carpeta del wordpress (blog) y renombra el htaccess luego ingresa al backend de tu wordpress y ve al apartados Ajustes -> Enlaces permanentes

Sin realizar ninguna modificación pulsar guardar cambios, comprueba luego si con ello al pulsar sobre cualquier articulo se visualiza de forma correcta

Screenshot(5)

Un Saludo

Respondido : 29/03/2021 4:17 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose
 Jose
Usuario experto

@karen Muchas Gracias!!! He seguido tus pasos y funciona todo correctamente.

😊

Respondido : 29/03/2021 4:21 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Jose,

Enhorabuena ha funcionado, siempre es un placer poder ayudarte 🤗 

Con esto podemos dar el tema como solucionado, escríbenos si tienes cualquier otra consulta

Un Saludo 😊

Respondido : 29/03/2021 4:24 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress