Avisos
Vaciar todo

Al actualizar mi tema Wizestore para Woocommerce se rompe la web  

Página 2 / 3
 
Farmaciola
 Farmaciola
Estimable Member

Buenos días,
tengo una tienda online con el CMS Wordpress 4.9.4 y el plugin Woocommerce 3.3.1, la versión de PHP que uso en esta web es la 7.0.27. Uso el tema Wizestore para Woocommerce con la versión 1.3.6, creado por los de gt3themes y comprado en Themeforest. El problema que tengo es que al actualizar mi tema a la versión 1.3.6.1 (Actualización muy muy pequeña del tema) se me rompe la web en 2 (adjunto captura de pantalla), ya me he puesto en contacto con el autor del tema y él me comenta que no es un problema global de esta actualización ya que él no tiene reports malos de esta actualización, solo de mí, en este caso.
El tema siempre lo actualizo directamente des del backend de Wordpress, con el plugin envatu market, pero en este caso el autor me dijo que loa actualizara manualmente, pues tampoco funciono, lo actualice des del Cpanel subiendo el archivo .zip y nada, la web se rompe igualmente. Probamos a desactivar casi todos los plugins y actualizar el tema, pues tampoco. Los permisos de las carpetas y de los archivos ya están en 644 y 755, es correcto no?
Tengo instalado un plugin gordo, el WPML, me puse en contacto con el soporte de WPML me dijeron que borrara los registros del plguin WPML y todos sus componentes y probara actualizar, pues tampoco. Ahora se que el problema no viene de plugins, ya que hasta ahora actualizaba tranquilamente el tema y no pasaba nada y se ha echo la prueba de desactivarlos, creo que puede venir por alguna configuración del Server. Os escribo haber si me podéis ayudar a encontrar alguna pista con lo que me pasa con la actualización de este tema, ya que no se por donde más puede venir el problema, ya nos e que hacer :unsure: .
Actualizo los plugins, acabo de actualizar Wordpress y ningún problema la web esta bien, luego solo actualizo el tema y ..pfff,, se me rompe. Hoy el autor del tema accederá al backend de mi instalación haber si puede ver el problema.
He visto que en el estado de Woocommerce me sale esto (Adjunto captura pantalla) pero no se si tiene algo que ver.
Muchas gracias haber si encontramos una solución entre todos!, saludos 😉

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 07/02/2018 10:05 am
Farmaciola
 Farmaciola
Estimable Member

Debe ser el autor, porque esta en la ruta /wp-content/themes.
Mientars solo tendría que estar dentro mi tema y dentro plugins. No?
Muchas gracias ya comentare cuando me conteste el autor.
gracias.

ResponderCitar
Respondido : 07/02/2018 5:19 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si, exacto, es posible que haya estado haciendo pruebas.

Saludos.

ResponderCitar
Respondido : 07/02/2018 6:03 pm
Farmaciola
 Farmaciola
Estimable Member

Perfecto mañana os comento 😉

ResponderCitar
Respondido : 07/02/2018 6:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Farmaciola
 Farmaciola
Estimable Member

Si, efectivamente el autor estaba haciendo pruebas. Haber hoy me ha contesatdo el autor diciendo que ya pudo actualizar el tema pero que aun hay contenido y el menu que no se carga, me dice que su tema es compatible con Woocommerce 3.3.1.. y que es culpa del host. Que puedo hacer? 🙁
Os escribo literlamente li que me ha dicho:
"El tema se ha actualizado con éxito pero el contenido no se está cargando.
Hay algo mal con su servidor, porque el tema tiene compatibilidad con Woocommerce 3.3.1.
Pudimos restaurar el control deslizante en la página de inicio.
Pero todavía hay un problema con el menú y el logotipo."

Me podéis ayudar haber si hay algo mal en el tema de host? Puede ser que sea la versioón de PHP ya que la tengo a 7. algo? y no a 5.6?
Ya no se que más mirar.
Muchas gracias.

ResponderCitar
Respondido : 08/02/2018 9:16 am
Farmaciola
 Farmaciola
Estimable Member

No me podéis mirar todo sobre mi dominio adicional "Elitderm.com" haber si hay algún problema en el host?
mmm... no se haber si están declarados bien los mínimos y máximos de memoria, ya que me los subisteis para WPML... el php se cambio también.. no se cualquier cosa, iré pensando en que más puede ser.
Muchas gracias.

ResponderCitar
Respondido : 08/02/2018 9:25 am

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

A nivel servidor lo tienes todo bien, solo unos avisos de fechas anteriores que a día de hoy están solucionados ya que no los marca.

¿ Si renombras la carpeta woocommerce de plantilla carga bien el menú ?

Una cosa que puedes probar es acceder a la carpeta plugins e ir renombrando os plugins que tienes instalados uno a uno por si hubiera alguna que te esté causando ese problema.

Un saludo

ResponderCitar
Respondido : 08/02/2018 9:42 am
Farmaciola
 Farmaciola
Estimable Member

Ahora si renombro la carpeta "Woocommerce" de mi theme, me sale error 500. Por lo cual la he dejado como estaba. E visto que el autorya me actualizo las palntillas obsolteas, dentro en el apartado "Estado" de Woocommerce ya no me salen en rojo, ya las tengo bien.
E echo lo de los pluguins y al renombrar el plugin de "Instagram feed", ahora me sale el menú en la web...
Pero claro esta todo mal, pero al menos deja cargarlo, pruebo a restablecer la web adía de ayer, desactivo ese plugin instagram feed y actualizo el tema a ver que pasa? creo que venía por aquí. Lo que haré es guardar la carpeta "Wizestore" que es la carpeta que ha actualizado el autor así no pierde la faena que hizo y también he guardado la carpeta "Woocommerce" de dentro plugins.
Muchas gracias.
Muchas gracias.

ResponderCitar
Respondido : 08/02/2018 10:47 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

Ok, parece que empezamos a ver un poco de luz:

al renombrar el plugin de "Instagram feed", ahora me sale el menú en la web...

Dejo el hilo en espera de tus indicaciones.

Un saludo

ResponderCitar
Respondido : 08/02/2018 11:19 am
Farmaciola
 Farmaciola
Estimable Member

He restablecido 2 y 3 días anteriores, he actualizado todo antes de actualizar el tema, he desactivado el "instagram feed" y nada. se vuelve a partir en 2.
Pfff... le e vuelto a enviar mensaje al autor del tema porque el problema viene del tema seguro.
Si he desactivado todos los plugins y aun sigue así...
No se que hacer, no me había pasado nunca un problema así.
Alguna idea?
Muchas gracias.

ResponderCitar
Respondido : 08/02/2018 12:48 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

haber, si no actualizas la web, ¿ esta se comporta bien ?, si te pasa cuando actualizas la web, los únicos problemas pueden venir de la propia plantilla o de algún plugin que no sea compatible.

Renombra la carpeta plugins y revisa si se muestra el menú, si se muestra ya sabes que el problema puede venir de algún plugin, entonces vuelves a dejar la carpeta como estaba e ir renombrando la carpetas de los plugins hasta encontrarlo.

Revisando veo que ya te carga bien :cheer:

Un saludo

ResponderCitar
Respondido : 08/02/2018 1:53 pm
Farmaciola
 Farmaciola
Estimable Member

Buenas de nuevo, se carga bien porque ayer hice una copia con el plugin Updraftplus, que me recomendaste y me a ido fenomenal para hacer copias en el acto y configurarlas para que vayan en un sitio x remoto.

Ahora e acabado unos retoques y volveré hacer copia por si acaso con updraft a parte de la copia de Supermigrator.

Sabes algún plugin para crear entorno de pruebas de mi web? Creare un entorno e iré probando, porque quiero solucionar el tema de actualizar mi Wizestore.
He probado con Wpsaging pero no me va bien en mi web, me da fallos, no se si conoces otro. Como puedo crear clon de mi web para hacer pruebas?
Y lo de los plugins ya lo hice, pero la web nunca acababa de estar bien...
Por eso creare entorno de pruebas para probar que puede ser, que mas puedo mirar?
Muchas gracias.

ResponderCitar
Respondido : 08/02/2018 2:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Farmaciola
 Farmaciola
Estimable Member

Tenéis el enlace a soporte técnico de Woocoommerce? También puedo probar a preguntar por allí 😉
Muchas gracias.

ResponderCitar
Respondido : 08/02/2018 2:39 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola.

puedes instalar una copia en una carpeta independiente.
.- Creas una carpeta en public_html con el nombre copia e instalas una copia de tu instalación en esa carpeta, para acceder seria tudominio.xxx/copia

Te dejo informacion al blog con los pasos -> https://www.webempresa.com/blog/clonar-wordpress-en-3-clics-sin-perder-tiempo.html

Si te sientes más cómodo/a con un plugin -> https://www.webempresa.com/blog/all-in-one-wp-migration.html

Tenéis el enlace a soporte técnico de Woocoommerce?
https://woocommerce.com/contact-us/?_ga=2.110268613.1913629450.1518087606-1874936984.1516009113

Un saludo

ResponderCitar
Respondido : 08/02/2018 2:49 pm

Cursos Gratuitos WordPress

Farmaciola
 Farmaciola
Estimable Member

Perfecto muchas gracias por todo Pepe, creare el entorno y así haremos pruebas. Aquí se explica como crear el clon pero en la public_html, en mi caso es un dominio adicional y esta a "public_html/elitderm.com", creare la carpeta "clon" quedando "public_html/elitderm.com/clon" y luego haré todos los pasos.
Una vez finalizado la url sera "elitderm.com/clon"?
también se puede hacer con subdominios no? O es mas complicado?
Muchas gracias.

ResponderCitar
Respondido : 08/02/2018 5:08 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Si, la ruta sería: elitderm.com/clon

En el caso de subodminios la ruta sería otra, pero para las pruebas que quieres no te compliques sólo usa un clon como carpeta

Saludos.

ResponderCitar
Respondido : 08/02/2018 5:42 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Página 2 / 3