Avisos
Vaciar todo

[Resuelto] AYUDA POR FAVOR, NO ME CARGA LOS CAMBIOS!  

Página 1 / 2
 
Mireia
 Mireia
Usuario activo

Hola. Llevo desde ayer intentando modificar mi página de Inicio (cambiar colores, añadir texto y algunos efectos) y me está siendo imposible. Publico los cambios y de doy a vista previa y me aparecen, pero luego voy a ver mi web y no me aparecen. He borrado microcache de hosting, he actualizado Colibri, he actualizado Wordpress y no hay forma. Antes, cuando he actualizado Colibri, me ha guardado un par de cambios, pero el resto no aparece por ningún sitio y llevo 3 días con el mismo problema. ¿Alguien puede ayudarme?

Contenido solo visible a usuarios registrados

Respondido : 12/06/2024 7:23 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mireia,

Primero que nada puedes compartirnos cuáles son los cambios que haces?, puedes enviarnos capturas con esta guía:

https://soporteforo.webempresa.eu/guia/subir-imagenes-a-consultas-en-foro/

Luego vemos que tienes la versión PHP en 7.3 trata subirla a 7.4, puedes seguir los pasos de esta guía:

https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Verifca esto y nos indicas con capturas los cambios que no vez para poder verificarlos desde este lado. Actualmente, vemos tu sitio así:

image

Un saludo 🖐️ 

Respondido : 12/06/2024 7:38 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Mireia
 Mireia
Usuario activo

Hola, @argenis.

Muchas gracias por tu respuesta.

Captura de pantalla 2024 06 12 204852

Disculpa que no cuelgue las imágenes de otra forma, pero no me aparece por ningún lado la opción de subir archivos.

En este caso, he añadido bastante texto nuevo en la página de Inicio. En la captura que adjunto aparece el texto nuevo que he añadido desde el editor y publicado. Sin embargo, cuando voy a visualizar mi web como si fuera un cliente, estos cambios no hay forma de que aparezcan.

Lo más extraño es que si cierro Wordpress y vuelvo a abrir la página de Inicio en el editor, me siguen saliendo los cambios guardados como si estuvieran publicados, pero fuera del editor (vista cliente) no hay forma de que muestre estos cambios.

Muchas gracias, quedo pendiente de lo que me pidas.

Respondido : 12/06/2024 7:56 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mireia,

Los cambios debes hacerlos en la misma página, estás ingresando a Paginas > pagina que deseas modificar? si no lo estás haciendo, de esta forma no se va a modificar el contenido. Si lo haces desde Apariencia > personalizar, lo que modificas son ajustes de colores, tipografías, más elementos que tengan que ver con los estilos.

Vemos que tienes elementor activo, también puedes hacerlo ingresando a tu página en este caso la de inicio, y en la barra superior debes ver un botón que indique Editar con elementor, aquí haces clic y te carga el editor para las páginas.

image

Aqui es donde cambias el contenido, verifica hacer algún ajuste aquí y nos envías capturas como lo has hecho sobre el ajuste que has realizado para validarlo, también tienes nuestro curso de elementor:

https://www.webempresa.com/university/curso-de-elementor-basico/

Un saludo 🖐️ 

Respondido : 12/06/2024 8:11 pm

Mireia
 Mireia
Usuario activo

Gracias @argenis.

Siempre modifico desde Páginas > Página que deseo modificar > Editar con Colibrí (todas las tengo hechas con Colibrí). Siempre lo he hecho correctamente y siempre he podido modificar cualquier página, es la primera vez que me pasa esto.

Si entro a editar con Elementor, se me mueven todas las cosas de lugar y me destroza el diseño, por eso siempre lo he hecho con Colibrí y 0 problemas. Pero hoy no hay forma de que me muestre los cambios una vez publicados. Sin embargo, los cambios se están guardando, porque ahora vuelvo a entrar al editor (sea Colibrí o Elementor) y siguen ahí todos, como si estuvieran publicados, solo que mi web no los está mostrando.

Ya no sé qué más tocar...☹️

Respondido : 12/06/2024 9:18 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mireia,

Veo que tienes el plugin de Swift Performance Lite, puedes verificar desactivar este plugin y realizar los cambios que comentas? si sigues sin poder, solo deja los plugins del constructor activos, el resto los desactivas.

Una vez hecho esto verifica si se guardan los cambios, si lo hace entonces vas activando uno a uno los plugins hasta dar con el que no permite que se guarden. Realiza esta prueba y nos comentas si encuentras el plugin para indicarte por cuál puedes cambiarlo.

Un saludo 🖐️ 

Respondido : 12/06/2024 10:06 pm

Cursos Gratuitos WordPress

Mireia
 Mireia
Usuario activo

Gracias de nuevo, @argenis

He desactivado el Swift Performance y varios plugins más, dejando solo Colibrí, Yoast SEO, Chaty, Social Chat. Ahora, cuando hago cambios, ni siquiera me los muestra en la vista previa, cuando antes sí lo hacía...

 

Respondido : 13/06/2024 12:06 pm
Mireia
 Mireia
Usuario activo

Acabo de solicitar a mi hosting que me ayude a actualizar PHP, @argenis, ya que Wordpress me avisa de que tengo un error crítico en la web y que necesito actualizar el PHP. ¿Creo que solo puedo hacerlo desde mi hosting según indica el artículo anterior?

Wordpress me dice esto:

 

PHP es uno de los lenguajes de programación utilizados para crear WordPress. Las versiones más recientes de PHP reciben actualizaciones de seguridad frecuentes y pueden mejorar el rendimiento de tu sitio. La versión mínima recomendada de PHP es la 7.4.

Respondido : 13/06/2024 12:23 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mireia
 Mireia
Usuario activo

Acabo de actualizar el PHP a 7.4, he cerrado sesión en WP, he vuelto a entrar con otro usuario y sigue sin mostrarme los cambios que hago en mi web. No sé qué más hacer, creo que voy a desistir porque llevo 3 días sin encontrar el fallo.

Respondido : 13/06/2024 12:36 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mireia.

Esto es lo veo cuando accedo a la página de inicio que es lo mismo que muestras en tu captura:

 

Lo primero actualiza todo que tienes pendiente que veo que hay plugins y la plantilla sin actualizar.

Una vez actualizado.

.- Accede a Páginas -> Todas las páginas.

.- Edita la página de inicio con Elementor

.- Realiza una modificación y revisa si se muestra, no utilices la vista previa, simplemente guardas y accedes a la web y revisa si los cambios se muestran.

 

Un Saludo 

Respondido : 13/06/2024 12:45 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mireia
 Mireia
Usuario activo

Hola@pepesoler.

Gracias por responderme y disculpad tantísimas dudas y problemas.

Acabo de actualizar todos los plugins y el tema de mi web.

Como verás en las capturas que te adjunto, cuando accedo a editar mi página con Colibrí (que es el editor que siempre he usado) me ha guardado los cambios nuevos que he hecho, pero mi web sigue sin mostrarlo. Puedo cerrar WP del todo y volver a entrar a editar la página y los cambios aparecen guardados, pero sin embargo nunca se muestran cuando voy a ver mi web. Verás que en las capturas hay mucho texto y elementos que están guardados, pero que tú no estás viendo en el vídeo que me mandas. Este es el mayor problema.

Me da miedo editar con Elementor porque ayer, cuando lo probé, sin ni siquiera editar nada, Elementor me destrozó la web, dejando espacios donde no debía y moviéndome textos de sitio (todavía hay trozos que no he podido modificar), por eso siempre he usado Colibrí.

¿Qué opinas de que los cambios estén guardados pero no se estén mostrando (lo que adjunto en las capturas)?

Qué horror dar tantas vueltas (y daros trabajo) y no estar pudiendo resolver de dónde viene 🙁

Captura de pantalla 2024 06 13 135000
Captura de pantalla 2024 06 13 134910

 

Respondido : 13/06/2024 12:59 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mireia.

El problema está en que esa página en un principio está construida con Elementor y luego utilizaste el constructor colibrí para realizar cambios y no se pueden utilizar dos constructores, tienes que trabajar con uno o con otro.

Los propios desarrolladores lo indican:

-> https://wordpress.org/support/topic/i-updated-colibri-and-now-i-cant-edit-my-page/

Puedes probar a crear una nueva página de inicio desde el principio y editarla con Colibrí, una vez lo tengas desde Ajustes -> Lectura seleccionas la nueva página de inicio.

Otra opción es que la edites con Elementor y trabajes solo con Elementor.

En conclusión, no puedes editar la misma página con dos constructores distinto.

 

Un Saludo

Respondido : 13/06/2024 2:58 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Mireia
 Mireia
Usuario activo

Hola de nuevo,@pepesoler

Entendiendo que ese era el error, he optado por crear una nueva página de Inicio desde 0 con Colibrí. Una vez la he tenido hecha, he ido a Ajustes - Lectura y he seleccionado la nueva página de Inicio que acabo de crear como la página de Inicio que quiero para la web.

El problema es que, cuando voy a la web, veo que la página de inicio que sigue mostrando es la página antigua y, para más problema, la muestra destrozada.... No me muestra la página nueva que acabo de crear y seleccionar como INICIO.

Captura de pantalla 2024 06 13 200519

 Como ves en la captura, como página de Inicio tengo puesta la que acabo de crear con Colibrí (por nombre "INICIO) y la que aparecía antes era la de "INICIO ANTIGUO". Pero es que si me voy a mi web, sigo viendo la página INICIO ANTIGUO como inicio/home. 

¿En qué puedo volver a estar fallando?

Mil gracias de nuevo....

 

 

Respondido : 13/06/2024 7:09 pm
Mireia
 Mireia
Usuario activo

Acabo de ver que el problema persiste... He creado la nueva página de Inicio desde 0 con Colibrí y cuando voy a verla al editor, me aparece tal cual la he creado. Cuando voy a vista previa igual, sin embargo, cuando la miro en mi web en modo incógnito para hacer la vista cliente, me sigue apareciendo mal (destrozada y antigua).

En las dos primeras capturas se ve lo que hay en el editor + lo que hay en vista previa (que es como quiero que se vea en la web), y en la última captura se ve como aparece mi web cuando voy a visualizarla...

Captura de pantalla 2024 06 13 210959
Captura de pantalla 2024 06 13 211019
Captura de pantalla 2024 06 13 211039

 

Respondido : 13/06/2024 8:13 pm

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mireia,

En este caso por qué entonces sigues manteniendo Elementor? eliminalo, o desactívalo si no lo estás utilizando. Luego El que no se actualicen los ajustes puede ser por la caché de tu sitio. De alguna forma tu sitio esta, tamaño la caché de una forma muy agresiva, desactiva y trabaja con el plugin de Swift Performance desactivado.

Instala este plugin:

https://es.wordpress.org/plugins/wp-super-cache/

Con este veras un indicativo en la barra superior, que indica Vaciar la cache, haz clic allí al hacer un cambio. De la misma forma veo en tu asistente virtual stephan unos errores en plugins:

image

Desactiva Wp forms solo por validar y nos comentas.

Un saludo 🖐️ 

Respondido : 13/06/2024 8:27 pm
Página 1 / 2