Avisos
Vaciar todo

[Resuelto] en el editor de elementor no se nos cargan los estilos  

 
Alvaro
 Alvaro
Usuario activo

Hola,

el editor de elementor no se nos cargan los estilos y vemos el siguiente error en la consola: 

TypeError: e.O is not a function
at frontend.min.js?ver=3.21.8:2:39876
at webpackJsonpCallback (styleguide-app-initiator.min.js?ver=3.21.8:3:13486)
at webpackJsonpCallback (webpack.runtime.min.js?ver=3.21.8:2:4680)
at frontend.min.js?ver=3.21.8:2:74

hemos probado: 

 

1) desactivar todos los plugins y dejar solo elementor: sigue ocurriendo lo mismo

2) otro navegador

3) incrementar el límite de la memoria a 1024

4) cambiado version php a 8 (teníamos 7.4)

5) bajado la versión de wordpress de 6.5.4 a 6.2.2

6) cambiado la forma de carga del editor y el print method del css en los settings de elementor y nada. 

 

a modo curiosidad, hay varias cosas tipo, tabs en el propio escritorio de wordpress, que no funcionan (se ven todos los elementos en forma de lista, en vez de en tabs). 

 

Estamos un poco desesperados con esto, porque ahora mismo no conseguimos ni crear ni editar nuevas páginas. gracias. 

Contenido solo visible a usuarios registrados

Respondido : 13/06/2024 6:04 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alvaro, 

Esto suele suceder por la caché de Elementor y no tiene que ver muchas veces con los plugins, para verificarlo accede a Elementor → Herramientas → General y pulsa en la opción de Regenerar CSS y datos

image

Luego de ello, accede a Varnish Cache y pulsa en la opción de Vaciar Caché.

image

Si aún no se muestran los cambios, envíanos algunas capturas como debe mostrarse para revisarlo con detalle. 

Te comparto la siguiente guía donde indican como subir imagene a foro → https://soporteforo.webempresa.eu/guia/subir-imagenes-a-consultas-en-foro/

Un Saludo 

Respondido : 13/06/2024 6:27 pm

Alvaro
 Alvaro
Usuario activo

@karen hola Karen, gracias. Esto lo intenté también, pero es que (y no sé si t8odo está relacionado) los tabs en el escritorio de wordpress no funcionan. Es decir, en los menús veo toda la info en listado. Y al hacer clic en el botón que comentas no hace nada; tampoco se muestra ningún error en la consola. ¿Te ha pasado algo así alguna vez?

 

image
Respondido : 13/06/2024 8:02 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alvaro, 

Has limpiado la caché de vernish?, como te comento esto suele ser un error de los CSS en Elementor y la caché, ahora mismo si ingreso lo veo así

image

Coméntanos si es de esta forma como debe verse o hay algunos cambios que no logras visualizar. 

Un Saludo 

Respondido : 13/06/2024 8:26 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alvaro
 Alvaro
Usuario activo

Si la caché de varnish siempre la limpio. El problema no está en la web. Es el editor de páginas de elementor el que se ve sin estilos y el propio escritorio de wordpress, que no permite hacer determinadas acciones por culpa de no mostrarse bien...

Respondido : 14/06/2024 8:11 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alvaro.

Prueba añadir lo siguiente en el archivo wp-config que encontras en la ruta /home/planrefo/public_html/stimat/wp-config.php

Añadelo encima de la línea /* ¡Eso es todo, deja de editar! Feliz blogging */ 

define( 'CONCATENATE_SCRIPTS', false );

 

Si ves que no se soluciona, por favor adjunta una captura de lo que ves sin estilos para que veamos a qué te refieres.

 

Un saludo

Respondido : 14/06/2024 8:57 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola alvaro.

Una cosita más que se me pasó antes y lo acabo de ver ver ahora que estaba revisando un poco tu instalación

Si no funciona lo de antes:

.- Elimina el código anterior

.- Actualiza todos los plugins y la plantilla que la tienes sin actualizar.

Es posible que cuando actualices la plantilla y los plugins vuelva a salir mas plugins para actualizar, actualizarlo todo y lo revisas.

 

Un saludo

Esta publicación ha sido modificada el hace 4 semanas por Pepe
Respondido : 14/06/2024 9:38 am
Alvaro
 Alvaro
Usuario activo

@pepesoler hola Pepe, cuando hago lo que me comentas dejo de ver correctamente el propio escritorio de wordpress (adjunto pantallazo).

image

 

Te adjunto el pantallazo de cómo se ve el editor de elementor, que es donde tengo el problema. Pero como digo, también me tiene mosqueado ver que las modales del propio wordpress no se ven bien, así como los tabs (quitando lo que me has comentado):

esto es el editor de elementor, intentado editar una página creada con él: 

image

 

 

Respondido : 14/06/2024 9:43 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alvaro.

Ok, elimina el código anterior, realiza lo que te indique en mi última respuesta:

Una cosita más que se me pasó antes y lo acabo de ver ver ahora que estaba revisando un poco tu instalación

Si no funciona lo de antes:

.- Elimina el código anterior

.- Actualiza todos los plugins y la plantilla que la tienes sin actualizar.

Es posible que cuando actualices la plantilla y los plugins vuelva a salir mas plugins para actualizar, actualizarlo todo y lo revisas.

 

Un saludo

Respondido : 14/06/2024 9:57 am
Alvaro
 Alvaro
Usuario activo

@pepesoler a qué te refieres con que tengo sin actualizar la plantilla? Te refieres al Theme stratus? 

Respondido : 14/06/2024 10:00 am

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Alvaro.

Si, si accedes a Escritorio -> Actualizaciones verás que tienes plugins y plantilla sin actualizar

screenshot mary52.webempresa.eu 2024.06.14 11 25 05

.- Actualiza todo lo qu etienes pendiente.

 

Un Saludo

Respondido : 14/06/2024 10:26 am
Alvaro
 Alvaro
Usuario activo

@pepesolerlos temas que tenía sin actualizar no son el que estaba usando---pero lo he actualizado TODO, plugins, temas, he vaciado cahcé con varnish desde el servidor. Me sigue dando el  mismo error en el editor de elementor de una página:

 

image
Respondido : 14/06/2024 11:18 am

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Álvaro, 

Revisando el sitio web veo que puede ser dos los causantes de este tipo de conflicto, lo primero es que tienes este plugin en tu sitio web https://wordpress.org/plugins/tables-for-elementor/ el cual está cerrado en WordPress y no se actualiza hace 7 años, desactivalo ya que este genera errores con Elementor. 

Por otro lado, es posible que tu tema no esté optimizado para funcionar con Elementor o este sucediendo algún tipo de error, prueba activar otro tema por defecto como Hello Elementor u otro de WordPress y revisa si el constructor carga en las páginas de forma correcta. 

Si al activa otro tema funciona quiere decir que el tema o la versión actual que tienes esta generando algun tipo de conflictos con Elementor, en este caso al ser un tema de pago no podemos revisarlo por lo que te recomiendo lo consultes con el soporte de la plantilla para que te indiquen de forma precisa como solucionarlo → Contenido solo visible a usuarios registrados

Un Saludo 

Respondido : 14/06/2024 2:36 pm
Alvaro
 Alvaro
Usuario activo

@karen muchísimas gtracias, porque efectivamente al actualizar el stratus, todo el admin y elementor han empezado a funcionar. Gracias!!!!!

Respondido : 04/07/2024 5:50 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Alvaro,

Es un gusto poder ayudarte, cualquier otra duda que tengas estaremos atentos

Saludos!

Respondido : 04/07/2024 6:25 pm