Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

IMAGEN CONFIGURADA DE YOAST SEO NO APARECE EN FACEBOOK  

 
Mario Iván
 Mario Iván
Usuario eminente

Hola,

Tengo instalado Yoast SEO en varias páginas y normalmente funciona muy bien, pero ahora tengo un problema, ya que configuré la imagen de facebook en Yoast SEO, pero sigue apareciendo la imagen destacada de wordpress. Lo que quiero, es que al compartir en Facebook se despliegue la imagen configurada en Yoast SEO en la pestaña "Social". Puedo confirmar que la imagen configurada tiene el peso y medidas correctas.

Contenido solo visible a usuarios registrados

Citar
Respondido : 24/09/2022 1:09 am
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mario,

Como nota general en internet el uso de mayúsculas tiene relación con un grito, está mal visto, por lo que el título es bueno que lo escribas en minúsculas las próximas veces, sobre todo porque igualmente lo vamos a leer este en minúsculas o en mayúsculas.

Con respecto a tu duda, veo que tu imagen es esta:

 https://tribulab.mx/wp-content/uploads/2022/08/IMAGEN-DESTACADA-HOME.jpg 

Esta imagen no tiene el tamaño correcto, debería ser 1200x627 y tienes configurada esta imagen con 1200x630, igualmente te comparto una captura directamente del depurador de facebook:

image

Sí que está tomando la imagen, o es otra página de la que tienes la duda?

Un saludo 🖐️ 

ResponderCitar
Respondido : 24/09/2022 1:23 am

Mario Iván
 Mario Iván
Usuario eminente

@argenis , gracias por tu respuesta,

Sobre tu comentario, realmente no le veo ninguna relevancia sin son mayúsculas o minúsculas en un título, pero lo haré así para próximas publicaciones en el foro.

Sobre mi duda, veo que si funciona en el home, pero es en las páginas de productos es en donde no muestra la imagen que configuro en Yoast SEO, esta jalando la imagen del producto y esto no funciona para compartir en facebook. ¿Hay alguna forma de priorizar la imagen de Yoast?

Te dejo un link donde sucede esto:

https://tribulab.mx/product/afters/

Y adjunto un screenshot de la configuración del Yoast y la imagen que debería aparecer al compartir en Facebook:

Captura de pantalla 2022 09 23 a la(s) 21.43.33
ResponderCitar
Respondido : 24/09/2022 3:45 am
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mario,

Le tienes asignado un título y una descripción también? Indican esto en su soporte, eso y que se vacíe cualquier caché que tengas y veo que tienes solo varnish cache, te recordamos que esta es una cache a nivel de servidor, faltaría que tengas otro por ejemplo:

https://www.webempresa.com/blog/autoptimize-wordpress.html

Luego de que tengas esto actualizado, verifica vaciando ambas cache, si sigue sin funcionar desactivar varnish cache y prueba nuevamente.

Un saludo 🖐️ 

ResponderCitar
Respondido : 24/09/2022 4:29 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Mario Iván
 Mario Iván
Usuario eminente

@argenis Disculpa, me desconecté un poco pero por fin puedo regresar al tema. He instalado Autoptimize con la configuración que menciona el enlace que me enviaste, también vacié caché de ambos plugins (autoptimize y Varnish), he desactivado varnish y sigo sin poder visualizar la imagen de Facebook configurada en Yoast SEO. ¿Me ayudas a conseguirlo?

ResponderCitar
Respondido : 29/11/2022 3:03 am
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Mario,

Si aun no se muestra la imagen te dejo las siguientes recomendaciones

-Validar que Yoast este actualizado
-Cambiar la imagen, puede ser la misma pero puedes renombrarla por algo mas simple ya que en ocasiones las imagenes con algunos caracteres suelen entrar en conflicto
-Vaciar la cache del sitio
-Aguardar que el cambio se propague y FB lo tome

Saludos!

ResponderCitar
Respondido : 29/11/2022 4:22 am

Cursos Gratuitos WordPress

Mario Iván
 Mario Iván
Usuario eminente

@bruno-vichetti Gracias por tu respuesta, revisé todos los puntos que comentas pero sigue sin mostrarse. Solo se muestran las imágenes destacadas, y lo que quiero es que se muestren las imagenes configuradas en Yoast SEO.

En el home si muestra la imagen que configuré con Yoast SEO pero no tengo ninguna imagen destacada, en las páginas de productos no puedo quitar las imágenes destacadas por que funcionan como la imágen principal del producto que se muestra en la tienda.

Habrá alguna otra cosa que pudiera estar mal??

ResponderCitar
Respondido : 29/11/2022 6:45 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mario.

Por casualidad lso productos los estas importando desde un archivo CSV ?

Prueba lo siguiente:

.- Instala el siguiente plugin:

-> Yoast Test Helper

Una vez instalado:

.- Accede a Herramientas -> Yoast Text

.- Selecciona " Reset indexables tables "

screenshot mary52.webempresa.eu 2022.11.29 14 00 57

 

Una vez termini:

.-Accede a yoast seo -> Herramientas y pulsa en el Botón " Empezar al optimización de datos seo "

screenshot mary52.webempresa.eu 2022.11.29 14 03 54 (1)

 

Revisa si con eso se soluciona

 

Un Saludo

 

 

ResponderCitar
Respondido : 29/11/2022 1:06 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress