Avisos
Vaciar todo

[Resuelto] No me deja clickar en el menú en el móvil  

 
Iratxe
 Iratxe
Usuario activo

Buenas tardes, estoy detectando un error en el menú del móvil. En la versión de escritorio, funciona bien. El error solo aparece en el móvil.

Os detallo mejor el problema: Este problema en abrir el menú solo ocurre en la página de inicio de la versión móvil. Es decir, si pincho en alguno de los botones de la página principal que me lleva a otra página de mi web, entonces si funciona el menú. Incluso vuelvo a la página de inicio y entonces, si funciona. No se muy bien qué es lo que está ocurriendo y no logro ver el error para poder arreglarlo. Parece como si el funcionamiento del menú se estuviera retrasando por algún motivo. No se cuándo empezó el problema y si se debe a alguna actualización de algún pluging o del tema. Tengo el tema y todos los plugings actualizados.

Lo que he probado para ver si el error desaparece: 

  • He vaciado la caché de varnish, wp rocket y autoptimize
  • He eliminado el pluging autoptimize
  • He desactivado Lazyload en WP Rocket
  • He desactivado la opción add missing image dimensions en WP rocket
  • He abierto un ticket en webempresa y me han dicho que a nivel servidor no ven ningún problema

El tema que uso es este: NeveVersión: 3.0.10

Ya no se qué más probar. ¿Alguna ayuda?

Contenido solo visible a usuarios registrados

Respondido : 04/11/2021 2:32 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Iratxe, 

Es muy posible que algún otro plugin esté ocasionando el conflicto e impida el correcto funcionamiento de tu sitio web, para verificar prueba desactivar todos los plugins y dejar solo los requeridos por tu tema, luego verifica si el menú funciona de forma correcta si es así ve activando uno por uno mientras realizas pruebas hasta determinar cuál puede estar generando este conflicto

Verifica esto y nos comentas como ha ido todo

Un Saludo 

Respondido : 04/11/2021 3:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Iratxe
 Iratxe
Usuario activo

@karen Hola Karen! Muchas gracias por tu respuesta. Pues he desactivado todos los plugins, excepto Stackable - Gutenberg Blocks y
Neve Pro Addon (creo que esos son los que necesita el tema para funcionar). He probado a ver si funcionaba el menú y sigue sin funcionar. No se si lo he hecho bien, porque he desactivado todos los plugins, pero me sigue apareciendo el aviso de las cookies. Yo las cookies las tengo puestas con un plugin que se llama Cookiebot | GDPR/CCPA Compliant Cookie Consent and Control. Entiendo que al desactivar ese plugin, no debería de aparecerme el aviso de las cookies no? Por eso estoy dudando de si he desactivado bien los plugins. Porque si ese paso no lo he hecho bien, puede que el menú siga sin aparecer por algún plugin. He desactivado bien los plugins? O si me sale el aviso de cookies es porque he hecho algo mal? Gracias de nuevo!

Respondido : 04/11/2021 3:48 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Iratxe, 

Lo que actualmente veo es que algo está bloqueando una funcionalidad en tu sitio web cuando se pulsa el botón del menú en la página de inicio para la versión móvil, por ejemplo si no acepto las cookies no se muestra el menú, pero una vez las acepto y recargo la página esta funciona sin problema, te envió un video de las pruebas que he realizado

Es posible que las opciones de consentimiento esté bloqueando esta funcionalidad, verifica si tienes algún código añadido para la aceptación de cookies en el archivo header.php de tu sitio web, actualmente si inspecciono el código de tu sitio web veo que tienes esto 

image

Prueba remover este código y borra las caché de tu sitio web, luego comprueba si con ello el menú funciona de forma correcta

PD: Antes de realizar cualquier cambio realiza una copia de seguridad de tu sitio web, de esta forma si se genera algún error puedes restaurarla

Un Saludo 

Respondido : 04/11/2021 4:09 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Iratxe
 Iratxe
Usuario activo

He probado a eliminarlo y me sale un error. Te adjunto pantallazo. Muchas gracias por tu ayuda

pantallazo

 

Respondido : 04/11/2021 4:39 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Iratxe,

Debes eliminarlo del todo, lo que pasa es que no te lo podemos marcar del todo en el inspeccionador pero debes eliminarlo por completo y dejar únicamente el código de tag manager.

Un saludo 🖐️ 

Respondido : 04/11/2021 4:46 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Iratxe
 Iratxe
Usuario activo

@argenisBuenos días, he eliminado esa parte del código y sigue sin funcionar. He vaciado la caché de varnis y wp rocket, pero sigue sin funcionar. No se qué más puedo hacer o dónde puede estar el error. Gracias

Respondido : 08/11/2021 10:53 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iratxe

Veo que se esta mostrado el menu:

Archivo 000

Realiza una limpieza de navegador:

-> https://support.google.com/accounts/answer/32050?co=GENIE.Platform%3DAndroid&oco=1

.- Revisa con él navegador en privado:

-> https://support.google.com/chrome/answer/95464

 

Un saludo

 

 

Respondido : 08/11/2021 11:48 am

Cursos Gratuitos WordPress

Iratxe
 Iratxe
Usuario activo

Hola, muchas gracias! He borrado cookies y he navegado en incognito, pero sigue pasando.

Hemos estado haciendo pruebas. En el móvil de mi pareja y mi padre no funciona. Sin embargo, a mi madre si le deja. 

Adjunto un vídeo de lo que ocurre en mi móvil. Un saludo!

 

Respondido : 08/11/2021 12:48 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Iratxe, 

Lo que sucede en este caso es que aun al aceptar las cookies debes recargar la página, ten en cuenta que aceptas las cookies, pero esta página no  de recarga por lo que aun está el bloqueo de la funcionalidad del menú que añade estas opciones, te envió una captura sobre la prueba que realice

Realiza estas pruebas y verifica si al hacerlo el menú se muestra de forma correcta, verifica esto y nos comentas como ha ido todo

Un Saludo 

Respondido : 08/11/2021 1:03 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Iratxe
 Iratxe
Usuario activo

Si, efectivamente eso es lo que me pasa. Hay que recargar la página para que el menú funcione. Cómo puedo solucionarlo?

Respondido : 09/11/2021 7:53 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Iratxe.

Pues veo que se puede seleccionar incluso activado la protección de Cookies:

Archivo 000 (1)

Revisa con un terminal distinto.

 

Un saludo

 

Respondido : 09/11/2021 9:46 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Iratxe
 Iratxe
Usuario activo

@pepesoler Hola! Ahora si que deja incluso sin aceptar las cookies. Es por un cambio que he hecho y que ha resuelto el problema. Lo dejo explicado por aquí por si a alguien le pasa en algún momento. 

El plugin que estaba generando el error es este: Cookiebot | GDPR/CCPA Compliant Cookie Consent and Control

Estas cookies se pueden agregar a la web de dos formas: 

1. Copiando un código en el head

2. Instalando un plugin

Yo lo hice instalando el pluging. En los ajustes del plugin te deja elegir Cookie-blocking mode y da dos opciones: automatic o manual. Si lo ponemos en automatic es cuando ocurre el error en el menú. Yo lo he puesto en manual y ahora el menú funciona sin necesidad de que la página se recargue. Así que solucionado. Muchas gracias a todos por vuestra ayuda!

Respondido : 09/11/2021 3:13 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Iratxe, 

Enhorabuena has logrado configurar las opciones correctas para que no se genere ningún error de compatibilidad en tu sitio web, muchas gracias por detallarnos el procedimiento estoy segura de que será de utilidad para otro usuario que presente el mismo inconveniente. 

Con esto podemos dar el tema como solucionado, escríbenos si tienes cualquier otra consulta

Un Saludo 😊 

 
Esta publicación ha sido modificada el hace 4 semanas por Karen Rios
Respondido : 09/11/2021 3:22 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress