Avisos
Vaciar todo

PHP Warning: ini_set() has been disabled for security reasons  

 
Pablo
 Pablo
Nuevo usuario

Buenos días,
Ayer actualicé el plugin de Cornerstone de mi web https://dechavesmotion.com/ y desde entonces me aparece en la cabecera de la web este mensaje:
":PHP Warning: ini_set() has been disabled for security reasons in /home/fabricat/public_html/dechavesmotion.com/wp-content/plugins/cornerstone/includes/classes/Tss/StyleParser.php on line 203."

Por si sirve de ayuda, la línea 203 pone esto: ini_set('xdebug.max_nesting_level', 500);

También actualicé a la versión de wordpress: 5.9.3

Luego actualicé la versión de PHP a PHP 7.4 porque me aparecía una notificación de que debía actualizar.

En la web del autor del Tema "X" de theme.co que funciona con Cornerstone me pone lo siguiete:
Thank you for writing in, please contact your hosting provider and ask how you can modify the site php.ini, disable_functions item and remove ini_set from the list.

En los parámetros de configuración de php le he dado a "on" pero no veo ninguna diferencia.

Otro problema que tengo es que el plugin Cornerstone no me funciona correctamente. No me deja editar las páginas.
Me podéis orientar para solucionarlo?

Contenido solo visible a usuarios registrados

Citar
Respondido : 19/04/2022 1:08 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Pablo,

En este caso envía un ticket a soporte para que puedan verificar que ocurre y puedan validar la información que nos comentas 

 

Verifica esto y nos comentas cómo ha ido todo

Un Saludo 

ResponderCitar
Respondido : 19/04/2022 1:48 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo
 Pablo
Nuevo usuario

Hola Karen,

Ya había enviado un ticket a soporte y me contestaron lo siguiente:

"Revisando veo que la configuración es correcta y la función ini_set realmente está haiblitada y no te debería generar problemas.

Es posible que si has actualizado el tema, plugin, el propio sitio o haya algún modo debug, por eso tengas problemas.

Si quieres podemos igualmente nosotros ayudarte, pero lo tienes que realizar en el canal adecuado que es el foro de soporte de Webempresa"

Podéis ayudarme desde el foro?

Gracias

 

 

ResponderCitar
Respondido : 19/04/2022 1:56 pm
Pablo
 Pablo
Nuevo usuario

Hola Karen,

Parece que ahora todo funciona correctamente. No entiendo que habrá pasado...

Un saludo,

 

ResponderCitar
Respondido : 19/04/2022 2:10 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Pablo.

Fuiste mas rápido que yo en revisarlo y contestar 😀 

Realmente lo hay que hacer es desactivar ini_set como indican en esta entrada del soporte:

-> https://theme.co/forum/t/php-warning-ini-set-has-been-disabled-for-security-reasons/92965

Ya lo hemos desactivado y veo que esta cargando sin el aviso.

Revisa y nos comentas si todo esta cargando sin problemas.

 

Un saludo

 

Esta publicación ha sido modificada el hace 1 mes por Pepe
ResponderCitar
Respondido : 19/04/2022 2:15 pm