Avisos
Vaciar todo

Problema subir imágenes al crear un anuncio en mi web  

 
Rafael
 Rafael
Usuario activo

Hola,

ayer migré a este servidor y estoy teniendo un problema que no lo tenía en el anterior, mi página es de anuncios clasificados, y se trata que los usuarios puedan publicar anuncios subiendo fotos, estas fotos las pueden arrastrar (hasta 15) y luego, la plantilla crea una galería a la hora de mostrar el anuncio.

El caso es que tengo wp-config bien configurado con todo, hasta un máximo de 512MB y demás, y en php todos los valores al máximo y mientras sube, no da tiempo a que los cargue y crea el anuncio con toda la información y con las fotos que le haya dado tiempo a subir (normalmente una o ninguna).

A la hora de publicar el anuncio, al darle a guardar, aparece un porcentaje de carga, y se queda entre el 12% y el 28% aprox y ahí cambia de pantalla al panel de control del usuario creando el anuncio pero sin imágenes. Esto está sucediendo desde que he cambiado de hosting, supongo que será por algo de configuración, pero todo lo que está en mis manos y conocimientos, lo he revisado y parece estar bien.

Saludos y gracias.

Contenido solo visible a usuarios registrados

Citar
Respondido : 17/03/2021 9:58 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Rafael,

Veo que tienes versión 7.4 de php, prueba el bajarla a 7.3 adicional a esto aumenta los valores php, para ello puedes verificar en esta guía:

https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Tampoco podemos acceder al área que nos comentas para validar si es un error a nivel de javascript, podrias suministrarnos un usuario solo con permisos de publicación en el front, es decir sin acceso al área administrativa del wordpress para poder acceder a esta zona y validar.

Un saludo 🖐️ 

ResponderCitar
Respondido : 17/03/2021 10:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Rafael
 Rafael
Usuario activo

Hola de nuevo,

 

gracias por la respuesta, si, he probado cambiando a versiones anteriores de php, en el servidor anterior funcionaba con la última tambien, y tambien modificando sus parámetros, pero el error es el mismo.

 

En cuanto al acceso, si lo que quieren hacer es entrar como un usuario normal, pueden ustedes registrarse con una dirección de correo electrónico o con una cuenta de facebook o gmail directamente, prefiero no dar credenciales por aquí.

 

Un saludo y gracias.

ResponderCitar
Respondido : 17/03/2021 11:33 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Rafael, 

Veo una serie de errores en la consola del explorador al momento de enviar el formulario, los errores están relacionados con código javascript del mapa, del recaptcha y de un evento de facebook que se lanza al momento. Así mismo, al procesar el formulario, el único error que veo en pantalla es "Ubicación no puesta" aún cuando ya elegí una en el buscador, ya probé con varias de distintos países y el error es el mismo. Debes tener un conflicto con algún plugin, te sugiero desactivar todos los plugins, excepto contact form, crea un nuevo formulario donde solo pidas imágenes, allí veremos si el problema es con las imágenes o si viene de otro lado.

Saludos 

ResponderCitar
Respondido : 18/03/2021 12:17 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rafael
 Rafael
Usuario activo

@bulmaro-webempresa

Gracias, el caso es que acabo de desactivar los módulos dejando los indispensables para que la web funcione, y sigue pasando... Esto no pasaba en el hosting anterior, por favor, necesito solucionarlo cuanto antes.

 

Gracias.

ResponderCitar
Respondido : 18/03/2021 8:14 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Rafael.

Veo el siguiente aviso:

[17-Mar-2021 11:49:32 UTC] PHP Notice: Constant WP_CACHE already defined in /home2/solobarc/public_html/solobarcos.es/wp-config.php on line 81

 

Este aviso es por la linea " require_once('ABSPATH' . 'wp-settings.php'); " que no estaba bien faltaban las comillas en 'ABSPATH', 

Revisa si puedes cargar las imagenes.

 

¿ solo pasa con las imagenes de los anuncios o no puedes cargar ninguna imagen ?

Si no se soluciona:

.- Accede ajustes -> medios 

.- Adjunta una captura de "

Captura de pantalla 2021 03 18 a las 10.30.02

 

Un saludo

 

ResponderCitar
Respondido : 18/03/2021 9:31 am

Cursos Gratuitos WordPress

Rafael
 Rafael
Usuario activo

@pepesoler gracias por la respuesta,

 

el caso es que con el módulo wp-caché desactivado, incluso lo acabo de borrar, me sigue fallando, el programador del tema me ha dicho que es un problema de ajax.js (ni siquiera le deja acceder con su cuenta, no sé por qué...) Pero vamos, despues de ver todo lo que estoy viendo creo que es un problema de java.

Tengo una copia de seguridad del antiguo servidor, sería buena idea volcarlo todo de nuevo?

 

Gracias.

 

Un saludo.

ResponderCitar
Respondido : 18/03/2021 10:04 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Rafael.

ni siquiera le deja acceder con su cuenta, 

Se conecta desde un país de habla no hispana ?

Los países de habla no hispana estan bloqueados por motivos de seguridad. Puedes permitir el acceso desde tu cuenta de cPanel:

-> https://guias.webempresa.com/preguntas-frecuentes/acceso-desde-paises-habla-no-hispana/

 

Si no es eso pro favor que te indique el problema que tiene al acceder paar que podamos revisarlo.

 

sería buena idea volcarlo todo de nuevo?

Sí, seria bueno probarlo por si la migración no termino de realizarse bien.

Puedes instalar en la URL temporal y así no tienes la web en producción parada mientras revisamos lo que puede estar pasando.

 

Un saludo

 

ResponderCitar
Respondido : 18/03/2021 10:27 am

wpdoctor-revisa-la-salud-de-tu-wordpress