certificado ssl - redirigir de http:// a https://  

 
Mauricio
 Mauricio
Usuario eminente

Hola -de nuevo- :blush:

He instalado con éxito el certificado ssl en mi dominio ****.es que es el principal del hosting. el nombre es idéntico al del sitio consultado, salvo por el .mx en lugar de .es y por supuesto se encuentra en el mismo hosting.

Creo haber llevado a cabo los mismo pasos que con el *.es, pero el hecho es que en lugar de redireccionar a https con www lo hace a https sin las 3 www y no aparece el candado verde, sino una i que indica que no es seguro.

 

Ya he leído:
-Códigos útiles .htaccess para sitios web (me enteré de poco)
-Una vez instalado el certificado SSL, ¿Cómo configuro Joomla? (fue el que me guió en la primera instalación)
-Migración de http a https (no me aclaré nada)

Saludos.

URL del sitio: Contenido solo visible a usuarios registrados

This topic was modified hace 5 meses por Gerard Martínez

Maus

Citar
Respondido : 21/06/2017 1:25 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mauricio.

Lo tienes bien instalado, lo que te indica es que tienes contenido mixto, es decir que algunas partes de tu web esta sirviendo información que no esta cifrada, en este caso por ejemplo son las imágenes que se estan cargando desde nuestros servidores de las demos que no estan cifradas y cargan con esta URL:

<img src=" http://demopackempresa.webempresa.eu/img/140x14 0" class="img-circle">

Modifica esas imágenes y carga las quieres mostrar, es posible que tengas algunas mas que tambien tengas que cambiar por ejemplo en la página de inicio el logo de gantry que aparece en el footer, pero lo iremos viendo por partes.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 21/06/2017 1:35 pm

Cursos Gratuitos WordPress

Mauricio
 Mauricio
Usuario eminente

Perfecto. Hoy por la tarde termino de cambiarlas y te cuento.

Gracias!

Maus

ResponderCitar
Respondido : 21/06/2017 2:14 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mauricio.

Ok dejamos el hilo en espera por si necesitas retomar esta consulta.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 21/06/2017 2:23 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mauricio
 Mauricio
Usuario eminente

En efecto ahora ya indica seguro con su candado verde.

La única diferencia es que no dice
https://www.sitio.com

únicamente
https://sitio.com

preferiría, si puede ser, que aparezcan las www. Los usuarios son raros y estos detalles los ponen de los nervios. Además, francamente a ver si me lo explicas, no sé si hay alguna diferencia en términos prácticos y reales.

Saludos!

Maus

ResponderCitar
Respondido : 21/06/2017 7:25 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Para redirigir a www y https debes hacerlo por .htaccess, tienes ya puesto algún codigo de redirección?, te sugiero revisar :

https://www.webempresa.com/blog/redirecciona-urls-de-forma-correcta-usando-cpanel-y-htaccess.html

Sin embargo no es tan importante tener www o no, Google te considerará igual asi que no tienes porque preocuparte, en términos prácticos hay una tendencia a no usar www para reducir la cantidad de caracteres de la url.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/06/2017 11:42 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Mauricio
 Mauricio
Usuario eminente

Gracias.

Tengo algunas preguntas para comprenderlo mejor. En mi hosting alojo de momento 2 dominios: *.es y *.mx

En su momento enfrenté este problema con el *.es que fue el primero en estar operativo y el *.mx se redireccionaba al *.es

Ahora cuando quiero cambiar otra vez el .htaccess veo que no está el re-direccionamiento que en su día hice del *.es no obstante, se redirecciona.
***********
## No directory listings
IndexIgnore *

## Can be commented out if causes errors, see notes above.
Options +FollowSymlinks
Options -Indexes

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site then comment out the operations listed
# below by adding a # to the beginning of the line.
# This attempts to block the most common type of exploit `attempts` on Joomla!
#
***********

Por otra parte ya esta re-direccionado en el re-direcciona de cPanel

marca error.

He eliminado el código de .htaccess y ya redirecciona OK.

No entiendo... pero ya funciona.

Saludos.

Maus

ResponderCitar
Respondido : 22/06/2017 10:30 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mauricio.

Puede ser que lo tengas en tu cuenta de cPanel, Puedes comprobarlo accediendo al bloque Dominios -> Redirige

Para que tu web cargue con www añade lo siguiente a tu archivo htaccess:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^quieroabogado.es [NC]
RewriteRule ^(.*)$  http://www.quieroabogado.es/$1  [L,R=301]

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 22/06/2017 10:47 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro