Avisos
Vaciar todo

[Resuelto] Fijar los elementos en hover  

 
David
 David
Usuario eminente

Muy buenas,

Los elementos del encabezado y pie de página se mueven al hacer hover. Ocurre porque le he añadido un borde inferior al bloque de cada elemento para que al hacer hover se subraye, pero esto hace que el elemento se mueva. He estado leyendo que se puede utilizar el comando inline-block, pero no consigo solucionarlo.

¿Qué podría hacer?

 

Un saludo y gracias como siempre

Contenido solo visible a usuarios registrados

Respondido : 11/12/2020 11:31 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola David,

He navegado por tu web pero no logro identificar a qué elementos te refieres con que "se mueven", ¿Podrías enviarnos una captura de pantalla y señalarnos dichos elementos? Por favor.

Saludos

Respondido : 12/12/2020 12:25 am
David
 David
Usuario eminente

Muy buenas,

 

Gracias por tu respuesta

Te adjunto fotos.

 

En Chrome se mueven entero los elementos del encabezado. En difrefox, solo las flechitas, por que probé añadiendo margen en no hover y parece "funcionar". El pie de página se mueve en ambos navegadores.

moveencabezado
movepiepagina

 

Respondido : 12/12/2020 12:27 am
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@urika1995gmail-com

Hola, 

El único movimiento que noto es el que da por el espacio que ocupa el subrayado y que es casi imperceptible, si pudieras enviarnos una captura de pantalla del movimiento que visualizas al hacer el hover sería lo ideal. Aunque si al movimiento que yo me refiero es el que tu estás notando dudo mucho que pueda corregirse.

Saludos

Respondido : 12/12/2020 1:30 am
David
 David
Usuario eminente

Muy buenas, ese era el problema. 

 

Ocurría tanto en los elementos de la cabecera, en los de dentro del menú y en los elementos del pie de página.

 

Lo he solucionado con un borde transparente, muchas gracias!

Respondido : 12/12/2020 5:36 pm