Avisos
Vaciar todo

[Resuelto] Problema con el menú principal  

 
Mary Greicy
 Mary Greicy
Usuario activo

Tengo una página única y busco que desde el menú principal se navegue entre secciones. En las secciones que quiero enlazar, en el apartado avanzado- identificador css les di un nombre a cada una. Después en apariencia- menú- menú principal he añadido enlaces personalizados, en "url" he puesto # con el nombre de la sección. ejemplo: #servicios y en "texto del enlace" he puesto el nombre con el que aparecerá en la página publicada. 

Este proceso lo he hecho antes con éxito, pero esta vez al hacer clic en el menú parece que no estuviera enlazado, no se que estoy haciendo mal. ¿Podría, por favor, ayudarme? muchas gracias. 

La página es www.insercym.com

Contenido solo visible a usuarios registrados

Respondido : 26/01/2021 6:51 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Mary,

Es muy raro que no se pueda navegar de forma correcta entre las anclas del menú, prueba verificar si algún plugin esta causando el conflicto. Para ello desactiva todos y deja solo los requeridos por tu tema luego verificar si logras navegar entre las secciones, si es así, ve activando uno por uno hasta determinar cual causa el conflicto.

De igual forma verifica si tienes algún actualización disponibles del tema Divi y prueba actualizarlo, luego comprueba si al hacerlo se soluciona el problema de navegación

PD: Antes de realizar cualquier actualización realiza una copia de seguridad de tu sitio web, de esta forma si se genera algún error puedes restaurarla. Te comparto el siguiente articulo donde mencionan como realizar una copia de seguridad de forma rapida -> https://www.webempresa.com/blog/backups-wordpress-en-2-minutos-con-all-in-one-migration.html

Un Saludo

Respondido : 26/01/2021 7:03 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Sólo veo que tienes el ID creado para servicios, asegúrate de que en HTML tengas todos los menús creados de manera similar, veoq que en algunos usas /, y además que el ID al que apuntará el menú existe en HTML.

Revisa el siguiente artículo relacionado: https://decodecms.com/crear-un-sitio-one-page-en-wordpress/

Saludos.

Respondido : 26/01/2021 7:11 pm
Mary Greicy
 Mary Greicy
Usuario activo

@karen muchas gracias, te cuento que ya intenté lo que me sugieres y no funciona 🙁 ya no se que hacer. Puedes sugerirme algo más? por favor?

Respondido : 30/01/2021 12:20 am
Mary Greicy
 Mary Greicy
Usuario activo

me preocupa porque esto solo me ha pasado despues de adquirir divi con web empresa, antes lo tenia directamente con elegant themes y funcionaba. Ayuda por favor!

Respondido : 30/01/2021 12:23 am
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@sinfoniacreativamedgmail-com

Hola Mary,

Revisa la respuesta de mi compañero @jhon, primero revisa tus enlaces personalizados del menú y posteriormente revisa que la sección o elemento que desees enlazar tenga el identificador idéntico al enlace configurado, debes ingresar solo el nombre del ancla y del identificador, evita el / y #. Observa las siguientes capturas, realiza las configuraciones tal como se muestran:

Captura de Pantalla 2021 01 29 a la(s) 18.45.23
Captura de Pantalla 2021 01 29 a la(s) 18.44.59

Saludos

Respondido : 30/01/2021 12:50 am
Mary Greicy
 Mary Greicy
Usuario activo

@bulmaro-webempresa Muchas gracias, he revisado las capturas que me envías y lo he hecho exactamente igual  y aún así no funciona. 

Respondido : 01/02/2021 5:41 pm
Mary Greicy
 Mary Greicy
Usuario activo
DIVI 2
DIVI 1

Adjunto las imagenes

Respondido : 01/02/2021 6:00 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mary,

Veo inspeccionando tu instalación que tienes la versión 4.2.2 de divi cuando actualmente la última es la versión 4.8.2, has verificado Actualizar esta versión de divi (tema activo) para confirmar que se solvente en esta actualización?

PD: Antes de realizar cualquier actualización realiza una copia de seguridad de tu sitio web, puedes hacerlo por medio del método que te compartió mi compañera Karen previamente o bien con superbackup > https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-seguridad-superbackup/.

Verifica y nos comentas, un saludo 🖐️ 

Respondido : 01/02/2021 6:04 pm
Mary Greicy
 Mary Greicy
Usuario activo

@argenis muchas gracias. Puedes indicarme como actualizarlo por favor?

 

Respondido : 01/02/2021 8:27 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Mary,

Una vez tengas el respaldo a la mano y estés segura que no se perderá nada en caso que salga mal, ingresas al panel lateral de wordpress Apariencias > Temas.

Dentro de estos haces clic en tu tema activo y se mostrará la opción para actualizar:

image

Un saludo 🖐️ 

Respondido : 01/02/2021 8:38 pm
Mary Greicy
 Mary Greicy
Usuario activo

Muchas gracias!!!

Respondido : 01/02/2021 10:25 pm
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@sinfoniacreativamedgmail-com

Hola Mary,

Muchas gracias a ti por consultarnos en el foro, por tu confianza y preferencia en Webempresa.

Quedamos atentos a tus futuras consultas.

Saludos 🙂

Respondido : 01/02/2021 10:48 pm