Problemas con el carro  

 
Antonio Ortiz
 Antonio Ortiz
Usuario experto

Hola.

Cuando añado un producto al carro de la compra en IExplorer funciona de lujo tanto como usuario registrado como anónimo.
El problema está en Chrome, Safari y Firefox que no añaden nada al carro ni mueven una pestaña ni siquiera para decir si hay o no algún problema.

He repasado los módulos y extensiones instaladas y he incluso despublicado los últimos que instalé aún cuando el problema ya lo tenía desde antes de dichas instalaciones.

He vaciado la caché, he hecho un desbloqueo global ya nada.

He desinstalado NoixACL y reinstalado la última versión de NinjaXplorer.

Ya no sé qué hacer. Aquí les mando mi error.log

Gracias

URL del sitio: http://www.potshop.es

URL del sitio: http://www.potshop.es

Citar
Respondido : 09/05/2012 8:32 am
David Noguera
 David Noguera
Miembro Admin

Hola Toni, no nos ha llegado el error_log, por favor reenvíalo.

Mírate este vídeo y obten los errores de tu web:

https://www.webempresa.com/blog/que-es-un-error-500-y-como-localizarlo-en-nuestra-web.html

Envíanoslos si no sabes como solucionarlo y te ayudamos.

Por otro lado, si el problema es que no añade al carro, por favor, reproduce el problema con Firefox y con la consola de Firebug abierta y envíanos los errores Javascript que veas..

Saludos!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/05/2012 9:36 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Antonio Ortiz
 Antonio Ortiz
Usuario experto


Gracias David por el cable.

Aquí te mando el "error.log" como los ficheros a los que hace referencia.

Cualquier ayuda es bienvenida.

Gracias de nuevo

ResponderCitar
Respondido : 09/05/2012 2:37 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Toni

Los errores que te aparecen son a nivel de adminstración error_log

Si te funciona en IE y en el resto de navegadores no , significa que posiblemente existe un problema de conflicto de extensiones, o una modificación accidental de algún archivo javascript.

Si es esto último entonces es dificil dar con el problema, si tienes una copia de seguridad , respalda tu sitio web.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/05/2012 4:57 pm

Cursos Gratuitos WordPress

Antonio Ortiz
 Antonio Ortiz
Usuario experto

si recupero una copia de seguridad. ¿Me tocará las bases de datos de los productos?

ResponderCitar
Respondido : 09/05/2012 6:19 pm
Antonio Ortiz
 Antonio Ortiz
Usuario experto

Bueno. He recuperado una copia de hace unos 30 días y el problema ya existía. Así que... Ni idea de qué lo está provocando porque en ese momento yo no había cambiado nada que yo recuerde.

Me he dado cuenta de que cuando le doy añadir producto al carro en chrome sale lo que está en la imagen adjunta en la parte inferior izquierda del navegador

y de ahí no se mueve aunque no me impide volver a intentarlo o moverme por la página. Es como si esperara algo.

ResponderCitar
Respondido : 10/05/2012 1:25 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Antonio Ortiz
 Antonio Ortiz
Usuario experto

Vamos avanzando.
Si pongo la dirección de la web SIN las www. funciona en todos los navegadores!!!
He modificado el archivo .htaccess añadiéndole:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^www.potshop.es [NC]
RewriteRule ^(.*)$ http://potshop.es/$1 [L,R=301]

y ya está solucionado.

Sigo teniendo el problema de la notificación de que se ha añadido un elemento al carro. Me sigue saliendo detrás del resto de ventanas abiertas con lo que no puede leerse. Sólo en IExplorer se puede ver.

Cambié el .../templates/gk_yourshop/css/template.css
añadiéndole: #gk-content{z-index:-10000;}

como me comentó David pero no ha funcionado.
Solo IExplorer lo hace perfecto.

ResponderCitar
Respondido : 10/05/2012 1:47 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Toni,

public_html/administrator/components/com_virtuemart/virtuemart.cfg.php
se definen las url's de Virtuemart.

// these path and url definitions here are based on the Joomla! Configuration
define( 'URL', 'http://potshop.es/' );
define( 'SECUREURL', 'http://potshop.es/' );

lo más normal es poner con www, y entonces en el .htaccess realizar la redirección a la inversa.

Respecto al tema de la visualización de la ventana emergente, cuando se pulsa en "añadir al carro" que solo se visualiza en IE, es extraño ya que como puedes comprobar en la demo del pack funciona correctamente. Puede deberse a un plugin que hayas instalado, como por ejemplo los que tienes de twitter, imprimir, facebook, etc, procede a despublicar.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 10/05/2012 8:47 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Antonio Ortiz
 Antonio Ortiz
Usuario experto

Hola Jordi.

Probé a despublicarlos todos y nada.
Lode facebook, etc es unas línes de código en webempresa_details.tpl.php. Los quité para probar y nada.

Los estoy dejando por imposible.

Lo que me deja perplejo es que funcione en IExplorer y en los demás nada de nada.
Sale pero detrás.

ResponderCitar
Respondido : 10/05/2012 6:02 pm
Antonio Ortiz
 Antonio Ortiz
Usuario experto

Solucionado!!!

La solución estaba en: virtuemart--configuración--sitio--al lado de "seleccione un tema para su tienda" hay un enlace a "configuración". Le damos y dentro de la configuración le decimos "NO" a
"Use Ajax to add, update or delete products from the cart?"

Y todo como la seda con TODOS los exploradores del mundo mundial.

Voy a emborracharme que llevaba dos días y dos noches amargado con esto.

Gracias a todos. Poco a poco me habéis ido dando ideas y, sobre todo, he podido ir descartando cosas hasta acercarme a la solución.

ResponderCitar
Respondido : 10/05/2012 8:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro