Avisos
Vaciar todo

Cuando le doy al boton añadir al carro no me lo carga en el carrito  

Página 1 / 2
 
Davis
 Davis
Reputable Member

Buenas en mi pagina de inicio existen dos modulos uno que se llama OFERTAS y el otro MAS VISITADOS que son modulos de virtuemark, pero cuando le doy al boton de AÑADIR AL CARRRO de cualquiera de los dos modulos no me redirecciona a la pagina del carro sino que se vuelve a cargar la pagina de inicio, que podria ser el error, muchas gracias.

Envio captura de los modulos

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 13/10/2012 9:59 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Davis,

¿Las URLs de VirtueMart (URL Secure) las tienes configuradas con o sin www en la url del dominio?

¿Que versión "exacta" de VirtueMart estás utilizando?.

Saludos

ResponderCitar
Respondido : 13/10/2012 10:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Davis
 Davis
Reputable Member

Hola Luis

La URL Secure la http://davarcomponentes.com y donde dice Site URL tambien http://davarcomponentes.com y la version que estoy utilizando es la VirtueMart 1.1.9 stable.

Le envio captura

Muchas gracias.

ResponderCitar
Respondido : 13/10/2012 11:01 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Davis,

Teniendo en cuenta que tu dominio redirecciona al mismo pero con www, pon la url en URLs Seguras de VirtueMart con www, limpia caché y prueba si funciona el botón de anadir al carro.

Si no funciona, deshabilita las URLs amigables de tu Configuración Global y prueba nuevamente.

Saludos

ResponderCitar
Respondido : 13/10/2012 11:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Davis
 Davis
Reputable Member

Buenas GNUMAX

Hice lo que me indicaste, pero continua igual cuando le doy al boton añadir no hace nada.

Saludos

ResponderCitar
Respondido : 13/10/2012 11:56 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Davis,

Veo que esto solo sucede en los módulos de "Ofertas" y "Más visitados" tal como indicabas al principio de tu consulta, sin embargo si accedo a categorías de productos estos si se añaden correctamente al carrito.

¿Qué módulos utilizas para "Ofertas" y "Más visitados"?
Facilitanos capturas de uno de ellos (cualquiera de los dos) para ver las configuraciones.

Veo que el tema de URLS amigables tampoco es parte del problema asi que si quieres las puedes habilitar de nuevo.

Prueba a habilitar el módulo "Ofertas" para que se muestre tambien el "Mapa de la Web" Contenido solo visible a usuarios registrados para descartar conflictos con otros módulos de portada.

Saludos

ResponderCitar
Respondido : 14/10/2012 12:04 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Davis
 Davis
Reputable Member

El modulo que utilizo para Ofertas y para Mas Visitados es mod_virtuemart_randomprod para ambos y las capturas de la configuracion de cada uno, ya te las habia enviado anteriormente

Saludos

ResponderCitar
Respondido : 14/10/2012 12:31 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Davis

Has realizado algún tipo de modificación en código para la extensión virtuemart?

Veo por ejemplo que en la definición del botón no aparece el nombre del formulario ni el id

Prueba cambiando de template de Joomla y verifica si te funciona.

Otra opción es que reinstales estos módulos, descárgate el paquete completo desde :
http://dev.virtuemart.net/projects/virtuemart/files

El archivo : VirtueMart_1.1.9-COMPLETE_PACKAGE.j15.zip , luego al descomprimir ingresa a la carpeta de módulos

Realiza un backup de tu sitio web antes de realizar este procedimiento.

Saludos.

ResponderCitar
Respondido : 14/10/2012 4:20 pm

Cursos Gratuitos WordPress

Davis
 Davis
Reputable Member

Buenas John

Si le realice cambios, pero antes de los cambios tampoco me servia añadir al boton, ya volvi a instalar el modulo nuevamente como me lo indicaste pero todo sigue igual.

ResponderCitar
Respondido : 14/10/2012 6:06 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Tendrías que indicarnos los cambios que has realizado. Es muy posible que los problemas no estén en el módulo sino en la plantilla que estás usando en Virtuemart y, concretamente en la plantilla que carga los productos de los módulos de destacados, aleatorios, últimos productos, etc.

Parece que estás usando el tema ja-zeolite para Virtuemart. A modo de prueba temporal, vete al apartado Configuración de la administración de Virtuemart y pulsa en la pestaña Sitio. En el parámetro Seleccione un tema para su tienda elige la opción default y guarda los cambios. Recarga la página de inicio y comprueba si ahora te funcionan los botones de añadir al carro.

Si es así, prueba coger el archivo productsnapshot.tpl.php que tienes en la ruta components/com_virtuemart/themes/default/templates/common y colócalo en la ruta components/com_virtuemart/themes/ja-zeolite/templates/common sustituyendo al que allí se encuentra con el mismo nombre. Antes de hacer esto, realiza una copia de seguridad del archivo que vas a sustituir.

ResponderCitar
Respondido : 15/10/2012 3:35 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Davis
 Davis
Reputable Member

Buenos dias Pablo hice lo que me indicaste pero sigue sin funcionar mas bien me cambio la apariencia del apartado Configuración de la administración de Virtuemart, en el parametro Seleccione un tema para su tienda siempre ha estado en JA Zeolite y cuando lo puse en default me cambio la apariencia de la administracion de Virtuemart, y lo del tema de añadir al carro sigue igual.

Te envio una captura de como me quedo la apariencia de Virtuemart

Saludos

ResponderCitar
Respondido : 15/10/2012 5:23 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Davis

Lo que te indicó pablo no debería haber cambiado la apariencia del backend, sino más bien del front-end de tu sitio web.

Es extraño lo que sucede, con otras extensiones ves el backend correctamente?, has realizado modificaciones en los archivos PHP de virtuemart?

Te sugiero reinstalar virtuemart, realiza una copia de seguridad antes de realizar esto.

Saludos.

ResponderCitar
Respondido : 15/10/2012 10:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Davis
 Davis
Reputable Member

Buenos dias John

Cuando trato de volver a instalar el virtuemart me dice que ya tengo instalado uno, mi pregunta es, no hay ningun problema si elimino el virtuemart que tengo ahorita para volverlo a instalar? Lo que no quiero es que se me borre toda la informacion que le ingresado de los productos, o de que forma lo puedo volver a instalar usted seria tan amable de indicarme los pasos, gracias.

Saludos

ResponderCitar
Respondido : 17/10/2012 4:00 pm
Davis
 Davis
Reputable Member

Existe la posibilidad de pasar toda la plantilla y actualizarme el joomla a 2.5 manteniendo la misma plantilla ja-zeolite o alguna parecida, ustedes que opinan?

ResponderCitar
Respondido : 17/10/2012 4:03 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Davis

Si, deberías aprovechar para pasar tu Joomla y virtuemart a las últimas versiones.

Con respecto a los datos que ya tienes de virtuemart, prueba exportando tu información a través de una extensión como CSVImproved, puedes aprender más sobre esta extensión en el siguiente artículo

Luego podrás importar la información en tu Joomla 2.5 con virtuemart 2.0

Para migrar tu contenido de Joomla debes utilizar Jupgrade
https://www.webempresa.com/blog/migrando-joomla-15-a-joomla-25-con-jupgrade.html

Tienes que conseguir la extensiones y plantillas para la nueva versión de Joomla.

Lamentablemente no hay versión de ja zeolite para Joomla 2.5
http://www.joomlart.com/joomla/templates/ja-zeolite-ii

Sin embargo puedes evaluar usar una plantilla diferente con un diseño similar a zeolite

Saludos.

ResponderCitar
Respondido : 17/10/2012 6:32 pm
Página 1 / 2