Avisos
Vaciar todo

Problemas actualización de virtuemart 2 a 2.0.2  

Página 2 / 2
 
Sergio
 Sergio
Usuario eminente

Hola,

Acabo de actualizar a la nueva versión de virtuemart 2.0.2 ya que me ha aparecido en el componente una actualización pendiente (antes usaba la ultima versión estable 2.0.0) y en principio parece que todo funciona correctamente excepto cuando voy al menú y en las categorías no aparecen los productos. Solamente puedo acceder a los productos a través de los destacados o a través del buscador de productos en la web. Cuando vas al menú, haces clic en una categoría me sale este mensaje:

vmdebug self::$_jpConfig->lang es_es
vmdebug vmTime: loadConfig db no: 0.00205302238464
vmdebug Start used Ram 8.5M
vmdebug vmTime: VirtuemartControllerCategory Finished task : 0.0503628253937
vmdebug End used Ram 14.75M
vmdebug Peak memory peak 14.75M

Y así con todas las categorías. Estoy un poco perdido ya que no tengo ni idea de donde viene esto. He revisado todo dentro del componente en el backend y todo parece estar correcto, las categorías existen, los productos están bien relacionados con las categorías, las categorías están bien enlazadas con los menús...
Estoy perdidísimo! 🙁

Saludos,

URL del sitio: http://www.shencompany-shop.com

Citar
Respondido : 25/02/2012 2:55 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

La url Contenido solo visible a usuarios registrados no carga ¿es la url correcta?.

Saludos

ResponderCitar
Respondido : 28/02/2012 10:08 pm

Cursos Gratuitos WordPress

Sergio
 Sergio
Usuario eminente

Hola Luis,

Es cierto no carga...
Lo que he hecho es lo que me comentó Lucas:

"...mediante el uso de la extensión Akeeba Backup, la cual le permite realizar una copia completa de su sitio y base de datos en formato .jpa..."

"Sube el fichero a una carpeta que crees dentro de public_html como por ejemplo pruebas:
/public_html/pruebas"

Asi que ahora hay un fichero jpa en una carpeta nueva dentro de public_html. No se si lo que he hecho está bien o no era la forma de hacerlo, la verdad que soy muy novato en estos aspectos.

Saludos,

ResponderCitar
Respondido : 28/02/2012 10:18 pm
Sergio
 Sergio
Usuario eminente

Hola Luis,

Ya esta solucionado, ya funciona la url.

Saludos,

ResponderCitar
Respondido : 28/02/2012 11:05 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

Correcto, ahora carga bien 🙂

¿Puedes facilitar una captura de como tienes configurado "Parámetros de optimización de SEO" en tu Configuración Global?.

Saludos

ResponderCitar
Respondido : 29/02/2012 12:59 am
Sergio
 Sergio
Usuario eminente

Hola Luis,

Mando la captura.

Saludos,

ResponderCitar
Respondido : 29/02/2012 1:56 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Sergio,

Prueba a habilitar la opción "Usar la reescritura URL" para ver si mejora la url que se muestra en tu sitio web.

Saludos

ResponderCitar
Respondido : 29/02/2012 2:16 am
Sergio
 Sergio
Usuario eminente

Hola Luis,

He habilitado la opción "Usar la reescritura URL" en configuración SEO y me da una página de error.
Mando captura.

Saludos,

ResponderCitar
Respondido : 29/02/2012 9:20 am

wpdoctor-revisa-la-salud-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Sergio, revisa si hay algún error en tu error_log que provoque que no se muestren los productos en la categoría, puedes mirar este vídeo para ver como localizar los errores del error_log:

https://www.webempresa.com/blog/que-es-un-error-500-y-como-localizarlo-en-nuestra-web.html

Saludos

ResponderCitar
Respondido : 29/02/2012 10:05 am
Sergio
 Sergio
Usuario eminente

Hola David,

He revisado dentro de /public_html/pruebas que es el directorio donde ahora mismo tengo la copia de la web y el mensaje de error que sale registrado es:

[29-Feb-2012 11:03:27] PHP Fatal error: Call to undefined method JDocumentJSON::getHeadData() in /home/shencomp/public_html/pruebas/libraries/joomla/cache/cache.php on line 530

No se si será ese ya que la fecha es de hoy cuando he activado la opción "Usar la reescritura URL" . Así que imagino que no tiene nada que ver con el problema de las categorías de virtuemart...

Saludos,

ResponderCitar
Respondido : 29/02/2012 10:32 am

Cursos Gratuitos WordPress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Sergio,

Errores parecidos se producen cuando se ha actualizado Joomla! a una versión superior. ¿Que versión está usando, has actualizado posteriormente a versiones superiores?

Revisa en la configuración global --> Sistema --> Configuración Cache, que la tengas desactivada.

Saludos

ResponderCitar
Respondido : 29/02/2012 11:51 am
Sergio
 Sergio
Usuario eminente

Hola Jordi,

La versión de Joomla que estoy utilizando es la 1.7.4 y no la he actualizado ultimamente. La que si he actualizado es la de Virtuemart 2.0.0 a 2.0.2.... ahí surge el problema.

Ese mensaje de error ha salido al hacer esta mañana lo que me decia Luis:

"Prueba a habilitar la opción "Usar la reescritura URL" para ver si mejora la url que se muestra en tu sitio web."

No se si en la nueva versión han actualizado algo referente a las plantillas de las categorías pero no hay manera. Estoy probando de cambiar todo lo referente a las plantillas en los menú, en la configuración de virtuemart, en los productos... pero no hay manera, siguen sin salir.

Saludos,

ResponderCitar
Respondido : 29/02/2012 12:12 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Sergio

Para tener una mejor vista de lo que se esta cargando te sugiero deshabilitar las urls amigables ya que hemos visto que este no era el problema.

Actualmente veo que tu sitio carga correctamente, pero no se muestra productos, tienes productos en todas las categorías?, por ejemplo :
http://www.shencompany-shop.com/pruebas/index.php/es/tablas/curry-series

Para deshabilitar las urls amigables coloca todos los parametros a NO, especialmente el primero URL amigables para las máquinas de búsqueda.

Saludos.

ResponderCitar
Respondido : 29/02/2012 3:34 pm
Sergio
 Sergio
Usuario eminente

Hola Jhon,

Ya he deshabilitado las urls amigables.

Y sí, tal y como me preguntas, tengo productos en todas las categorías.
Puedes ver como funcionan todas las categorías correctamente en la web (no la de pruebas).

www.shencompany-shop.com

Saludos,

ResponderCitar
Respondido : 29/02/2012 3:40 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Sergio,

Si accedo a http://www.shencompany-shop.com --> bancos --> lleva a
http://www.shencompany-shop.com/index.php?option=com_virtuemart&view=category&virtuemart_category_id=9&Itemid=118&lang=es
y se visualiza correctamente.

En cambio http://www.shencompany-shop.com/pruebas --> bancos --> lleva a http://www.shencompany-shop.com/pruebas/index.php/es/bancos no se visualizan imágenes correctamente. ¿Se visualizaba bien antes de actualizar? Y desactivando las url's amigables o parámetros de SEO al igual que en la página principal que no es de pruebas.

Comentan temas de errores al actualizar en http://forum.virtuemart.net/index.php?topic=98683.0

Saludos

ResponderCitar
Respondido : 01/03/2012 11:04 am
Sergio
 Sergio
Usuario eminente

Hola,

Ya he encontrado el problema con la visualización de categorías al actualizar!
En "configuración del orden de productos", en el desplegable "Orden de productos por omisión" tenia configurado "Fecha de creación", lo he cambiado a "Nombre del producto" i voilà! Han vuelto a aparecer los productos en las categorías!

Gracias a todos por la ayuda

Un saludo,

ResponderCitar
Respondido : 02/04/2012 10:32 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Página 2 / 2