mensaje de error con router.php para urls amigables  

 
javier
 javier
Usuario eminente

Estimados amigos.

Estoy intentando habilitar las urls amigables en una tienda con virtuemart. A parte de activar los 3 parámetros SEO en la configuración del joomla, que funcionan bien, estoy intenando que las rutas hacia los productos sean amigables, siguiendo los pasos que habeis descrito en este mensaje: https://www.webempresa.com/foro/5-Virtuemart/22401-URL-Amigables-Virtuemart.html

He subido el archivo router.php a la carpeta del componente virtuemart, y la url del producto se vuelve amigable, sí, pero aparece un mensaje en el espacio lateral izquierdo de la página:

Notice: Object of class stdClass could not be converted to int in /var/www/vhost/(miweb.com)/home/html/components/com_virtuemart/router.php on line 436

Este mensaje se repite varias veces durante toda la columna, y aparece ya sea que se carge el inicio, la tienda, o cualquier apartado de la web.

Saludos.

Citar
Respondido : 21/01/2012 3:26 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Javier

Se agradece que cuando formules una consulta:

- Facilites la URL de tu sitio web donde podamos ver el problema.
- Trates de documentarla lo mejor posible, con capturas y enlaces concretos que apunten al problema.
- Informando de que versión de Joomla! utilizas así como la versión de la extensión que se encuentre implícita en tu problema concreto, así descartamos vulnerabilidades o incompatibilidades de versiones antiguas.
- Aquella información adicional que consideres importante que debamos tener en cuenta para ayudarte mejor.

Saludos y gracias por tu colaboración.

Envía la url de tu sitio web, indícanos además la versión de Joomla qu

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/01/2012 4:57 pm

Cursos Gratuitos WordPress

javier
 javier
Usuario eminente

Hola Jhon, gracias por tu respuesta, y lamento no haber dejado más datos sobre el problema...

En realidad ya lo he solucionado, instalando esta extensión, que me funciona bien:

http://extensions.joomla.org/extensions/extension-specific/virtuemart-extensions/virtuemart-administration/11665

De modo que no he necesitado el archivo router.php, pero gracias igualmente! 🙂

ResponderCitar
Respondido : 21/01/2012 5:15 pm

Por favor Iniciar Sesión o Registro