Avisos
Vaciar todo

Problema con cupones de descuento  

Página 2 / 3
 
Ramon Batista
 Ramon Batista
Usuario experto

Saludos,
La parte del descuento de los cupones estaba trabajando super bien, pero al actualizar el virtuemart, entonces ahora, no importa que le escriba el codigo del descuento, el boton de Grabar el cupon como que no funciona... O sea, no se aplica el descuento, como que no se ejecuta el comando de Grabar...
Que puedo hacer ?
Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 08/05/2014 3:10 pm
Peichi
 Peichi
Usuario experto

Hola,

En este caso si funciona el cupón de descuento.
Pero en el carro no salen las tallas ....
¿Cuál es la solución?

Gracias

ResponderCitar
Respondido : 19/10/2014 8:00 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He realizado pruebas con renombrar el directorio "cart" en el pack Shop and Buy y veo que los atributos del producto se siguen mostrando en el carro.

En tu carro también veo el atributo. No se si has dejado el directorio con el nombre original.

ResponderCitar
Respondido : 20/10/2014 12:35 pm
Peichi
 Peichi
Usuario experto

Hola Pablo,

Lo tenía desactivado.
Ya está activado y funciona. El problema es que después de elegir un producto y si le doy a continuar comprando y elijo más productos no se actualizan en el carrito de la compra. Sólo se actualiza el carrito después de usar el cupón. Esto en sí es un problema y si el cliente no tiene cupón más todavía.
Puede hacer la prueba ahora. Cupon : prueba11

Saludos

ResponderCitar
Respondido : 20/10/2014 2:50 pm

Cursos Gratuitos WordPress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No acabo de ver el problema que comentas. He probado en tu web a agregar productos al carro antes de activar el cupón y se añaden sin ningún problema. Después he probado a añadir el cupón y sigo pudiendo agregar artículos al carro de compra.

El funcionamiento que veo es siempre normal. Si estás hablando de otra cosa explícanos de la forma más detallada posible los pasos que sigues.

ResponderCitar
Respondido : 20/10/2014 3:20 pm
Peichi
 Peichi
Usuario experto

Hola PAblo,

Paso por paso.
1.- Añado un producto al carrito. Ningún problema. Voy a mostrar carrito y aparece.
2.- Añado un segundo producto al carrito. Cuando voy al carrito sólo aparece el primer producto.
3.- En el caso segundo añado el cupón de descuento y ya me aparecen los dos productos.

Te adjunto lo que comento.

Saludos

ResponderCitar
Respondido : 21/10/2014 11:28 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Peichi,

Como invitado en el sitio web, he iniciado el proceso de compra, y he añadido primero un producto, se visualiza correctamente en el módulo superior de carro de compra, y en la cesta, luego navego por el sitio web añado otro, y se visualiza correctamente en el módulo superior de carro de compra y en la cesta.

¿El problema te sucede como invitado, o como usuario ya registrado en el sitio web?

Saludos

ResponderCitar
Respondido : 21/10/2014 11:44 am
Peichi
 Peichi
Usuario experto

Hola Jordi,

Como invitado....
Uso Chrome de navegador y he probado con firefox y pasa lo mismo...

Saludos

ResponderCitar
Respondido : 21/10/2014 11:55 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He realizado pruebas con diversos navegadores (Firefox, Chrome, Safari) en distintos sistemas operativos y, en todos los casos, el funcionamiento de la tienda es el correcto.

Es decir, si añado un producto a la tienda se agrega correctamente y lo mismo si añado un segundo producto. Si te es posible, prueba con otro equipo para ver si te funciona. En el caso de que te siga pasando estaría claro que estamos haciendo pasos distintos. Tendrías que detallar si al añadir el primer producto entras en el carro de compra o tratar de buscar algo que provoque el problema.

También le he pedido que hagan pruebas otros empleados de Webempresa y también les funciona todo bien.

ResponderCitar
Respondido : 21/10/2014 12:38 pm
Peichi
 Peichi
Usuario experto

Hola Pablo,

He probado en otro ordenador y me ocurre lo mismo.
Te mando paso a paso lo que he hecho.

Gracias
P.D. Te mando en otro post más pasos.

ResponderCitar
Respondido : 21/10/2014 3:44 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Peichi
 Peichi
Usuario experto

Más...

ResponderCitar
Respondido : 21/10/2014 3:49 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

He probado el sitio
Contenido solo visible a usuarios registrados

He visto que a veces ocurre que el carro no se actualiza, al agregar el primero producto bien, el segundo producto, mal por que no se muestra, luego el tercer producto vuelve a mostrarse, es decir el problema es una actualización del carrito de compra

Has logrado actualizar tu vm?, si no te detecta actualización puedes descargarte vm e instalarlo como si no lo tuveras

Luego podrías probar cambiando temporalmente de template y verificar si te sucede lo mismo, o algo más práctico es que ubicques la carpeta : /templates/TU_PLANTILLA/html/com_virtuemart/ y renombres a por ejemplo : back_com_virtuemart

Si renombrando te funciona entonces es problema de actualización del template

En ambos casos antes de realizar actualizaciones realiza un backup de tu sitio web con Akeeba

Saludos.

ResponderCitar
Respondido : 21/10/2014 5:45 pm

Cursos Gratuitos WordPress

Peichi
 Peichi
Usuario experto

Hola Jhon,

Sí virtuemart está actualizado a la version 2.6.10. No obstante lo he vuelto a actualizar pero el problema es el mismo.
Y he cambiado temporalmente de templete como me dices pero sigue pasando lo mismo.

Voy a desactivar la opción de cupón a ver si me ocurre igual ya que de este problema me he dado cuenta al activarlo aunque hubiera podido ser que antes no lo detectase.

Saludos

ResponderCitar
Respondido : 21/10/2014 6:22 pm
Peichi
 Peichi
Usuario experto

ahhhhhhh....... sigue pasando lo mismo.

ResponderCitar
Respondido : 21/10/2014 6:26 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es extraño lo que comentas, debes tener alguna otra extensión, posiblemente de terceros que te puede ocasionar problemas

Primero:

- Al reinstalar virtuemart tambien lo has hecho con el componente AIO?
- Al cambiar de template asegurate de cambiar con un template que no haga overrides de virtuemart puedes uar un template de los que vienen por defecto con Joomla

Saludos.

ResponderCitar
Respondido : 21/10/2014 7:31 pm
Peichi
 Peichi
Usuario experto

Hola Jhon,

He reinstalado virtuemart. También el componente AIO.
He cambiado de templete y he usado el de GK_boutique. El problema usando esta plantilla es el mismo . Cuando le das a actualizar si te aparecen todos los productos bien.
He comprobado las extensiones que tengo y son las que por defecto vienen con vuestra instalación. EL único componente que he actualizado es la de Ackeba.

Saludos

ResponderCitar
Respondido : 22/10/2014 12:55 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Página 2 / 3