No muestra imagen en blog de leotheme  

 
Raul E. Londoño
 Raul E. Londoño
Estimable Member

Hola.

Me gustaria saber por qué no se muestran las imagenes en los articulos del Blog: no muestra ni la miniatura ni la imagen cuando se abre el articulo.

La imagen si queda cuando la ingreso en la elaboracion del articulo, incluso puedo ver los archivos que se generan en la respectiva carpeta.

Envio capturas.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 07/04/2015 10:07 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Debe ser por el nombre de la imagen, pruecura que las imagenes que subas el nombre de arhivo no tenga espacios ni caracteres especiales, en el caso enviado tiene un espacio

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/04/2015 10:46 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Raul E. Londoño
 Raul E. Londoño
Estimable Member

Hola.
Ya he hecho pruebas de todas las formas posibles y sigue el mismo problema.

Que más podría hacer?.

Gracias.

ResponderCitar
Respondido : 08/04/2015 3:33 am
Raul E. Londoño
 Raul E. Londoño
Estimable Member

Además, cuando subo la imagen, ésta sube con un tamaño más grande a la que he subido (supongo que se hace una mejora de la imagen), incluyendo las miniaturas (tambien se forman con un tamaño muy grande.

Esto haría que consumiera mucho espacio en el servidor. Qué podría hacer?.

Gracias.

ResponderCitar
Respondido : 08/04/2015 3:56 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si se encuentra la imagen en la ruta: Contenido solo visible a usuarios registrados, me marca un error al buscar la imagen.

Al subir una imagen con tamaño excesivo relanteriza tu web y también ocupa espacio. Puedes ejecutar el optimizador de imágenes desde tu área de clientes para corregir este problema.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/04/2015 4:27 am
Raul E. Londoño
 Raul E. Londoño
Estimable Member

Hola.

Si el archivo de la imagen si está en ese directorio, así como los otros arhivos de las imagenes de los demas articulos del blog.

Sobre el tamaño de la imagen: Cuando subo una imagen pequeña el mismo codigo me la convierte a un tamaño más grande. Mas adelante te pregunté cómo haría para que esto no pase, ya que me ocupa mucho espacio.

Esta plantila Leotheme tambien en modulos/leoblog/ carga la imagen de cada articulo y con un tamaño más grande. Lo que hace que exista la imagen dos veces. Será que pòr codigo se cuadra esto?.

Me gustaria utilizar el blog de esta plantilla, ya que soporta multitienda y se adapta a mis necesidades; pero buscando solución a estos problemas. Gracias Johnny.

ResponderCitar
Respondido : 08/04/2015 5:02 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Raul E. Londoño
 Raul E. Londoño
Estimable Member

Hola.

Parece que el problema es por el tipo de permiso de la carpeta que contiene las imagenes, el cual debería ser 755. Me puedes decir cómo cambiar este tipo de permiso?. Gracias.

ResponderCitar
Respondido : 08/04/2015 6:21 am
Raul E. Londoño
 Raul E. Londoño
Estimable Member

Hola. Ya cambie el tipo de permiso a 755 y ahora me muestra las imagenes miniatura, pero aun no me muestra la imagen cuando miro el articulo.

Como hago para que cuando se introduzca una imagen quede con el permiso correcto?. Hay que modificar el codigo?.

ResponderCitar
Respondido : 08/04/2015 6:52 am

Cursos Gratuitos WordPress

Lorena
 Lorena
Miembro Moderator

Hola,

Si realizas una revisión automática con nuestro asistente Stephan, en esta revisión se comprueba que los archivos y carpetas tengan asignados los permisos adecuados (archivos con 644 y carpetas con 755) y en caso contrario se modifica automáticamente.

Respecto a los tamaños de las miniaturas que se generan, los puedes modificar en Preferencias -> Imágenes aunque normalmente con los valores por defecto ya está optimizado para la plantilla.

Un saludo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/04/2015 11:53 am
Raul E. Londoño
 Raul E. Londoño
Estimable Member

Hola.

Si estoy de acuerdo que el asistente Setphan me cuadra los permisos. Pero aun no me resuelves la pregunta. Vuelvo y la formulo:

Tengo un blog con una plantilla LeoTheme, que trae un blog incorporado. Aqui cuando realizo un articulo y coloco la respectiva imagen, en los archivos que se generan (las miniaturas y demas), en los directorios NO hay permisos 755 (que es la razon por la que no se muestran las imagenes).

1. ?Entonces cómo hago para que automaticamente al ingresar una imagen automaticamente queden con sus directorios queden con permisos 755?.
2. Al abrir el articulo del blog, tampoco me muestra la imagen correspondiente?. Qué puedo hacer?.

Gracias.

ResponderCitar
Respondido : 08/04/2015 9:30 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Que permisos se ponen en la imagen cuando terminas de subir?

Es muy extraño que no tome los permisos correctos, es posible que desde tu ordenador los archivos tengan permisos incorrectos, tendrías que revisar probando desde otro ordenador con otras imágenes.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/04/2015 10:33 pm
Raul E. Londoño
 Raul E. Londoño
Estimable Member

Hola:

Me genera permiso 700. Y por qué mi ordenador tiene algo que ver?. Mas bien creo que es el codigo del blog el que cambio estos permisos.

ResponderCitar
Respondido : 09/04/2015 12:29 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Raul E. Londoño
 Raul E. Londoño
Estimable Member

Hola.

Doy por cerrado este tema, ya que parece que es problema en el codigo de la plantilla. Opté por trabajar con otro modulo. Muchas gracias y felicitaciones por su excelente trabajo.

ResponderCitar
Respondido : 09/04/2015 2:01 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

El blog que tienes es del propio tema, puedes probar a cambiarlo: https://www.webempresa.com/blog/item/1694-tus-clientes-deben-estar-al-dia-sobre-tus-productos-inserta-un-blog-para-tu-prestashop.html

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/04/2015 2:05 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro