No veo imágenes en la biblioteca de medios ni puedo buscar plugins desde el wp-admin  

 
Jose Ramón
 Jose Ramón
Nuevo usuario

Buenas tardes

Tengo los mismos problemas que se trataron en el tema del foro:

https://www.webempresa.com/foro/administracion-wordpress/biblioteca-de-medios-y-otras-funciones-inaccesibles/paged/4

He hecho todas las pruebas que he encontrado (desactivar plugins, etc.) y sigue sin funcionar.

El usuario del tema que indico dice que el problema estaba en el archivo .htaccess de su directorio raiz, pero no dice la solución.

¿Podrían decirme cual fue?

Gracias

Citar
Respondido : 07/10/2020 4:24 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola José Ramón,

Puedes indicarnos cual es la URL del sitio web donde no logras ver la librería de medios? de manera general usualmente este problema esta relacionado con la ruta Upload Url Path, comprueba este asigna de forma correcta en tu sitio web.

Una forma correcta de configuración es /home/cuenta/public_html/directorio_sitio_web/wp-content/uploads/

Revisa el siguiente articulo donde mencionan como puedes verificar y corregir esta configuración -> https://www.webempresa.com/blog/corrige-la-ruta-upload-path-en-wordpress.html

Nos comentas como ha ido todo

Un Saludo

 

ResponderCitar
Respondido : 07/10/2020 4:47 pm

Cursos Gratuitos WordPress

Jose Ramón
 Jose Ramón
Nuevo usuario

@karen

Gracias por tu pronta respuesta.

La URL es: https://asesordecompras.es/

Y he verificado la carpeta y es correcta.

Como le pasaba al otro usuario, en modo LISTA si que veo los archivos, cuando no los veo es en modo GRID.

ResponderCitar
Respondido : 07/10/2020 4:54 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola José Ramón,

Puedes enviarnos una captura como ves la librería de medios en tu sitio web? de igual forma si es posible envíanos una imagen de la sección de  Upload Url Path de tu base de datos, esta opción se encuentra en phpmyadmin.

Ingresa a tu base de datos y localiza la tabla wp-options (el prefijo wp puede cambiar de acuerdo a tu base de datos) y sobre la segunda pagina ubica la linea que tienes la configuración

Screenshot

De igual forma comprueba generar un nuevo archivo htaccess, para ello puedes ingresar en tu cPanel -> Administrador de archivos -> Public_htm, una vez dentro de el ingresa a la carpeta donde tienes los archivos de tu web.

Dentro de este ubicar el archivo .htaccess  y renombralo por ejemplo a htaccess_old

Screenshot

Screenshot

Luego de ello ingresa a tu sitio web al apartado Ajustes -> Enlaces permanentes

Screenshot

Si modificar nada pulsa en la opcion de guardar cambios

Screenshot

Comprueba si al hacer esto logras ver la biblioteca de medios sin problemas

Un Saludo

ResponderCitar
Respondido : 07/10/2020 5:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose Ramón
 Jose Ramón
Nuevo usuario

@karen

Al volver a crear el archivo .htaccess  ha funcionado.

He localizado las líneas del archivo original que lo provocaban y son estas:

## Charset UTF-8 (Utilizar solo si es necesario)
<IfModule mod_headers.c>
Header set Content-Type "text/html; charset=UTF-8"
</IfModule>

 

No tengo claro para que están, pero si las quito, parece que funciona.

Gracias, seguiré probando para ver si me falla algo más.

 

ResponderCitar
Respondido : 07/10/2020 5:58 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Esa línea de código india al navegador que el contenido que esta cargando es text/html, sin embargo WordPress ya debería enviarte esto, por lo que posiblemente cause algún tipo de problema tenerlo doble o si se va a cargar otro tipo de datos, como el caso de imágenes.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/10/2020 6:20 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro