No puedo configurar multisite al inicio  

Página 1 / 2
 
César
 César
Usuario experto

Buenas noches:

Quiero crear un sitio multi-idioma en mi web, Contenido solo visible a usuarios registrados

Citar
Respondido : 16/01/2019 9:41 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Si tienes los códigos debería de funcionarte.

Puedes probar a eliminar totalmente el WordPress y procede a instalarlo de forma manual:
https://www.webempresa.com/blog/instalar-wordpress-manualmente-como-lo-hago.html

Verifica si de esta forma te funciona.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/01/2019 2:51 am

wpdoctor-revisa-la-salud-de-tu-wordpress

César
 César
Usuario experto

Gracias por la respuesta, Johnny... Puesto que nunca lo he hecho y no quiero perder lo que hasta el momento he venido trabajando, me gustaría mostrarte el procedimiento que creo debo seguir... Corrígeme si me equivoco en algo:

1) Hacer copia de seguridad de mi actual sitio con All-In-One WP Migration, ya que es el plugin que por defecto venía en la instalación del paquete de Wordpress de Webempresa, y descargarlo en mi ordenador

2) Borrar todo el sitio y la base de datos correspondiente a ese sitio

3) Subir por FTP el fichero de Wordpress manual y crear la base de datos manualmente

4) Crear multisite "a pelo" y los distintos sitios en subcarpetas (español, inglés, alemán...)

5) En uno de los sitios creados (vidaloe español) importar con All-In-One WP Migration el sitio web

¿Es correcto?

ResponderCitar
Respondido : 17/01/2019 9:29 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Cesar.

El aviso indica que ya tenías una red de sitios creada anteriormente ¿ Puede ser ?
Si tenias un multisitio creado primero tienes que eliminar el anterior por completo.

En este hilo del foro tienes los pasos para eliminar la anterior RED

-> https://www.webempresa.com/foro/24-Administraci%C3%B3n-WordPress/153708-C%C3%B3mo-eliminar-configuraci%C3%B3n-Multisite-en-instalaci%C3%B3n-Wordpress.html

Aparte de lo que se indica en esa entrada tienes que eliminar de la base de datos la anterior red.
.- Accede a tu cuenta de cPanel -> phpMyAdmin
.- selecciona la base de datos que utiliza la instalación
-> https://www.webempresa.com/blog/datos-de-conexion-de-la-base-de-datos-donde-encontrarlos.html

.- Realiza una copia de la base de datos seleccionado la opción de exportar
.- elimina las tablas:

wp_blogs
wp_blog_versions
wp_registration_log
wp_signups
wp_site
wp_sitemeta

De normal cuando se crea una red de sitios WordPress crear una carpeta blogs.dir dentro del directorio wp-content, que es donde se guardan los archivos subidos por cada sitio de la instalación. revisa si tienes la carpeta y la borras.

Una vez realizados los pasos anterior crea de nuevo la red de sitios siguiendo los pasos de esta entrada del blog

-> https://www.webempresa.com/blog/red-de-sitios-wordpress-en-varios-idiomas-sin-plugins.html

Espero que esta información te sirva para lo que buscas, de no ser así por favor indícalo para que podamos seguir ayudándote.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 17/01/2019 11:05 am

Cursos Gratuitos WordPress

César
 César
Usuario experto

Estimado Pepe:

Me sigue saliendo el mismo mensaje... Te cuento...

1) He seguido a rajatabla los pasos tal y como se indica en el hilo del foro siguiente:

https://www.webempresa.com/foro/24-Administraci%C3%B3n-WordPress/153708-C%C3%B3mo-eliminar-configuraci%C3%B3n-Multisite-en-instalaci%C3%B3n-Wordpress.html

2) Después, he accedido a PhpMyAdmin y he eliminado todas esas tablas que me indicabas:

wp_blogs
wp_blog_versions
wp_registration_log
wp_signups
wp_site
wp_sitemeta

3) He comprobado si había creada una carpeta llamada "blogs.dir" dentro de public_html/vidaloe.net/wp-content y no había ninguna creada.

4) He intentado configurar de nuevo el sitio web siguiendo los pasos que marcáis en este post
https://www.webempresa.com/blog/red-de-sitios-wordpress-en-varios-idiomas-sin-plugins.html

Es decir, crear carpetas "en,de,fr" dentro de public_html/vidaloe.net/ , subir primera línea de código a wp-config.php, desactivar plugins, acceder a Herramientas >Gestión de la red...

Y una vez que cumplimento el nombre de la red y el correo, me devuelve el mismo mensaje de error que te mostraba en la anterior captura de pantalla... Idéntico...

¿Qué consideras que debo hacer? Muchas gracias anticipadamente

ResponderCitar
Respondido : 17/01/2019 12:32 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola César

¿ El aviso es de la base de datos ?
Sigue con los paso siguiente de añadir el código en el archivo config y en el html

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 17/01/2019 1:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

César
 César
Usuario experto

Hola de nuevo, Pepe... Lo he seguido tal cual... Pero nada

1) Borrar las líneas de código de wp-config.php

2) Re-emplazar el contenido del fichero .htaccess con el contenido original

3) Borrar las tablas que indicas en phpMyAdmin

4) Comprobar si en wp-content hay algún directorio denominado blogs.dir... No hay ninguno

5) He creado tres carpetas vacías dentro de public_html/vidaloe-net que son "en", "de", "it" y "fr" (correspondientes a la instalación en 4 idiomas adicionales del contenido de la web).

6) He añadido nuevamente al fichero wp-config.php la primera línea de código, teniendo como resultado después esta pantalla:

7) Tal y como indica, he añadido en wp-config el contenido que dice y en .htaccess he re-emplazado el código que había por este nuevo que me facilita

8) El resultado sigue siendo el mismo

Disculpas anticipadas,

César

ResponderCitar
Respondido : 17/01/2019 2:55 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola César.

ok, pero eso es un aviso que no tiene por que afectar.
¿ Si pulsas en Escritorio te aparece la opción " mis sitios "

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 17/01/2019 4:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

César
 César
Usuario experto

Lo siento... No aparece... Ya lo había verificado, pero nada...

ResponderCitar
Respondido : 17/01/2019 6:04 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Es como si hubiera quedado alguna configuración anterior, posiblemente en tu archivo wp-config tienes algo relacionado, de ser posible restaurar una copia de este archivo antes de haber hecho la configuración de multisites.

Lo otro es que tengas algún plugin que te este afectando, prueba ir desactivando plugins que algunos tienen problemas con multisites

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/01/2019 6:36 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

César
 César
Usuario experto

Buenas noches, Jhon:

Todos los plugins están desactivados... Y en cuanto al fichero , pues no le encuentro nada raro... El contenido de wp-config.php es este (Los datos de las variables que conectan la BD, nombre de usuario y contraseña los he cambiado por "xxxxxxx" y las líneas de código que me pide WordPress Multisite las acabo de eliminar)... ¿Se te ocurre otra razón?

<?php
/**
* Configuración básica de WordPress.
*
* Este archivo contiene las siguientes configuraciones: ajustes de MySQL, prefijo de tablas,
* claves secretas, idioma de WordPress y ABSPATH. Para obtener más información,
* visita la página del Codex{@link http://codex.wordpress.org/Editing_wp-config.php Editing
* wp-config.php} . Los ajustes de MySQL te los proporcionará tu proveedor de alojamiento web.
*
* This file is used by the wp-config.php creation script during the
* installation. You don't have to use the web site, you can just copy this file
* to "wp-config.php" and fill in the values.
*
* @package WordPress
*/

// ** Ajustes de MySQL. Solicita estos datos a tu proveedor de alojamiento web. ** //
/** El nombre de tu base de datos de WordPress */
define('DB_NAME', 'xxxxxxxxxxx');

/** Tu nombre de usuario de MySQL */
define('DB_USER', 'xxxxxxxxx');

/** Tu contraseña de MySQL */
define('DB_PASSWORD', 'xxxxxxxxxxx');

/** Host de MySQL (es muy probable que no necesites cambiarlo) */
define('DB_HOST', 'localhost');

/** Codificación de caracteres para la base de datos. */
define('DB_CHARSET', 'utf8');

/** Cotejamiento de la base de datos. No lo modifiques si tienes dudas. */
define('DB_COLLATE', '');

/**#@+
* Claves únicas de autentificación.
*
* Define cada clave secreta con una frase aleatoria distinta.
* Puedes generarlas usando el {@link https://api.wordpress.org/secret-key/1.1/salt/ servicio de claves secretas de WordPress}
* Puedes cambiar las claves en cualquier momento para invalidar todas las cookies existentes. Esto forzará a todos los usuarios a volver a hacer login.
*
* @since 2.6.0
*/
define('AUTH_KEY', 'pon aquí tu frase aleatoria'); // Cambia esto por tu frase aleatoria.
define('SECURE_AUTH_KEY', 'pon aquí tu frase aleatoria'); // Cambia esto por tu frase aleatoria.
define('LOGGED_IN_KEY', 'pon aquí tu frase aleatoria'); // Cambia esto por tu frase aleatoria.
define('NONCE_KEY', 'pon aquí tu frase aleatoria'); // Cambia esto por tu frase aleatoria.
define('AUTH_SALT', 'pon aquí tu frase aleatoria'); // Cambia esto por tu frase aleatoria.
define('SECURE_AUTH_SALT', 'pon aquí tu frase aleatoria'); // Cambia esto por tu frase aleatoria.
define('LOGGED_IN_SALT', 'pon aquí tu frase aleatoria'); // Cambia esto por tu frase aleatoria.
define('NONCE_SALT', 'pon aquí tu frase aleatoria'); // Cambia esto por tu frase aleatoria.

/**#@-*/

/**
* Prefijo de la base de datos de WordPress.
*
* Cambia el prefijo si deseas instalar multiples blogs en una sola base de datos.
* Emplea solo números, letras y guión bajo.
*/
$table_prefix = 'wp_';

/**
* Para desarrolladores: modo debug de WordPress.
*
* Cambia esto a true para activar la muestra de avisos durante el desarrollo.
* Se recomienda encarecidamente a los desarrolladores de temas y plugins que usen WP_DEBUG
* en sus entornos de desarrollo.
*/
define('WP_DEBUG', false);
define( 'WPLANG', 'es_ES' );
define( 'DISABLE_WP_CRON', true );

/* ¡Eso es todo, deja de editar! Feliz blogging */

/** WordPress absolute path to the Wordpress directory. */
if ( !defined('ABSPATH') )
define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

ResponderCitar
Respondido : 17/01/2019 10:13 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola César.

Puedes crear el multiidioma con un plugin sin tener que crear multisitio ni carpetas para los idiomas.
Por ejemplo uno de los más utilizados es Polylang.

-> https://wordpress.org/plugins/polylang/

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 18/01/2019 12:20 pm

Cursos Gratuitos WordPress

César
 César
Usuario experto

Hola de nuevo:

Lamento ser pesado, Pepe... Tras leer tu mensaje instalé el plugin y he estado trabajando en la web... Veo que cuando lo tengo activado me da problemas con Elementor... Te lo muestro:

Con el plugin desactivado puedo maquetar la web sin problemas

Y con el plugin activado (y sin haber trasteado mucho), me da de entrada el fallo de que si quiero añadir un widget que muestre productos de woocoomerce, éstos ni si quiera se muestran

He estado mirando otras alternativas como WPML, y veo que es un plugin que ralentiza mucho la carga de la web...

Lo que dije antes... No quiero ser pesado pero ¿se os ocurre alguna solución?

Muchas gracias

ResponderCitar
Respondido : 18/01/2019 10:25 pm
César
 César
Usuario experto

Buenos días de nuevo... Viendo que no me sirve ninguna de las opciones anteriores he probado a instalar el paquete de webempresa en una subcarpeta del directorio principal... Y lo de siempre: Con dos clicks ya tengo el sitio creado.

Y siguiendo a rajatabla el procedimiento que describís en https://www.webempresa.com/blog/red-de-sitios-wordpress-en-varios-idiomas-sin-plugins.html

Colocar la primera línea de código en wp-config.php

define( 'WP_ALLOW_MULTISITE', true );

Y seguir los siguientes pasos ta cual... Añadir el resto del fragmento de código en wp-config.php y después, al añadirlo a .htaccess ya directamente me devuelve un error 500

Me imagino que será porque esté montado sobre https ¿puede ser?

De cualquier modo, y viendo que todas las opciones anteriores no me sirven para ponerlo en multi-idioma, creo que lo mejor es esto... Lo monto sobre la carpeta https://vidaloe.net/web/ y vuelco los datos manualmente de la principal.

ResponderCitar
Respondido : 19/01/2019 11:43 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

César
 César
Usuario experto

Permitidme añadir algo más... Ahora lo he instalado manualmente... Wordpress 4.9.9 descargada manualmente, configurada base de datos manualmente y siguiendo exactamente los mismos pasos...

El resultado es idéntico a lo que indicaba al principio de este post...

Y bueno... Soy torpe, pero aquí estoy seguro de que lo he hecho tal y como se indica en Wordpress y en el post de webempresa

https://www.webempresa.com/blog/red-de-sitios-wordpress-en-varios-idiomas-sin-plugins.html

Lamento los inconvenientes, pero es que no puedo continuar mi trabajo...

ResponderCitar
Respondido : 19/01/2019 12:04 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro