Avisos
Vaciar todo

Problemas para trabajar con extensiones sitemap  

 
Rosario
 Rosario
Noble Member

Estoy instalando extensiones para crear un html sitemap pero me dan continuamente error 500 o error 0, he quitado la limitación de acceso del archivo robots temporalmente, pero aún así no me funcionan. ¿Sabéis que puede estar pasando?
He instalado y desinstalado OsMap, ahora está Xmap, sitemapgenerator, sitemapcache, aimysitemap...

¿sabéis algún sitio on line que los genere gratis?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 18/12/2017 9:16 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Pues se tendría que revisar el motivo si te muestra un error 500. Te recomendaría que lo instales nuevamente el plugin Osmap: https://www.webempresa.com/blog/genera-tu-sitemap-en-joomla-3-4-con-osmap.html

Si te muestra en algún momento en un error tendrías que revisar el fichero error_log para buscar los últimos registros: https://www.webempresa.com/blog/que-es-un-error-500-y-como-localizarlo-en-nuestra-web.html ,finalmente adjuntarlos para poder verificar el motivo.

ResponderCitar
Respondido : 19/12/2017 2:05 am

Cursos Gratuitos WordPress

Rosario
 Rosario
Noble Member

🙁 He hecho un rastreo con el busca en el cpanel y en toda la web no sale ninguna línea de error en ningún archivo erro_log localizado de modo que no sé que puedo hacer.

ResponderCitar
Respondido : 19/12/2017 12:39 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes más de una extensión que te genera sitemaps?, es posible que haya conflicto entre ellas, desinstala todas y sólo quédate con osmap por ejemplo y revisa nuevamente.

Saludos.

ResponderCitar
Respondido : 19/12/2017 4:14 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Rosario
 Rosario
Noble Member

ya lo he hecho, pero no funciona

ResponderCitar
Respondido : 19/12/2017 6:12 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tal vez tenga que ver con la versión de PHP, has probado cambiando la versión de PHP en tu sitio?
Si te da pantalla en blanco debería generarse algún error en el archivo administrator/error_log

Saludos.

ResponderCitar
Respondido : 19/12/2017 8:40 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rosario
 Rosario
Noble Member

La versión php que estoy usando es bastante reciente, no recuerdo exactamente pero php.7.
La verdad es que no me genera una pantalla en blanco, me da un error 500, es muy raro que no me funcione ninguno, al principio descubrí que tenía el acceso de datos bloqueado con el robot, pero ahora no se si desconectar todo lo ajeno a joomla y probar otra vez, si no encuentro otra solución más rápida lo tendré que hacer.

ResponderCitar
Respondido : 20/12/2017 1:42 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si otra extensión no te da problemas: https://extensions.joomla.org/category/structure-a-navigation/site-map/ ya que OsMap no parece que te da resultados positivos.

ResponderCitar
Respondido : 20/12/2017 1:49 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Rosario
 Rosario
Noble Member

He instalado y desinstalado OsMap, ahora está Xmap, sitemapgenerator, sitemapcache, aimysitemap...yo creo que no se trata de probar otra extensión es que debe de haber surgido alguna incompatibilidad, pero gracias igualmente por el consejo, mañana si tengo tiempo probaré alguna nueva, de momento estoy tratando de generar un mapa on line en https://xmlsitemapgenerator.org/sitemap-generator.aspx, si conoces alguna dirección de este tipo que sea buena puedo probar varios mapas para comparar la calidad.

ResponderCitar
Respondido : 20/12/2017 2:05 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

No conozco alguna herramienta como la que adjuntas, si dicha herramienta permite generar el sitemap de forma dinámica te serviría caso contrario no creo que te ayude en mucho.

ResponderCitar
Respondido : 20/12/2017 2:09 am

Cursos Gratuitos WordPress

Rosario
 Rosario
Noble Member

paciencia, mañana será otro día, me aseguraré de haber desinstalado todas las anteriores opciones antes de instalar una nueva

ResponderCitar
Respondido : 20/12/2017 2:37 am
Rosario
 Rosario
Noble Member

Jhon Marreros Guzmán tiene razón, el problema es de php, he actualizado a 7.1 y ahora parece que funciona, aunque d euna forma extraña porque le pido un mapa de una subcarpeta y en xml y html me genera un mapa de la web principal en la raíz. La voy a trabajar un poco más o la cambiaré, supongo que pretenden que la gente se la compre. Muchas gracias

ResponderCitar
Respondido : 20/12/2017 1:06 pm

wpdoctor-revisa-la-salud-de-tu-wordpress