Avisos
Vaciar todo

Actualización VM 2.022  

Página 2 / 4
 
ISIDRO
 ISIDRO
Estimable Member

Hola:
He iniciado la actualización de VM 2.0.14 a 2.0.22 con la fatalidad de interrumpir el proceso casi al principio del mismo. Grave error.
Ahora no me deja actualizar, aparece este mensaje: "Invalid Token, in store config"
En el frontend, pinchando en cualquiera de los productos de cualquier categoría o de los destacados, aparece el siguiente mensaje:
"Not Found

The requested URL /tienda/nutricion-dietetica-y-alimentacion/nutraceuticos/aquilea-omega-3-90-capsulasfarmaviva.es was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

En VM, Configuración se puede leer justo debajo de Configuración ésto:

"Atención, el Safe Path está vacio, por razones de seguridad es muy importante para crear una carpeta en una ruta no accesible por una dirección URL, crea también una carpeta de facturas en ella para almacenar seguros sus datos sensibles. Nuestra ruta es sugerido para su sistema es /home2/product4/vmfiles "

y todo el contenido se muestra en inglés.
Unos minutos antes había realizado una copia con Akkeba Backup
www.productosmil.com
Un saludo

Citar
Respondido : 21/08/2013 8:30 am
ISIDRO
 ISIDRO
Estimable Member

Hola: En este momento he lanzado el script de kicksatar y en el ANGIE en configuración recomendad y real, ea esta segunda me aparece que comillas mágicas está en ON. Qué debo hacer?
Un saludo.

ResponderCitar
Respondido : 24/08/2013 7:04 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

ISIDRO
 ISIDRO
Estimable Member

Hola:
He hecho punto por punto todo lo que me indicaban los videos tutoriales: desde cPanel, borrar todos los archivos y lpublic_html, borrar o eliminar las tablas de BD, cargar el Backup y el archivo Kicstart, descomprinirlo y borrar el archivo .zip tres veces y siempre ocurre lo mismo: en cualquier producto de cualquier página del frontend de www.productosmil.com siempre da erro y no se ven los detalles del producto (si la imagen). Sólo he encontrado que en el ANGIE me decía que las comillas Mágicas etaban activadas. Lo he hecho con el usuario y contraseña anterior de la BD y TAMBIÉN con usuario y contraseña de BD nuevos (con todos los privilegios). Siempre ha ocurrido lo mismo.
Se me ocurre pensar que quizá el Backup o el fichero Kickstart so están en buen estado. Puede ocurrir esto?
En cualquier caso qué se puede hacer para salvar las cientos de horas que llevo invertidas en el Joomla 2.5 VM 2 PACK CERAMIC?
Un saludo.

ResponderCitar
Respondido : 24/08/2013 10:19 am
ISIDRO
 ISIDRO
Estimable Member

Hola:
Deciros que en el cPanel tengo un Backup de hace un mes. Podría utilizar esta copia?
Cómo se haría?
Un saludo.

ResponderCitar
Respondido : 24/08/2013 10:27 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Isidro

Veo que los productos generan un url un poco extraña , con ".es" , al final de la url.

Has recuperado en una nueva base de datos?, por que usualmente se crean nombres diferentes cuando hay productos repetidos.

Verifica los Alias de las categorías y de tus productos ya que estos deben ser correctos, puedes eliminarlos y se crearan nuevamente al guardar

Si aún continuas con problemas, si que puedes usar una copia de tu cpanel, debes tener una opción de CPRemote, si tienes dudas de cómo utilizar esta herramienta te sugiero lo consultes a través de tickets de soporte.

Saludos.

ResponderCitar
Respondido : 24/08/2013 2:18 pm
ISIDRO
 ISIDRO
Estimable Member

Hola:
He revisado categorías y productos ý no encuentro nada extraño.
Creo que el problema está en que el backup no se abre. Es decir, cargado el fichero Kickstart, extraigo y elimino el fichero .zip, sin problemas, pero cuando intento abrir el fichero Backup para ver el contenido que he cargado, este fichero bakup no se abre. Creo que puede ser ese el problema.
Un saludo.

ResponderCitar
Respondido : 25/08/2013 8:30 am

wpdoctor-revisa-la-salud-de-tu-wordpress

ISIDRO
 ISIDRO
Estimable Member

Hola:
Es evidente que al interrumpierse la actualización de VM algunos ficheros están dañados. Cómo puedo saber cuáles son?
Un saluso.

ResponderCitar
Respondido : 25/08/2013 12:54 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Isidro,

Si tienes una copia de seguridad puedes probar a restaurarla, también te recomiendo utilizar cPremote en tu cuenta de cPanel, lo del fichero Kickstart.php que puede estar corrupto lo dudo si haz descargado una versión estable, es mas probable que la copia de seguridad este corrupta mas que el fichero. Seria importante que nos indiques en que directorio estas ejecutando el fichero, por ultimo veo la web en:

Contenido solo visible a usuarios registrados

Pero al ingresar en un producto veo que no funciona, deshabilita las urls amigables y revisa si se visualizan.

Saludos.

ResponderCitar
Respondido : 25/08/2013 3:00 pm

Cursos Gratuitos WordPress

ISIDRO
 ISIDRO
Estimable Member

Hola Johnny:
He desactivado las url AMIGABLES Y AHOR FUNCIONA. FUNCIONA.
Por qué es esto así. Deben estar siempre desactivadas? Puedo actualizar ahora VMSIN PROBLEMAS
Un saludo.

ResponderCitar
Respondido : 25/08/2013 5:03 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Isidro,

Prueba nuevamente activarlas, te deberían funcionar sin problemas. Verifica si el fichero error_log te brinda alguna referencia.

Qué es un error 500 y como localizarlo en nuestra web
https://www.webempresa.com/blog/que-es-un-error-500-y-como-localizarlo-en-nuestra-web.html

Saludos.

ResponderCitar
Respondido : 25/08/2013 5:10 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

ISIDRO
 ISIDRO
Estimable Member

Hola:
Al habilitar las url amigables vuelve a producirse el mismo error. Además he visto que la configuración de VM CON LAS URL HABILITADAAS APARECÍAN EN INGLÉS
sALUDOS

ResponderCitar
Respondido : 25/08/2013 5:27 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Isidro,

Antes tenias dicho problema?. Con la copia de seguridad no tenias este problema?, adjuntanos una captura de la configuración de seo tanto de tu Joomla como de tu Virtuemart, haz realizado algún cambio en el fichero .htaccess?

Saludos.

ResponderCitar
Respondido : 25/08/2013 5:36 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

ISIDRO
 ISIDRO
Estimable Member

Hola:
Y si con las url amigables dashabilitadas, realizo la actualización de VM A VM 2.022b ? Recordaros que fue esa actualización interrumpida el origen del problema.
Un saludo.

ResponderCitar
Respondido : 25/08/2013 5:49 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola ISIDRO,

Es evidente, que independientemente del problema que comentas que tienes con las URLs amigables, deberás actualizar, al menos si quieres tener "estable" VirtueMart ya que todas las versiones entre la 2.0.8 y la 2.0.22a SON VULNERABLES por inyección SQL.

-

He revisado la lista de cambios de esta versión y no veo referencias a urls amigables, pero tampoco encuentro en el Foro oficial de VirtueMart referencias a problemas con esto tras actualizar.

La decisión es tuya. B)

Saludos

ResponderCitar
Respondido : 25/08/2013 7:36 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

ISIDRO
 ISIDRO
Estimable Member

Hola:
Si, he bajado de vuestro asistente de webempresa un archivo .htaccess y lo subí al administrador de archivos de cpanel
Un saludo.

ResponderCitar
Respondido : 26/08/2013 11:16 am
ISIDRO
 ISIDRO
Estimable Member

tE ENVÍO UN NUEVA CAPURA DE PANTELLA

ResponderCitar
Respondido : 26/08/2013 11:29 am

Cursos Gratuitos WordPress

Página 2 / 4