Problema con multisite y plantilla Helena pack tienda wordpress  

 
Angie
 Angie

Hola,
He creado una multisite en una web en pruebas. En la web original (raíz) utilicé la plantilla Helena, que es la que quiero que utilice por defecto toda la red. Así la he configurado. De hecho, es la que está activada en las webs, sin embargo, no es la que se muestra en la visualización de las notas. Coge una de wordpress.

Además, compruebo que no llevan el contenido. Cuando creé la multisite pensaba que las webs eran copias del original y lo que tendría que hacer es cambiar los textos, pero parece que las tengo que adaptar una por una. ¿Eso es así o me he equivocado en algún paso?
Quiero que todas las webs de la red multisite utilicen plantilla helena, la instalé pero cogen una de wordpress por defecto. ¿Tengo que diseñarlas una por una de cero? pensaba que cogían la original por defecto y lo que habría que traducir son los textos.

También he tenido que deshabilitar el plugin rocktheme que lleva por defecto la plantilla Helena porque daba problemas con la multisite. Cuál podría utilizar?

Nota: la url que adjunto es la versión alemana, si eliminas (biogranatapfel) de la URL verás la orginal (.com). Digamos que es la web que busco replicar en los distintos idiomas.
Gracias,
Un saludo

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 13/08/2018 11:19 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Angie.

¿Eso es así o me he equivocado en algún paso?
Cuando creas el multisite le indicas que plantilla quieres que utilice cada dominio desde las opciones administrador de red -> temas. Puedes hacer que un tema esté a disposición de otros sitios haciendo click en activar para la red:

Revisa lo siguiente:

-> https://www.webempresa.com/blog/red-de-sitios-wordpress-multisite.html

pensaba que cogían la original por defecto y lo que habría que traducir son los textos.
No, si instas el pack directamente si que tienes las mismas opciones pero si instalas solo la plantilla tienes que configurar sus opciones.

También he tenido que deshabilitar el plugin rocktheme
¿ Que es lo que desactivaste, El framework de gantry, la galería ( RokSprocket )?, todos esos plugins forman parte de la plantilla sobre todo el framework de gantry que es que tiene toda la estructura de la plantilla.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 13/08/2018 12:06 pm

Cursos Gratuitos WordPress

Angie
 Angie

Hola Pepe,

El problema con la plantilla Helena es que es esa la que está activada para la red (como podrás ver en adjunto) pero no se visualiza así. Salen con la twenty, excepto la "raíz" http://agrofunc-cp5023.wordpresstemporal.com/clon/. El resto recoge la twenty: http://agrofunc-cp5023.wordpresstemporal.com/clon/organicpomegranates/ (adjunto 2"red")

"si instalas el pack directamente si que tienes las mismas opciones pero si instalas solo la plantilla tienes que configurar sus opciones"
Si vuelvo a crear una multisite ¿podría hacerlo como indicas? Es decir, instalar el pack directamente ahí. Aunque supongo que tendría que crear desde cero la web raíz (la de español), no serviría la que tengo ahora. Me explico. Actualmente tengo publicada una web "granadasecologicas.com". Para gestionar el tema de las webs en idiomas he creado esta multisite en pruebas. Pero si tengo que rehacer todas las webs desde cero, incluso esa con la que ya estoy trabajando, me planteo si interesa más hacerlas en carpetas distintas y olvidarme de la multisite. Sobre todo, después del siguiente punto.

Sobre Plugin RokSprocket:
Sí perdona, me refería a ese plugin. Tuve problemas para acceder a la red multisite, envié un ticket y me dijeron que "El problema veo que estaba siendo causado por el plugin rocksprocket por lo que he procedido a deshabilitarlo en tu sitio renombrando el directorio a: public_html/clon/wp-content/plugins/wp_roksprocket-old"
Qué otro plugin podría utilizar? o me olvido de multisite?

ResponderCitar
Respondido : 13/08/2018 12:55 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Angie.

Si vuelvo a crear una multisite ¿podría hacerlo como indicas?
Si, instalas el pack y creas el multisite, para los demás sitios accedes al adminsitrador de redes, seleccionas el dominio y activas esa plantilla para la red.

Qué otro plugin podría utilizar?
El plugin RokSprocket es el que se encarga de mostrar el slider y algunas secciones de la web, es un plugin importante ¿ Que problema es el que tenias por si podemos solucionarlo ?

Para el tema de las galerías y slider puedes utilizar alternativas :
-> https://www.webempresa.com/blog/5-alternativas-al-plugin-revolution-slider-en-wordpress.html

¿ El multisite es solo por el tema del idioma ?

Tienes varios plugins para configurar los idiomas en wordpress, uno de los mas utilizados es WPML
-> https://wpml.org/

El plugin es de pago pero por su facilidad y opciones vale la pena:
-> https://www.webempresa.com/blog/traducir-wordpress-varios-idiomas-que-plugin-usar.html

Como alternativa gratuita tienes polylang
-> https://es.wordpress.org/plugins/polylang/

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 13/08/2018 1:31 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Angie
 Angie

Hola Pepe,
¿ Qué problema es el que tenias por si podemos solucionarlo ?
No podía acceder al administrador de la página clon y a ninguna de las sites. Cuando ponía la dirección mas /wp-admin me daba error. Lo reporté en un ticket y me contestaron lo que te he enviado. Que era ese plugin.

¿ El multisite es solo por el tema del idioma ?
Sí. Valoré utilizar el WPML aunque fuese de pago pero leí que pesaba mucho, que hacía la web más lenta. En cuanto al polylang, para woocommerce ví que tenía que comprar otro plugin para adaptarlo así que lo descarté.

ResponderCitar
Respondido : 13/08/2018 2:17 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Angie.

No podía acceder al administrador de la página clon y a ninguna de las sites
En principio no tendrías que tener problemas ya que lo soporta, si quieres puedes activarlo y lo revisamos.

leí que pesaba mucho, que hacía la web más lenta
El tema de el consumo mas bien es por que al ser un multisite tiene mas consultas hacia la base de datos, pero eso lo encontraras en todas las instalaciones multisite y con cualquier plugin de idiomas que añadas.

El plugin WPML a realiza muchas mejoras en este aspecto y la carga no suele ser muy pesada

En cuanto al polylang, para woocommerce ví que tenía que comprar otro plugin

Tienes gratuitos:
-> https://es.wordpress.org/plugins/woo-poly-integration/

Personalmente empezaría por probar el plugin gratuito y ver como se comporta, para la mayoría de los casos es mas que suficiente.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 13/08/2018 2:39 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Angie
 Angie

Hola Pepe,
He intentado activar el plugin RokSprocket para la web pero me da error (adjunto imagen). Quizá lo tendría que solicitar desde zona ticket?

De todos modos, en paralelo creo que crearé otro clon y pruebo con polylang. Porque en caso de pasarme a WPML, para esta web necesitaría versión MultilinguaL CMS ¿no?

Gracias

ResponderCitar
Respondido : 17/08/2018 10:59 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es común que te de error de rocksprocket por la verisón de PHP, asegúrate de tener la versión 5.6 y verifica.

Luego con respecto a WPML no necesitas multisitios para esto.
Para el plugin de Multilingual Press si se necesita tener multisitios

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/08/2018 7:13 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Angie
 Angie

Hola,
Voy a problar con el plugin polylang para woocommerce. ¿Tenéis algún tutorial? He revisado el foro y no encuentro nada.
Gracias!

ResponderCitar
Respondido : 05/09/2018 1:15 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

No tenemos un artículo de uso de ese plugin, sin embargo puedes revisar :

https://www.youtube.com/watch?v=VCLLxcYAFdI
(1/3 videos)

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/09/2018 6:00 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro